Poppet

Ultimate Traffic 2 Prepar3D v3 & v4

Recommended Posts

Update 29 \ 05 \ 17 

To Install for Prepar3D v4 Click the link below 

 

==============================================================================================================

==============================================================================================================

 

Introduction

Prepar3D v3  

 
This is a Tutorial to Install Ultimate Traffic 2 for Prepar3d V3   
 
Ultimate Traffic 2 was never Officially released for Prepar3D,  But there is a small work around to have you up and Running.
 
------------------------------------------
 
Important Information
 
I have Prepar3D V 3.2 Installed 
 
I will Not be using any other Tools to help me Install Ultimate Traffic 2 
 
I Do Not have FSX Installed and have Not added any FSX Keys in my Registry Editor.
 
------------------------------------------------------------------------
 
-----------
INDEX
-----------
 
 
(1)  Installing Ultimate Traffic 2 
 
(2)  Creating\Modifying your exe.xml file.   
 
(3) Configuring Simobjects.cfg  
 
(4) Modifying your Path
                                                                                          Click Pictures to Make Big 
(5)  Last words, Important. 
 
 
======================================================
 
Do Not Lanch Prepar3D Or The UT2 Control Panel Until you Complete all the steps outlined below.   
 
 
(1) Installing Ultimate Traffic 2 
 
The UT2 Installer will Specifically look for a fsx.exe during the Installation, If it doesn't see it,  The Install will be aborted.  I can work around this by Navigating to my Prepar3D folder and Copy and Pasting another Prepar3d.exe and Renaming it to fsx.exe
 
1 Right Click on Prepar3D.exe and Click Copy.     2  Go back outside your Prepar3D folder,  Right Click and Paste Directly into your Prepar3D folder. 3 Right Click on Prepar3D-Copy.exe and Rename it to fsx.exe
 
Please Note,  You will have to Leave the fsx.exe  (Copy) in your Prepar3D core  folder as the UT2 Control panel will Not work without it. 
 
25467285370_1ab146eb08_o.png
 
 
 
 
The Result 
 
25741919936_1a773f65b2_o.png
 
 
==================================================
 
 
 
 
Disable UAC and add the UT2 Installer to your Exclusions Zone 
 
1 Disable your uac User Account Control.  Type uac into your Search bar,  Drag down to Never notify and Click Ok.  
You will need to add the UT2 Installer to your Anti virus Software Trusted Zone or "Exclusions"  Zone 
 
25671322541_e5f0056293_o.png
 
 
===============================================
 
 
I will now Run the UT2 Installer.
 
1  Download the Installer.   If you have Never purchased UT2 before you can do it Now by filling out your Detail's.  If you already own UT2,  Just Click Reinstall.   2 Fill out your Account information and Password. 
 
3 This is the Default Location for the Installer Only,   This is Perfect,  Click Ok.
 
25645443082_754281021f_o.png
 
 
 
 
1 The Default Location will be C\Program Files\FSX,  You Need to change this,  Click Change.   2 Navigate to your Prepar3D folder, Just like the Image shows.   3 No Need for Changes here, Click Next.  
 
4  At this stage,  if the Installer does not see an fsx.exe the Install process will be aborted,  But as you can see ""The Installer has enough Information to Install UT2 On my Computer""
 
5 and 6  Ok Great  Installation Successful
 
25135963664_b0803845a9_o.png
 
 
 
 
You can have a peep in these Locations to see if everything Installed as it should
 
The Image on the Left shows your Prepar3D folder.
 
Effects You will have 3 Touch_Down effects in your effects folder
 
Flight One Software.  UT2.EXE will Install here 
 
Simobjects.  You will have 101 Items in your UT2 Aircraft folder
 
The second Image on the right located at     ► Computer ► Local Disk (C:) ► Users ► your user name ► AppData ► Roaming ►Flight One Software ► Ultimate Traffic 2 
In here you will have your  Plans, Timetables,  UT2Settings.cfg  I will be Modifying this at a later stage. 
 
25671323701_ed72b20d64_o.png
 
 
 
===========================================================================
 
 
 
(2) Creating\Modifying your exe.xml file. 
 
I have a fresh Install of Prepar3D V3,  So i Do Not have an exe.xml file yet located in AppData Roaming 
 
What is an exe.xml file
 
""The exe.xml file is used to specify Add On code that is launched or loaded by Prepar3D when it starts""    Basically this file Kicks the UT2.exe into play when Prepar3D starts.
 
If you have already an exe.xml you can skip to the next step.   
 
I could go to my SDK Kit and borrow one there,  but i will Create one instead and Manually add my "Header" code and my UT2 Launch Code.
 
Go to  ► Computer ► Local Disk (C:) ► Users ► you ► AppData ► Roaming ► Lockheed Martin ► PreparD v3
 
1  Right Click anywhere on a white bit,  Click New,  Click New Document.   2  A New Tex Document will appear, Right Click and Rename it to exe.xml.   3 Perfect
 
25740553886_8429b58652_o.png
 
 
============================================
 
 
Click on the Image and read the Tex,  Right Click on your New exe.xml file.   1  As you can see it will be Empty, Leave it open for now. The bottom Right Image shows what it should look like.
 
2 The "Header" Code will be at the Top, This is a Generic code and will look the same on all exe.xml files located here.   3 This is the UT2 Launch Code.  4 Also part of the "Header" Code, This will stay at the bottom  
 
5 This is My path, you will have to change it to Your Path.   In the next Post I will Post the "Header" Code and the Launch Code so you can Copy and Paste Directly into your exe.xml file
 
25645651242_217548eef1_o.png
 
 
You can Copy and Paste this Directly into your exe.xml file.  You have to change your Path,  I have Left ????,  Change this to Suit your Path 
 
<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Name>UT2</Name>
<Path>?:\????\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
<NewConsole>True</NewConsole>
</Launch.Addon>

</SimBase.Document>

 

==============================================

 
 
Right Click on Prepar3D.cfg and Rename to fsx.cfg.  This step is essential for the UT2 Control Panel to work
 
25740553766_e795ddb656_o.png
 
 
===============================
 
 
Click on fsx.cfg to open up and add this between [Main] and [Panel] Just like the Image shows.  Click File and Save it,  Also essential for the UT2 Control Panel to work correctly 
 
25465927430_bc8c97d084_o.png
 
You can Copy and Paste this 
SimObjectPaths.0=SimObjects\UT2 Aircraft

===================================================================

 
 
(3) Modifying your Path. 
 
Go here   Local Disk (C:) ► Users ► you ► AppData ► Roaming ►Flight One Software ► Ultimate Traffic 2 
 
As you can see the default path is to   \Microsoft\FSX\FSX.cfg.  
 
This has to point to    AppData\ Roaming \Lockheed Martin\Prepar3D v3\FSX.cfg   
 
So change it to  Lockheed Martin\Prepar3D v3\FSX.cfg.   Make sure you have the correctly spelling and Observe the spaces.  Click File and Save. 
 
25740553286_bb63f47ef8_o.png
 
 
 
 
========================================================
 
 
 
(4) Configuring Simobjects.cfg
 
Go here   ► Computer ► Local Disk (C:) ►ProgramData ► Lockheed Martin ► PreparD v
 
Click on Simobjects.cfg.  You will need to add an at the bottom.   Click the Picture and Read the Tex.  Be sure that you have the Numbers correct.  Click File and Save it
 
25671532041_8d61ca3ecf_o.png
 
You can Copy and Paste this into your Simobjects.cfg,  Make sure the Number is Correct 
 
[Entry.10]
Path=SimObjects\UT2 Aircraft
Required=True
Active=True

==================================================

 
Before I go any further,  I will go to my Main Prepar3D folder and Run UT2 as administrator  Go to  Prepar3D v3  ► Flight One Software ► Ultimate Traffic 2 
 
Right Click on UltimateTraffic2.exe and UT2Services,   Click on Properties,  Click Compatibility,  Tick the Box Run this Program as administrator and Click Apply.
 
You should also be Running Prepar3D as Administrator,  The same process as above.
 
25671531961_fa550ecff9_o.png
 
 
 
===========================================================
 
 
(5) Last words, Important
 
I still have the fsx.exe (Copy)  in my Prepar3D folder,  If I remove it,  My UT2 Control Panel will Not work.  Leave it there its fine   
 
When you start Prepar3D,  It will Generate another Prepar3D.cfg.  I will now have a Prepar3D.cfg and a fsx.cfg in AppData Roaming,   If i Delete the fsx.cfg,  My UT2 Control Panel will Not work. Leave it there its fine 
 
As Prepar3D has Generated another Prepar3D.cfg,  You will have to re adjust your Settings.  Do Not touch the Traffic settings,  As you can Not adjust the UT2 Traffic settings from inside Prepar3D. 
 
 
=====================
 
 I will Now open up my UT2 Control Panel, If you have followed the steps correctly, you should Not have any Errors when opening the Control Panel 
 
 When you Start Prepar3D,  You will the UT2 Music.  ♪ ♪  
 
  • Upvote 6

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks for this Elaine.

 

I did a fresh install of 3.2 last night and haven't installed UT2 with the migration tool. I think I'll try your way and see how it goes.

 

Mark

  • Upvote 1

Share this post


Link to post
Share on other sites

I have done that as well, but want to try the manual install.

 

Mark

  • Upvote 1

Share this post


Link to post
Share on other sites
 

Ok,  So i have Installed Ultimate Traffic 2.  As you can see from My UT2 Control Panel,  My Version is 2.09,  My Season is Summer 2010  (The Starter Pack) 

 


 

25164497514_4516f13d10_o.png

 

 

================================================================================================

================================================================================================

 

 

 

I will now Install the Summer\Fall Package 2013  (7 Euro) 

 

1 Select the Same folder as the the Previous Install.   2 Again this is the Default Install Path,  Click Change.   3 Select your Main Prepar3D folder 

  

25168453803_7d551efdec_o.png

 

 

 

 

When the Installation has Completed,  Right Click on your UT2 Control Panel, Run as administrator.  It will bring you through Several Updates and bring you up to Version Summer\Fall 2013 

 

25494410720_ac1fa1d307_o.png

 

 

 

 

Open your UT2 Control Panel and you will now see you have been Updated to Version 2.10.  My Season is now Summer\Fall 2013 

 

25700133141_989048d614_o.png

 

 

============================================================

 

 

 

Power pack

 

What is UT2 Power pack?   ""Create add-on schedules manually.  Airport modification.  Import downloaded schedules.  Share add-on schedules""

 

Installing Power Pack is the Exact same Process as outlined above 

 

Please Note:  If you going to use Power Pack with the Summer\Fall 2013 Package,  You Need to Install Power Pack Version 2.10.  Version 2.09 is Not Compatible with Summer\Fall 2013

 

 

============================================================

 

 

Errors 

 

Some very basic Errors you might Encounter

 

FSX.cfg Missing Error 

 

25700746051_65a9867152_o.png

 

 

Ok 2 things.

 

1 There is no FSX.CFG located in   ► AppData ► Roaming ► Lockheed Martin ► PreparD v3.  You can sort this by Renaming  Prepar3D.cfg  to  fsx.cfg.  

 

2  OR This Path has not been Correctly Modified.  Change this.  

 

 

25740553286_bb63f47ef8_o.png

 

 

============================================================

 

 

 

Flight Simulator X Missing Error 

 

25169217123_f441480d6a_o.png

 

 

There is No fsx.exe in your Main Prepar3D Folder.  If so Go back to the Start of the Tutorial and Follow step one.

 

It should be like this

 

 25741919936_1a773f65b2_o.png

 

 

================================================

 

 

InvalidArgument Error.

 

25169218373_884ffc174b_o.png

 

You Need to Change This SimObjectPaths.1=SimObjects\UT2 Aircraft

 

                              To this   SimObjectPaths.0=SimObjects\UT2 Aircraft    

 



SimObjectPaths.0=SimObjects\UT2 Aircraft


 

25465927430_bc8c97d084_o.png

 

 

 

 

 

  • Upvote 3

Share this post


Link to post
Share on other sites

Poppet, first and foremost thank you for putting all this together.  I have had UT2 for some time now and could not figure out a way to make it work in P3D without using the EMT.  I don't use that and didn't want to and really would of hated to use it just for UT2 so I was searching and came across your post.  

 

I did the steps for the manual install as you said.  When I start the UT2 Control Panel I am able to see all options, no errors and all seems to be running well.  I start P3Dv3.2 and I hear the UT2 Music playing, no errors.  My only thing is so far I have done two short flights(there were quickies just to test stuff out 15 min) so far and the only traffic I am seeing is a King Air.  I was in PNW at Friday Harbor and only seen one King Air South of me, then did the default flight at Eglin AFB in FL and only seen an additional three King Air.  Is there something I am missing here?

 

Now I will say this.  My P3D install was not fresh and I do have FSX and P3Dv2.5 all installed but they are on independent drives and I have checked both of them, no files leaked over or nothing of that sort and as I said all things seem to be in the right place.  I did do all the steps and as said I got no errors so far.  Only thing I did that you said not to do was I adjusted my traffic in P3D, reason being before I did the install of UT2 I had all my AI levels at 0.  So I went in and turned them up to 45 Commercial and 45 GA.  Still nothing!  I even went to the dummy FSX.CFG and changed the traffic values in there since they were 0 also and made them match my current ones.  Not sure where else to look.  Any ideas?

 

 

:::::UPDATE:::::: Still nothing as of yet, I have tried now going to the busiest airspace in the country around LAX and still have nothing.  No traffic at the gates and only airborne traffic is KA350.  I went and checked the tail numbers of the default KA that comes with P3D, FSX etc it's the same one really but one thing I did notice is all the Tail #'s of the ones flying are different on each one and don't match the default CFG file Tails for the KA.  So I am unsure where it is getting that information from. SMH, this is frustrating as I am so close but yet seems so far.

  • Upvote 1

Share this post


Link to post
Share on other sites

Now I am trying to fly online just to see if it would work since it did in FSX(I know this made for FSX) and it just keeps giving me a Simconnect error saying AI model matching set not installed in FSX.  Will continue to troubleshoot and if I can find a fix I will post it.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank You Soooo MUCH  Elaine.  I took the plunge after much research and comparing between UT2 and mytraffic6. I was an old traffic user and was looking for a change and your post tipped the scales for me. I am so satisfied everything went perfectly on the UT2 install following your post. Now I'm flying P3d V3.2 with my various payware airports, loving it. Nice models, night lighting the whole setup compared to MT6.

Next I'll get to adding more AI airplanes, paints and flight plans.

You really should pin this like you did for my traffic 6. I just happened to stumble on it but it was truely helpful.

  • Upvote 1

Share this post


Link to post
Share on other sites

​I believe this post should be pinned.  Great tutorial with visuals to help many of us install UT2 into P3D!

  • Upvote 1

Share this post


Link to post
Share on other sites

Not seeing any aircraft moving - weird

 

Estonia tool used not this method which would take me forever  :wink:

  • Upvote 1

Share this post


Link to post
Share on other sites

15 minutes max, Rich.

 

Worked perfect for me first time.

 

Cheers,

Mark

  • Upvote 1

Share this post


Link to post
Share on other sites

Guess I must of did something wrong then, or perhaps having FSX installed with Registry entries could be causing issues.  SMH at this point cause it seems to be working.  I got music at start, my UT2 Control Panel is working just fine but still no aircraft.  I have been messing with this for 8 hours now, sooo frustrating.  Glad others seem to get it to work though, obviously it is something I did.

  • Upvote 1

Share this post


Link to post
Share on other sites

So I am happy to report that my UT2 is now working in free flight and online via VATSIM.  So attention to detail is key for me.  This morning I went back through all the steps to see if I was missing something and in fact I was.  Actually it was not missing, I simply did not place it in the right area.  I noticed in Elaine's post where she was referring to the simobjects.cfg and the entry that needed to be made there.  So what I did not notice was that the path for that simobjects.cfg is in a different location.  I was a bit confused by that so I looked on my machine and could not find that folder named "Programdata".  But then it clicked to me this morning that on my machine that is a hidden folder, so I needed to go to my folder options and select "Show Hidden Folders and files" and wit that led me to the simobjects.cfg and the one entry that needed to be made which was adding line 10 in the CFG.

 

Yesterday when I did this process I did not see the simobjects.cfg in my main P3D folder and that is where I was confused so I created my own new one and dropped it in my main P3D folder and was wondering why nothing was happening.  It all turns out I simply was looking in the wrong spot, didn't need to create the file but simply find the one on my machine int he right location.

 

Again, happy to report all is well and my traffic is flowing like normal, FANTASTIC!

  • Upvote 1

Share this post


Link to post
Share on other sites

15 minutes max, Rich.

 

Worked perfect for me first time.

 

Cheers,

Mark

 

Thanks but I think I waited a lot more than 15 minutes :(

  • Upvote 1

Share this post


Link to post
Share on other sites

The ProgramData folder was a hidden folder, so I needed to go to my folder options and select "Show Hidden Folders and files" and wit that led me to the simobjects.cfg 

 

Yes, to complete this Install you will need to access the following folders, these specific folders (shown below) can be hidden sometimes in your C Drive. 
 
► Computer ► Local Disk (C:) ►ProgramData ► Lockheed Martin ► Prepar3D v3
 
 ► Computer ► Local Disk (C:) ► Users ► your user name ► AppData ► Roaming ► Lockheed Martin ► Prepar3D v3
 
To show these folders,  follow the steps below. 
 
Universally,  for windows 7 and 8 and 10 users,  open your Control Panel and follow the path. 
 
Control Panel ► Appearances and Personalization    Show hidden files and folders    3 Tick the circle, Click Apply and Ok
 
 
23445724373_3c3ae5170d_o.png
 
 
 
=======================================================================
 
 
 
The steps outlined below is a shortened checklist of the Tutorial,  Please read the Tutorial again for more detail on each item below  
 
 
Checklist  (In this order) 
 
Have you........
 
Copied and Pasted " a copy" of Prepar3D.exe in your main Prepar3D folder and renamed it to fsx.exe.  
 
Please Note:  You will have to Leave the fsx.exe (Copy) in your Prepar3D folder as the UT2 Control panel will Not work without it
 
 
 
============
 
 
 
Have you........
 
Done your Security checks?  Disabled the uac User account Control.   Added the Installer and the entire UT2 folder to your Exclusions of your Anti virus Software. 
 
 
 
============
 
 
Have you........
 
Checked your exe.xml file located in  AppData ► Roaming ► Lockheed Martin ► Prepar3D v3
 
This is what it should look like with 1 Add On (Entry)  As you can see i have left ?? were your path should be
 
Have you spelt your path exactly pointing to UT2,  including the -spaces- and the correctly placed \  
 
<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Name>UT2</Name>
<Path>?:\????\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
<NewConsole>True</NewConsole>
</Launch.Addon>

</SimBase.Document>
 
 
==========
 
 
Have you........
 
Renamed your Prepar3D.cfg  to  fsx.cfg also located in   AppData ► Roaming ► Lockheed Martin ► Prepar3D v3
 
This step is essential for the UT2 Control Panel to work
 
 
===========
 
 
Have you......
 
Modified your fsx.cfg by adding the line shown below between [Main] and [Panel also essential for the UT2 Control Panel to work correctly 
 
SimObjectPaths.0=SimObjects\UT2 Aircraft
 
=============
 
 
Have you......
 
Modified your path  in AppData ► Roaming ►Flight One Software ► Ultimate Traffic 2  ►UT2Settings.cfg 
 
By default the path is   AppData\Roaming\Microsoft\FSX\FSX.cfg.
 
You need to change to  AppData\ Roaming \Lockheed Martin\Prepar3D v3\FSX.cfg 
 
 
=============
 
 
Have you......
 
[Entry.10]
Path=SimObjects\UT2 Aircraft
Required=True
Active=True
  • Upvote 1

Share this post


Link to post
Share on other sites

Yep, a wonderful post Elaine.  I was frustrated yesterday but it was simply my attention to detail on that one hidden folder that cost me 9 hours of enjoyment but I am very happy all is well now :)  Thanks again for providing all this information so that we can enjoy our addons in P3D.

  • Upvote 1

Share this post


Link to post
Share on other sites

Not working for me either, I have followed the instructions to the letter, checked and triple checked and everything is in the correct locations but on start up get fsx.cfg is missing, managed somehow to cure that although it was correctly in p3d folder and now get flight simulator x missing!! Have tried everything including fresh install of p3d and Windows 10 at least 3 times but cannot get it working.

 

On one of my attempts I tried with migration tool enabled and that time got no error messages and altered ut2 interface to show max aircraft but on starting p3d got no ut2 music and sure enough no aircraft. What is really infuriating is that I had ut2 working fine in p3d version 2.5 but cannot for the life of me do so in 3.2.

 

Currently using version 3.2. 16769 and migration tool 3.2.9 1011 which is the latest version.

 

Any further suggestions gratefully received.

 

Ian

  • Upvote 1

Share this post


Link to post
Share on other sites

This Tutorial and the steps outlined in it are designed only for use Without any Migration Tool 

 

It could be a Windows 10 thing,  i don't know, i don't have Windows 10.  

 

If your using the Migration Tool,  get rid of it you Do Not need it.  Please Note:  when you Uninstall the Migration Tool it will still leave files at the bottom on your main Prepar3D folder,  you will know them by Date, Delete them. 

 

-------------------

 

Fusions 

 

If your not hearing any music and not seeing any aircraft i would first start at your exe.xml file,  can you Copy and Paste it here and give me wee gander at it  :smile: 

 

-----------------

 

 

 

flight simulator x missing

 

 

 

Flight Simulator X Missing Error 
 
25169217123_f441480d6a_o.png
 
 
There is No fsx.exe in your Main Prepar3D Folder.  If so Go back to the Start of the Tutorial and Follow step one.
 
It should be like this
 

 

 25741919936_1a773f65b2_o.png
 
 
 

===========================

 

 

fsx.cfg is missing

 

 

 

FSX.cfg Missing Error 
 
25700746051_65a9867152_o.png
 
 
Ok 2 things.
 
1 There is no FSX.CFG located in   ► AppData ► Roaming ► Lockheed Martin ► PreparD v3.  You can sort this by Renaming  Prepar3D.cfg  to  fsx.cfg.  
 
 OR This Path has not been Correctly Modified.  Change this.  
 
 
25740553286_bb63f47ef8_o.png

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Elaine,

 

I have currently deleted everything and have done a fresh install of Windows 10. I'm lucky as only use this computer for simming so I will start afresh tomorrow with installing p3d and then ut2 as until I have that working I won't install anything else. Will let you know either way how it goes and paste you my Exe.xml if needed.

 

One thing I am curious with is my p3d entry in my main folder doesn't show .exe extension as per your illustration just p3d but if you hover the mouse over the application it does show as exe. Could this be an issue?

 

 

Thanks for your help

 

Ian

  • Upvote 1

Share this post


Link to post
Share on other sites

Yes try it again without the Migration tool. 

 

 

 

 


One thing I am curious with is my p3d entry in my main folder doesn't show .exe extension as per your illustration just p3d but if you hover the mouse over the application it does show as exe.

 

lol  Yes i had that as well   :blush2:   Its Not the Issue though 

 

Go to your Control Panel,  Type folder Options into your search bar,  Click Folder Options Click View  Untick the box "Hide extensions for Known file types"  Click Apply  

 

25257438044_19abba890b_o.png

Share this post


Link to post
Share on other sites

Thanks so much for your guide, Elaine! It worked perfectly for me. I have the Migration Tool but I'd rather not install it if I don't have to.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi again Elaine,

 

Well I have done a new install of P3D and UT2 and this time I have got past the previous problems I had but now get the "This feature requires that smart assembly is available on this computer" error!!

 

Loading P3D I don't have the addons heading on the top where UT2 should appear either.

 

These are the settings I have done so far

 

Simobjects cfg.

 

[Entry.10]
Path=SimObjects\UT2 Aircraft
Required=True
Active=True

 

exe.xml file

 

<?xml version="1.0" encoding="Windows-1252"?>

 
<SimBase.Document Type="Launch" version="1,0">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>
 
<Launch.Addon>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Name>UT2</Name>
<Path>D:\Prepar3D v3\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
<NewConsole>True</NewConsole>
</Launch.Addon>
 
</SimBase.Document>
 
I have also changed everything else exactly the way you describe so when I start the UT2 control panel it loads without a problem, I'm just now getting the smart assembly error and no traffic.  Any further suggestions please??
  • Upvote 1

Share this post


Link to post
Share on other sites

Possible success!!

 

Had a flash of inspiration and ran the legacy simconnect files and problems appear to have gone! No error message and ut2 music plays and addons now appears with ut2 in it.

 

Haven't time now to fully test but will in next couple of days and report back any further issues.

 

Thanks for your help everybody and especially Elaine

 

Ian

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.