Sign in to follow this  
z06z33

P3Dv3 is causing strange PC issues

Recommended Posts

Ok here goes. Everything starts out normal, but then a few minutes into the flight the sim will stop accepting inputs from my rudder pedals, flowed by a beeping sound if I click anywhere with my mouse. I can still exit the program with the keyboard but even after the program has exited the system hangs and beeps if I click anywhere. If I try to shut it down it just hangs at the shutting down screen so the only way to reset it is via the switch. Here is where it gets really weird the keyboard and mouse say powered on even when the PC is off (they are back-lit) I have to either unplug the computer or wait a few minutes for them to turn off. When I turn the system back on half the USB ports don't work,this can be fixed by either resetting the PC again or unplugging it after the initial problem. I don't have this issue with any other program X-plane maxed out,GTA V maxed out,FSX, fallout 4ect Only p3dv3 and I never had this issue with V2. 

System specs

Windows 7 64Bit

I7-4790k @4.5ghz

GTX980TI

16GB Gskill ram at 1866mhz

2X1TB HDD's

1X120 GB SSD for OS

1X512GB for P3Dv3

Prepar3d V3.0

 

Thanks David

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Ok here goes. Everything starts out normal, but then a few minutes into the flight the sim will stop accepting inputs from my rudder pedals, flowed by a beeping sound if I click anywhere with my mouse. I can still exit the program with the keyboard but even after the program has exited the system hangs and beeps if I click anywhere. If I try to shut it down it just hangs at the shutting down screen so the only way to reset it is via the switch. Here is where it gets really weird the keyboard and mouse say powered on even when the PC is off (they are back-lit) I have to either unplug the computer or wait a few minutes for them to turn off. When I turn the system back on half the USB ports don't work,this can be fixed by either resetting the PC again or unplugging it after the initial problem. I don't have this issue with any other program X-plane maxed out,GTA V maxed out,FSX, fallout 4ect Only p3dv3 and I never had this issue with V2. 

System specs

Windows 7 64Bit

I7-4790k @4.5ghz

GTX980TI

16GB Gskill ram at 1866mhz

2X1TB HDD's

1X120 GB SSD for OS

1X512GB for P3Dv3

Prepar3d V3.0

 

Thanks David

 

Motherboard ? by the way why are you not using 3.2 waaaaaaaaay better

 

==============================================================

 

Found this might be worth a try

 

Well, last night when I shut the system down for the night the keyboard powered down.

 

I can only conclude that going into the bios and just saving and exiting somehow changed something.

 

Here's a stretch but maybe what affected it.

A day or so earlier I disconnected everthing and moved the tower so that I could add new case fans. When I reconnected everything maybe I put the mouse and keyboard back in opposite USB slots than they were in before. Maybe the motherboard detected the change in device for the keyboard that caused an issue. I don't know. Just saving and exiting the bios seems to have fixed it though.

Share this post


Link to post

Motherboard ? by the way why are you not using 3.2 waaaaaaaaay better

 

==============================================================

 

Found this might be worth a try

 

Well, last night when I shut the system down for the night the keyboard powered down.I can only conclude that going into the bios and just saving and exiting somehow changed something.Here's a stretch but maybe what affected it.A day or so earlier I disconnected everthing and moved the tower so that I could add new case fans. When I reconnected everything maybe I put the mouse and keyboard back in opposite USB slots than they were in before. Maybe the motherboard detected the change in device for the keyboard that caused an issue. I don't know. Just saving and exiting the bios seems to have fixed it though.

I don't think a failing mobo would cause this,I could see an unstable over clock but it's never given me an issue in other CPU intensive programs. I think it's an issue in p3dv3 corrupt data because somtimes the program just drops to desktop no warning,error or even a report in the windows logs

Share this post


Link to post

I don't think a failing mobo would cause this,I could see an unstable over clock but it's never given me an issue in other CPU intensive programs. I think it's an issue in p3dv3 corrupt data because somtimes the program just drops to desktop no warning,error or even a report in the windows logs

 

No its not a failing motherboard - looking in or refreshing bios may help - may have got glitched somehow - what is your motherboard ?

Share this post


Link to post

No its not a failing motherboard - looking in or refreshing bios may help - may have got glitched somehow - what is your motherboard ?

MSI Z97 Gaming 7. I'll try refreshing the bios. I tried to do the client update but the P3Dv3.2 crashes every time its about to finish loading so I guess its clean install time... Oh well it need one.

Share this post


Link to post

MSI Z97 Gaming 7. I'll try refreshing the bios. I tried to do the client update but the P3Dv3.2 crashes every time its about to finish loading so I guess its clean install time... Oh well it need one.

 

Ok thanks - cant see how P3D would cause hardware issues but you never know - checking on your motherboard now - I would assume you have moved around your hardware positions and its only doing this in P3D ?

Share this post


Link to post

Ok thanks - cant see how P3D would cause hardware issues but you never know - checking on your motherboard now - I would assume you have moved around your hardware positions and its only doing this in P3D ?

Thanks Rich

Share this post


Link to post

Thanks Rich

 

Keep getting check you bios on search - did you move hardware and place in different usb positions - just because it happens in P3D doesnt prove its P3D as thats when your controllers are being used and the problem presents itself only till then - your going to have to go thru it before resorting to a new install

 

Remove all usb controllers for p3d and see if the problem persists that should rule out p3d if the problem is gone - use keyboard to control aircraft - only have a mouse and a keyboard connected to do this - let me know - thanks

Share this post


Link to post

Keep getting check you bios on search - did you move hardware and place in different usb positions - just because it happens in P3D doesnt prove its P3D as thats when your controllers are being used and the problem presents itself only till then - your going to have to go thru it before resorting to a new install

 

Remove all usb controllers for p3d and see if the problem persists that should rule out p3d if the problem is gone - use keyboard to control aircraft - only have a mouse and a keyboard connected to do this - let me know - thanks

Well I've been up flying now for about 10 minutes with no issues. I updated to 3.2 and deletedo my shaders. I'm starting to think I may be overloading the pc with usb inputs I have 15 devices plugged into it. I know there has been a few time that the PC wouldn't even boot until I unplugged the goflight radio panels

Share this post


Link to post

Well I've been up flying now for about 10 minutes with no issues. I updated to 3.2 and deletedo my shaders. I'm starting to think I may be overloading the pc with usb inputs I have 15 devices plugged into it. I know there has been a few time that the PC wouldn't even boot until I unplugged the goflight radio panels

 

15 HOLY @#@$ that would have been an easy answer if you stated that to begin with - yowser 

 

The blaming of P3D is getting old - not you Dave :wink:  constantly seeing posts claiming P3D is the problem its not  -  thought I would throw that out there and off topic - sorry

Share this post


Link to post

15 HOLY @#@$ that would have been an easy answer if you stated that to begin with - yowser 

 

The blaming of P3D is getting old - not you Dave :wink:  constantly seeing posts claiming P3D is the problem its not  -  thought I would throw that out there and off topic - sorry

The odd thing is I use them in FSX without issue and have used them in p3dv2.5 without issue. Somthing in V3 doesn't like them.

Share this post


Link to post

The odd thing is I use them in FSX without issue and have used them in p3dv2.5 without issue. Somthing in V3 doesn't like them.

 

Interesting going to be a hard one to diagnose - guess you could add one at a time and see maybe which device is causing an issue and moving them to different spots - good luck

Share this post


Link to post

I have same motherboard with windows 10 64bit and have similar problem.

mine is caused by my Saitek Cessna trim wheel. I have to wake the trim wheel every time I boot the system or I will experience the situation described here.

I now make sure to turn the trim wheel a few times before starting pp3d. That seems to have taken care of it.

Share this post


Link to post

This might or might not work but its worth a try.

 

Turn on legacy support for USB in the bios if it isn't already turned on.

 

Next go to power settings in control panel - system and find your power plan. Go into settings - change advanced settings find USB selective suspend and disable it.

 

Regards,

Shanan

Share this post


Link to post

The odd thing is I use them in FSX without issue and have used them in p3dv2.5 without issue. Somthing in V3 doesn't like them.

That's like saying it works under Windows but crashes on Linux.

 

P3D is NOT FSX - just because it worked in FSX is NO guarantee that it will work in P3D.

 

The sooner we all get used to that the easier it will be to track down issues.

 

Vic

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this