Sign in to follow this  
angeli662

Any Help for DX10Fixer and Rex TD/SOftCloud?

Recommended Posts

After many months trying to figure it out why is this happening with the sun glare, I decided  to uninstall DX10Fixer and revert  to DX9 and the issue went away. Of Course if there isn't a solution I still will keep the fixer.

below is a video of the issue.

 

Thanks

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Try disabling the glare and red outs in the Fixer

dx10glare.jpg

Share this post


Link to post
Share on other sites

To add to this.

 

In fsx sp2 the tick box in fsx settings seems to control dx10 preview on/off and also sun glare on/off - there should be another tick box!! In sp1 the tick box controlled sun glare on/off for dx9 which was the only support directx version.

 

So in sp2 you can have

 

Dx9 with sun glare off

 

Dx10 with sun glare on

 

The setting Glynn describes is a workaround in the fixer to prevent the sun glare from being visible in dx10.

Share this post


Link to post
Share on other sites

Steve, just to be clear the problem is with the DX10 and not with RexTD?

 I did ticked the hide glare and I see very faint glare still/

Is there any other trick I could try? 

 

Thanks

Share this post


Link to post
Share on other sites

It's very difficult to know with a video or picture what exact problem someone perceives.

 

When you look directly at the sun fsx greys out the screen. This fsx feature is broken in dx9 (cannot be turned on) and cannot be turned off in dx10 . The fixer compensates for this if you tick the option.

This is the thing that Both Glynn and I saw and have commented on.

 

There is another thing in your video that the sun is slightly distorted near the edge of the screen. it's the alignment of the corona, close sun glare texture and sun itself which are slightly out. This is a fault in the dx10 fsx engine but can be reduced by editing the sun texture. There are some old posts on here on the subject.

 

Both these issues would appear the same without a cloud in the sky.

 

It's hard to see from the video why you are referring to clouds , perhaps you perceive some other issue?

Share this post


Link to post
Share on other sites

Hi Steve the only issue I see is the sun glare not following the sun path, if  I face the sun straight out the glare centers but when I turn the glare moves faster then the sun. There is no other problem other then that.  The other effect in the video is because I capture with my cell.

Here another video I made a while ago to show Rex support this issues with varius sun:  Thanks again...

 

 

Share this post


Link to post
Share on other sites

I think thats an issue with the sun effect.cfg. I found a post in the dx10 discussions forum where you had a similar issue in Jan 2015 and you reverted to an old sun effect.cfg to deal with it.

 

This thread is the best explanation, it's clearly a dx10 issue with zoom levels and the drawing of the stack of sun textures from some sun effect.cfgs

 

http://www.avsim.com/topic/434255-problem-with-the-sun/?hl=%2Bcorona+%2Bdx10#entry2922731

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this