Sign in to follow this  
AviatorMan

Update from V3.0 to latest must do all interim versions?

Recommended Posts

I have been running P3DV3 since it came out in March without issues, but have now decided to install the latest version which I believe is V3.3 I Intend to install only the client as set out in the pinned topic. I haven't installed V3.1 or V3.2. Does V3.3 include everything, or do I need to install the interim versions?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I Intend to install only the client as set out in the pinned topic. I haven't installed V3.1 or V3.2. Does V3.3 include everything, or do I need to install the interim versions?

Client update will not be enough. You have also to update Content, otherwise you get problems with the menus of 3rd party addons such as GSX and Sode. You can update from 3.0 directly to 3.3

Share this post


Link to post

I updated client only. NO problems with 3rd party addons such as GSX and Sode. But I went from 3.2 to 3.3.5.

Share this post


Link to post

V3.0 to 3.2 updated both the Client and Content so you will need to update both if going from V3.0.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this