Sign in to follow this  
FlightSimDimm

Autogen Tree Shadows - Strange rendering behavior.

Recommended Posts

Hello All -

 

I have been witnessing a strange behavior on my Prepar3d 3.3.5 with the rendering of the autogen trees and their shadows. It has because even more pronounced since I started using the Prepar3D Tweak Assist (PTA) since it darkens up the shadows. I have already confirmed that it does the strange rendering using the standard shader files.(so PTA is not to blame)

 

I am a low and slow pilot, flying generally over the Pacific Northwest with my autogen trees maxed out. I recently turned on the autogen tree shadows and really liked the additional depth and realism that it added to the sim.

 

What I noticed now while flying around and above the treetop level, is the rendering or almost like painting of the shadows popping up on individual trees in front of me. It seems to be worse when I am flying into the sun and the shadow would be on the side of the tree I am flying toward. It reminded me of the old autogen popping up.

 

I spent 5 hours yesterday (my wife thinks I'm nuts) trying all sorts of shadow changes (shadow distance, shadow quality, cfg file settings), disabling SLI, dropping back to driver 361.43 (Rob's recommended driver), restoring the original shaders, etc. and still get the same behavior. 

 

Has anyone else seen this? Any recommendations on minimizing the effect or fixing?

 

Thanks,

Daniel

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Without any screenshot it is rather hard to get what your problem is all about. A guess: do you also have "receive" shadows for the autogen trees activated? Might be simply that? I also have all shadow options activated for my VFR flying and so far did not recognize any unusual behaviour, but probably I simply missed it...

Share this post


Link to post

Without any screenshot it is rather hard to get what your problem is all about. A guess: do you also have "receive" shadows for the autogen trees activated? Might be simply that? I also have all shadow options activated for my VFR flying and so far did not recognize any unusual behaviour, but probably I simply missed it...

 

Hi - unfortunately a screenshot would not show it. Yes, I have the receive shadows ticked on. I noticed the behavior everywhere but was flying mostly in Orbx PNW, Cascade Locks Airport. I do have Orbx HD trees installed but cannot image that is the issue since all the trees in all the default scenery have the same strange shadow drawing. 

Share this post


Link to post

I still get shimmering autogen shadows if I turn them on.

Share this post


Link to post

I ran a quick test with just base P3D 3.3.5 and FTX Global only ... no HD Trees, no PTA ... nVidia drivers 368.39.  Unfortunately I wasn't able to replicate your issue?

 

Can you provide a video that demonstrates the problem?

 

Cheers, Rob.

Share this post


Link to post

 

 



Can you provide a video that demonstrates the problem?

 

Thanks Rob - I'll put together a video this evening.

Share this post


Link to post

I've not noticed anything like you describe, but that vid would help get a full handle on what you're seeing. I'm running Orbx HD Trees along with PTA and all shadow option ticked, except non flagged (or whatever it is) and all shadow sliders at mid point. The only thing I see that is less than ideal is some shimmer from the blocky nature of the shadows in the mid to far distance.

 

Standard tree autogen has a horizontal texture that pops up at close range, but Orbx HD trees do not have this texture, unless you have not ticked them in FTX Central, or the install went wrong, and you are still running default Autogen by mistake.

 

Nv driver version 368.69 btw.

Share this post


Link to post

The only other thing I can think of is clipmode ... are you running EZDok or some other product that adjusts cameras (Opus)?

 

Cheers, Rob.

Share this post


Link to post

 

 


The only other thing I can think of is clipmode ... are you running EZDok?

 

No EZDok installed. My add-ons are only payware like Orbx, Opus, and UT2.

Share this post


Link to post

Ok- here is the video. I run 3 screens and used ShadowPlay to make it. The end of the video has my setting. I have not changed anything from in the cfg file for the shadows.

 

Notice in the center of the screen, the shadows pop into view on the individual trees as I fly over the treetop level. If you cant run the video across three screens, then try running at half speed. You can clearly see the tree shadow behavior in this. Best played on an iPad and double click the screen to zoom in full screen.

 

https://drive.google.com/file/d/0B2D1Nes8ShkLLUVWczJUWGpGZzQ/view?usp=sharing

 

Thanks for looking at it... I'm baffled...

Share this post


Link to post

Ok, now in the video it is clearly visible and this again let me think of the relevant option influencing this is: "receive shadows". Did you try with "receive shadows" for trees on off? It looks to me as this what you see here is the shadow of the tree casted on itself is displayed sometimes to late or later than the rest, that's why it looks popping. I am almost sure that it is the shadow casted from one of the tree sprites to the other (trees are basically two sprite textures combined in a 90° cross if looking exactly from above).

Share this post


Link to post

It seems to be a design limitation of the shadow system on autogen trees. There must be a hard coded distance limit that is not affected by the settings sliders. I've just done a similar tree top scraping flight in your video and see the same thing, and it is more noticeable depending on the position of the sun, as the shadows are in front of the object and you therefore see them being drawn. It might be possible to tweak the draw radius, but obviously performance would suffer badly.

 

BTW play any PC game and you will see very similar shadow drawing as you move. Shadows are very demanding to render, so there has to be a limit.

Share this post


Link to post

BTW play any PC game and you will see very similar shadow drawing as you move. Shadows are very demanding to render, so there has to be a limit.

 

It happens in X-Plane and Aerofly FS 2 which use a similar shadowing system. Pretty sure I've also seen it in GTA 5. Realtime rendered shadows work great in a confined space such as a first person shooter where the maximum distance is perhaps a few hundred meters at most. However it becomes problematic when you want to apply shadows to an entire outdoor scene with a draw distance of perhaps 50 miles.

 

Increasing the draw distance reduces the apparent resolution of the shadows, unless you also increase the resolution of the shadow maps (which impacts performance). Cascaded shadow maps help

 

However it's not enough for the extreme draw distance of flight sims.. So if they were to increase the tree shadow distance, the shadows would flicker and become pixelated instead. It's a tradeoff

Share this post


Link to post

It's a precision problem and no 64bit will not solve the problem.

 

I ran a quick test flight last night on my main sim PC and distance mapping precision was apparent (note Terrain shadow precision seems fine), but I was NOT seeing the issue Daniel presented?

 

 

Have you done any tweaks to adjust the shadow maps or shaders?  Mine are very subtle, your video they seem too dark to me.

 

Cheers, Rob.

 

NOTE: tree shadows are pretty hard on the GPU, I don't typically operate with them On.

Share this post


Link to post

Hi Rob -

 

The prepar3d.cfg setting for the shadow entries have not been modified. I did use the PTA to darken the autogen shadows for the shaders and it is more pronounced now.  When I reverted back to the default shaders, it did the same thing, only less noticeable because they were lighter. I also have the receive shadows ticked for the autogen trees. I do not use any terrain shadows, just cloud shadows. I think my video has the setting at the end of it...

 

I am running 2 980GTX, SLI using 361.43. Behavior is there with or with SLI enabled.

 

Thanks.

Share this post


Link to post

 

 


am running 2 980GTX, SLI using 361.43

 

When you reverted back after using PTA, did you delete the shaders?  My settings are in the video also (I did see yours) and both autogen trees cast/receive were checked.

 

I installed the latest 368.69 drivers last night (used DDU 6.0.0.4 for a clean uninstall), deleted my shaders ... they seem as good as 361.43 (maybe even a little better).  Perhaps that's the difference?

 

If you can save your flight file using default Bonanza A-36 and provide a download link, I'll try that out without Terrain Shadows.

 

Cheers, Rob.

Share this post


Link to post

I did use the PTA to darken the autogen shadows for the shaders and it is more pronounced now.

Darkening the shadows does make it more apparent, and you have to fly towards the sun, which for the most part Rob did not do. I didn't see it to start with, but its there, and it has nothing to do with tweaks or your system, its just the way it is.

Share this post


Link to post

Hi Rob -

 

Yes, I manually deleted the shader files before retesting with the default shaders. I'll clean install the 368.69 drivers tonight and save a flight for you to download. Thanks.

 

 


Darkening the shadows does make it more apparent, and you have to fly towards the sun, which for the most part Rob did not do. I didn't see it to start with, but its there, and it has nothing to do with tweaks or your system, its just the way it is.

 

Since you can reproduce it as well,  did you use the Orbx HD trees or default? Does that make a difference?

Share this post


Link to post

 

 


Since you can reproduce it as well, did you use the Orbx HD trees or default? Does that make a difference?

 

Orbx HD. Maybe defualt trees hide it to some degree, with the horizontal plane texture. But I think the main factor is the extra darkening of PTA that brings the shadows out.

 

It certainly something I will tollerate, as you only really see it when scaping the tops of the trees.

Share this post


Link to post

Hi,

just to confirm - i see exactly the same effect.

 

Situation tested: Bonanza-300ft-170kts-straight and level-sun from the left side- 30fps locked-stable-v=0.2%

GTX970-368.69-4*SGSSAA-4*MSAA(p3d)-1920*1080

P3D v3.3.5-actual - no tweaks/mods - no texture adons

 

Ticking off the "receive shadows" for vegetation eliminates this effect - of course - but doing this, the vegetation doesn't receive shadows from the clouds too.... and those cloud shadows on the ground are an effect i dont want to miss any more.

 

Would be a really nice gift to see a solution for "receive shadows" enabled for vegetation....

 

Cheers

Share this post


Link to post

I did a clean install of the new 368.69 driver and still see them same shadow rendering issue on the autogen trees.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this