Sign in to follow this  
Meeko

Admin Privileges

Recommended Posts

I have Prepar3d v3, all was well with W7.

 

I have just upgraded to W10 and, as expected, have had my share of problems.  Saitek Pro Flight controls was one of them.  Problem was solved by FAQ over at Madcatz.  Another problem I’m having is this;  I’m not able to edit aircraft CFG files in order to install liveries.  When I go to save I get the message;

 

“You don’t have permission to save in this location.  Contact the administrator to obtain permission”. 

 

Everything I have installed in P3D has been “Run as Administrator” so I am at a loss to know why this is now an issue.  I’m sure there is an easy solution but I’m at my wits end trying to find it.  Is there a tick box somewhere, or a slider to adjust?  Any help would be appreciated.

                           

 

Bruce R

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Try running Notepad or whatever editor you're using as admin.

Share this post


Link to post

I'm already opening the CFG file in Notepad to edit it.  It's when I go to save my entry I get the message.  Very frustrating.

 

 

Bruce R

Share this post


Link to post

Did you install P3D into default ProgramFiles x86?

 

If so, I recommend you install P3D into a folder outside of that ... i.e. d:\Lockheed Martin\Prepar 3d v3.

 

Also turn UAC to never notify.  And finally make sure your account type is Administrator (Control Panel - User Accounts - User Accounts - change your account type ... make sure administrator is selected.

 

Cheers, Rob.

Share this post


Link to post

Thanks Rob.  Your last two suggestions - turn UAC to never notify, this has always been on the bottom (never notify), and "administrator" has always been checked. Your first suggestion is interesting.  P3D was installed into the default location Program Files X86.  I didn't realise P3D would have the same problems as FXS had.  Do you think the problems could be solved by installing directly into C:\ ?

 

Bruce R 

Share this post


Link to post

Thanks Rob.  Your last two suggestions - turn UAC to never notify, this has always been on the bottom (never notify), and "administrator" has always been checked. Your first suggestion is interesting.  P3D was installed into the default location Program Files X86.  I didn't realise P3D would have the same problems as FXS had.  Do you think the problems could be solved by installing directly into C:\ ?

 

Bruce R

 

When you say "directly to C:\" do you mean install to "C:\Prepar3D v3"? Installing to the root off you disk (without a "Prepar3d v3" folder) is a bad idea, but installing to a dedicated directory outside of Prpgram Files (or any other system rated director) is the recommendation.

Share this post


Link to post

It's not really a problem with P3D or FSX, it's just how Windows OS treats ProgramFiles under a different security context.  But yes

 

C:\Lockheed Martin\Prepar 3d v3   will work also, I'd recommend putting P3D on a different physical drive, but it that's not an option then anywhere outside of ProgramFiles x86

 

Cheers, Rob.

Share this post


Link to post

Definitely sounds like you have installed to the default "Program Files (x86)" location which is not a good idea with P3D.

 

I wouldn't recommend disabling UAC since it's a security feature. Without it, any program you run on your system can run with full privileges which is a huge security risk these days.

Share this post


Link to post

As others had already pointed out 

 

I'm already opening the CFG file in Notepad to edit it.  It's when I go to save my entry I get the message.  Very frustrating.

 

 

Bruce R

 

Yes, I understand the problem is when you try to save the file but what I suggested/asked was not if you're opening the file using Notepad but if you're starting Notepad as Admin. If you simply double-click the file you want to open that will not launch Notepad as Admin unless you configured Notepad to always be ran as Admin.

 

Making sure you're running Notepad as admin should help you save the file even when it's under the default Program Files (x86) folder for this time but as others have already suggested installing P3D outside the default Program Files (x86) folder is definitely the best thing to do or you will risk facing similar issues further down the road.

Share this post


Link to post

With W7 I had FSX installed in C:\FSX and P3D in it's default location in Program Files x86.  Everything worked just fine.  I took the plunge last week and upgraded to W10.  Immediately after that I decided FSX had come to the end of its life so I uninstalled it leaving P3D in Program Files x86.  Its only since then I've been having these problems.  So thanks gents ..... I'll take on board your advice and uninstall P3D and relocate as C:\ Lockheed Martin \ Prepar3D V3.  A job for next week I think.  Thank goodness for retirement; it's not a 5 minute job.

 

Richard A - thanks for the Notepad suggestion.  As a matter of interest how do you open a file in notepad as administrator.  I can't get my head around that one.

 

Regards

Share this post


Link to post

Hi there Bruce and you're most welcome!

 

Running Notepad as admin is actually very simple, just right-click the Notepad shortcut/icon and pick the 'Run as admin' option from the context menu.

 

Then you open whatever file you like by going to the file menu in Notepad and browse to the location of the file.

 

Doing it like this you should have no issues saving the file regardless of its location.

Share this post


Link to post

Richard - After your first reply I went into notepad on my desktop, right clicked and opened properties / shortcut / advanced and clicked on the "Run as Administrator".  Then tried to edit an aircraft cfg file again.  I still had the same problem.  I still had to "contact the administrator to obtain permission".  That's what was confusing me.  Hopefully it's all academic now because P3D has been uninstalled.  Today's a new day, 0830 here in NZ, and I'm about to start installing into C:\LM\Prepar3D. 

 

It's quite surprising how things accumulate over the years.  I have 50 - 60 scenery packages and 17 aircraft addons to install.  It will keep me in doors all day.  Just as well because the whole country is being hit with a cold blast today.  Woke up to snow all around the hills.   

 

Regards   

Share this post


Link to post

Richard - After your first reply I went into notepad on my desktop, right clicked and opened properties / shortcut / advanced and clicked on the "Run as Administrator".  Then tried to edit an aircraft cfg file again.  I still had the same problem.  I still had to "contact the administrator to obtain permission".  That's what was confusing me.  Hopefully it's all academic now because P3D has been uninstalled.  Today's a new day, 0830 here in NZ, and I'm about to start installing into C:\LM\Prepar3D. 

 

It's quite surprising how things accumulate over the years.  I have 50 - 60 scenery packages and 17 aircraft addons to install.  It will keep me in doors all day.  Just as well because the whole country is being hit with a cold blast today.  Woke up to snow all around the hills.   

 

Regards   

 

Interesting when we have one of the best summers here in Sweden with somewhere between 25-30C almost every day now :wink:

 

Strange you were not allowed to save the file using Notepad after configuring it to be ran as admin but maybe it's because you don't have UAC disabled or something else. Not a big deal though now that you already reinstalled P3D in another location.

 

Good luck with the rest of the reinstallation!

Share this post


Link to post

Definitely sounds like you have installed to the default "Program Files (x86)" location which is not a good idea with P3D.

 

I wouldn't recommend disabling UAC since it's a security feature. Without it, any program you run on your system can run with full privileges which is a huge security risk these days.

 

Been running every flight sim I have had on x86 location and never had one issue. Just requires about 20 seconds of reading to understand how admin permissions work. 

 

 

Richard - After your first reply I went into notepad on my desktop, right clicked and opened properties / shortcut / advanced and clicked on the "Run as Administrator".  Then tried to edit an aircraft cfg file again.  I still had the same problem.  I still had to "contact the administrator to obtain permission".  That's what was confusing me.  H

 

The account you are using, is it admin?

Share this post


Link to post

Thanks for replying Bob.  Yes the account is 'admin'.  I was using W7 and had both FSX and P3D V3 installed.  FSX was installed in C:\FSX and P3D in the default x86.  Everything worked perfectly.  Just last week I upgraded to W10.  I then decided, as I was not really using FSX anymore, to un-installed it.  I later found I couldn't edit files in P3D such as an aircraft cfg file.  On suggestions in this topic I un-installed P3D and re-installed in C:\LM\Prepar3d V3.   Now everything is back to working perfectly again.

 

It's quite strange how this happened after upgrading to W10.  Everything I have installed in both flight sims has been as an administrator so I guess it should have continued to work in W10.  But that's computers for you.  Problem has been sorted thanks.      

Share this post


Link to post

 

 


But that's computers for you.

 

Glad it's now working for you.  Yes Microsoft works in ways only they understand (they certainly do NOT listen to feedback) ... can't wait to see what the Windows 10 August 2nd major update brings in the "nothing works anymore" category ... I just hope Microsoft fix the legacy device USB bugs and Explorer context menu delay bug if you have a USB device that can go into sleep mode.  Everything else in the August 2nd update appears to be aimed at mobile computing and nothing desktop users will benefit from.

 

Happy flying.

 

Cheers, Rob.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this