Sign in to follow this  
RayHff

Recover Joystick Button Assignment

Recommended Posts

All of my joystick button assignments are set to my liking.

 

One particular aircraft changes those button assignments (a second one has also in the past).

 

If I load a different aircraft, it does not revert back to my button assignments.

 

If I do a reset controls to default, it goes back to FSX's original assignments.

 

The only way I can get back to my assignments is to complete close FSX and restart it.

 

After using such an aircraft, how can I recover my settings without exiting FSX?

 

Any help is appreciated.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

As a test, try changing aircraft and also a new starting airport and destination (basically creating a new flight). 

 

See if that will restore your view settings that are controlled by your joystick buttons.  Other than that, I

 

think you may be stuck doing the FSX shutdown and restart.

 

OK, saw at the other site that you tried it and no go.  Looks like restarting FSX is the only solution.

Share this post


Link to post
Share on other sites

Once lost, there isn't any way to recover Joystick settings.  Unfortunately there are times when, for no explicable reason, settings are removed and go back to default. This seems to occur when Saitek drivers are installed (at least I haven't seen it with other controller drivers).  We had numerous people have this problem in the group I ran, as well as having it reported by a number of other people - but only for a time. I don't know anyone who's had the problem recently, leading me to wonder if a Windows update may have resolved this. 

 

Anyway, what you can do is copy the file name "Standard" from the Controls section of your FSX / P3D Roaming directory, and copy it back anytime you loose your settings.

 

Best wishes.

Share this post


Link to post
Share on other sites

Good to know.

 

I've noticed anytime I rebuild the FSX.cfg all my assignments get lost. Surprised me since the assignments aren't defined in the cfg but seems to happen if I let the sim build a new one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this