Sign in to follow this  
allergiecheck

CTD after upgrading to 4K Monitor

Recommended Posts

Hi,

I am using P3D 3.2 on a Win7 machine (4,5 GHz OVC, 16 GB RAM) with Nividia GTX 780 Ti with 3GB RAM. My old monitor was an ultra wide screen with 3440 x 1400, and I never had a CTD with this setup.

Now I have upgraded to a 55 inch TV with 4K resolution, and experience a CTD after about 3-5 minutes of every flight, no matter which plane. I am using ORBX scenery. In the event log, the panels.dll is mentioned as the cause of the CTD.

Would it help to upgrade to a better video card, lets say a GTX 980 Ti with 6 GB?

Thanks, Thomas

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Thanks Stefan,

 

I still stink it has something to do with graphics, since I did not have this error before...and I just changed the Screen resolution, nothing else. Also, I have no problems in less demanding areas. 

Share this post


Link to post

Thanks Stefan,

 

I still stink it has something to do with graphics, since I did not have this error before...and I just changed the Screen resolution, nothing else. Also, I have no problems in less demanding areas. 

 

Well... Normally the resolution does only add to more VRAM usage.

I also switched to 4K some time ago and did not have any trouble. Really strange. I guess the link above did not help?

 

As you said: It must be in connection with your switch to 4K as you did not change anything else.

 

Can you run 1080p on your new monitor and do a flight to see if something strange happens?

 

Which plane are you using? And which other addons?

Share this post


Link to post

Thanks Stefan,

 

I still stink it has something to do with graphics, since I did not have this error before...and I just changed the Screen resolution, nothing else. Also, I have no problems in less demanding areas. 

 

Did you check that the old 3440x1400 res is not still in the p3d.cfg file?

Maybe delete both p3d.cfg and Shaders folder and see what happens.

 

gb.

Share this post


Link to post

I assume you are using the latest drivers for your GPU? Make sure to do that, robot the computer, and delete the shaders folder in P3D. Also, make sure that your resolution and refresh rates in Nvidia control panel match your screen's native settings.

Share this post


Link to post

I'd think that a quick way to check if VRAM was behind your problem is to force the sim to 1920x1080 resolution (it'll be a bit fuzzy on the TV) and see if the problem persists.

 

I use a pair of 6GB 980Ti GPUs, and I monitor VRAM usage on the LCD display in a Logitech G13 control pad.  In P3D (v3.3.5) I exceed 3GB of VRAM usage regularly at 4K resolution, so it very well could be posing a problem for you.  I rarely see >4GB VRAM usage--only at crazy high AA levels at 4K res...so perhaps an upgrade to a 4GB or better card would be a better fit.

 

Regards

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this