Sign in to follow this  
joepoway

Using Nvidia Inspector to Turn On Triple Buffering?

Recommended Posts

Recently I upgraded to a GTX-1070 G1 and a Samsung 40 inch 4K TV model 40KU6300 (runs at 30hz or 60hz - $450 Amazon price match at Best Buy) and couldn't be happier, no lag or latency issues what so ever even at 30hz.

 

I followed several suggestions posted by Rob A. and others to set it up based on my fps.

 

I'm running the TV at 30hz (it can run at 60hz or 30hz) with 4:4:4 Chroma.   (As an aside make sure font size is not auto increased by Win 10 that causes problems) 

I use 30hz because I maintain 40-55fps and want to take advantage of Vsync.

 

P3D settings  Unlimited with Vsync On and Triple Buffering On

 

I also use Nvidia Inspector set to 4XSGSSA to elliminate any shimmering with associated 4XMSAA in P3D, also set Preferred Max Performance in Nvidia Inspector.

Running the latest Nvidia drivers

 

With sliders pushed pretty hard and limited AI, A2A aircraft and all the Orbx goodies my GTX-1070 runs at ~70%  all is good (see all my system specs in signature)

 

Everything looked good but I was curious why I didn't see any recommendations to set Triple Buffering to On with Nvidia Inspector so I turned it On with Nvidia Inspector to see what would happen.

 

Well after turning it on in the P3D Profile of Nvidia Inspector along with the previous mentioned settings still as they were my GTX-1070 card load jumped to 100% pretty steady.

 

This makes me think Triple Buffering wasn't working when only set using the P3D in sim settings.

When I turned it Off in Nvidia Inspector leaving it on in P3D load dropped back down to ~70%

 

So I put it back on in Nvidia Inspector and reduced my SGSSA to 2X and matched that with 2XMSSA in P3D and now my load is ~75-80% and everthing looks good.

It's too soon to tell but I think from first look the smoothness in turns seems to be even better with triple buffering set On in Nvidia Inspector.

 

So my question: do we really have triple buffering working if we only set it to On in P3D and not in Nvidia Inspector which defaults to Off and I don't see any Application override for Triple Buffering.

 

My test seems to indicate it's not on unless something else is happening when it gets turned on with Nvidia Inspector causing my GTX-1070 to run much harder?

 

 

Joe

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

 

 


So my question: do we really have triple buffering working if we only set it to On in P3D and not in Nvidia Inspector which defaults to Off and I don't see any Application override for Triple Buffering.

 

Yes that`s correct, either enable it with the main NV control panel selecting the P3d profile or like you did with NI, i guess the Nvidia driver will not recognise the triple buffer call from P3d without you associating the exe with the provided P3d profile Nvidia made for LM.

Share this post


Link to post

And how about disabling TB in P3D UI then? Just in case, to make sure they don't confict when both TB are on. I would also measure the load again after disabling TB in P3D and enabling it in NVI.

 

Dirk

Share this post


Link to post

 

 


So my question: do we really have triple buffering working if we only set it to On in P3D and not in Nvidia Inspector which defaults to Off and I don't see any Application override for Triple Buffering.

 

Very interesting find.

You should ask over at LM forums.

Since almost everyone uses nvidia stuff, that would be a major blue if it is unknowingly turned off.

 

gb

Share this post


Link to post

My 980Ti driving a 40-in 4K Samsung runs about the same GPU load (50%) with the triple buffer setting in P3D on or off but GPU memory increased from about 2.4 to 3.0GB.  Not sure what the triple bufffering is supposed to look like if any different at all.

 

I did change the NVidia driver setting for max pre-rendered frames from app controlled to 3.

 

Running at 30Hz screen refresh, P3D frame rate limit 32 and VSync on with triple buffering.... it's smoother than anything I saw before getting my 4K TV.

Share this post


Link to post

Try turning it on using Nvidia Inspector at the Global level or in the P3D profile and see if your load changes.

 

Joe

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this