Sign in to follow this  
y4zz

Terrible Lag After Reformatting PC

Recommended Posts

Hello there,

 

I am having an Alienware M17 R2 with an external GPU(alienware graphics amplifier) running the Geforce GTX 980 windforce by Gigabyte. Before reformatting the PC, I had ### AI 2.0 scaled upto 20% and it had no impact on FPS everything worked fine.. I also had FTX global, FlyTampa DXB.

 

I have set my frame limiter to 30 FPS.

 

After reformatting, I was testing at LFPG(Default Scenery) airport:-

 

Initially, I thought that ### AI and FTX Global was the cause of FPS killing, so I removed ### AI at first and my fps was 18-25. I never got 30 FPS. Then I removed GTX Global, still the same.. Then I removed both and still the same. I was checking about the aircraft... I switched to a PA A380 and still the same..

 

I am using dX10 preview and fixer by steve and tried out this tweaking guide (link removed)

 

 

 

 

 

-Yajvan Mcdonald

Edited by Jim Young

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

In my experience, it's simply a case of setting up fsx over many months or years, applying various tweaks, optimising both fsx, graphics card tweaks and the system in general.

 

When I've reformatted, it's always a case of forgetting to optimise a tweak or two, forgetting how I previously had my graphics driver software set up or something like that.

 

I guess you've forgotten something along the way and will with time find what you have missed.

 

Best of luck, IAN

Share this post


Link to post
Share on other sites

In my experience, it's simply a case of setting up fsx over many months or years, applying various tweaks, optimising both fsx, graphics card tweaks and the system in general.

 

When I've reformatted, it's always a case of forgetting to optimise a tweak or two, forgetting how I previously had my graphics driver software set up or something like that.

 

I guess you've forgotten something along the way and will with time find what you have missed.

 

Best of luck, IAN

 

Hello Ian, thanks for your reply, please give me sometime and let me try it out.. thanx

Share this post


Link to post
Share on other sites

Ok, so  I have tried most of the tweaks for FSX for the past 4 months and I am tired of this(i.e, it is still the same now. No change is observed)....... I really need some help now...

 

add me on steam: VerticalBird

Display name: VerticalBird #UAEVirtual

Share this post


Link to post
Share on other sites

I really need some help now

 

I switched to steam edition recently, and after experimenting a lot and after reading complete steam changelog, my conclusion is that dovetail have done a great job - You don't need to tweak steam edition anymore. The only tweak i use is:

[bUFFERPOOLS]

Usepools=0

 

This helps fps and smoothness with complex airliners over payware scenery. It gives me fps boost in DX9 only - if you try it, water should be set to at least high 2x with this tweak to avoid flashing on autogen loading. There's no flashing with DX10, but also no fps boost.

 

No other performance tweaks are needed, highmemfix is added by default(coded, not visible in fsx.cfg), affinity mask is set by installer based on your CPU, other tweaks for better scenery loading are applied etc.

 

I'm not sure about one thing, it may be fixed by now - if your AI traffic(or other objects)are not visible / popping up when you are close, add SmallPartRejectRadius=1 under [sCENERY] section. There was a problem with some AI, this value was set to 4 in steam, default was 1 in fsx boxed. I don't use AI traffic now, so i can't check this.

 

About DX10, i allways had a better performance with DX9(probably becouse bufferpools tweak works in DX9 only), so i don't use it. You have a much better GPU then mine, so maybe your system can handle it better.

 

Another things to consider - i've found a post here on Avsim - there was a problem with Windows update service, at least for Windows 7. Even with updates set to manual or disabled, service was active and was using some important amount of CPU resources. I disabled it and i get about 4-5 more FPS at complex addon sceneries like Frankfurt or Heathrow - the only places where my fps goes down from 30(locked), so now i see 26-27fps instead of 22 and that is smooth enough. Just set Windows Update service to manual, that means it's not going to start with windows anymore, but it will be available if you need it.

 

Download scenery config editor https://sourceforge.net/projects/fs-sceditor/ After you install it, under menu go to "actions" and run "reset area and layer numbers and reorder the file". This should help scenery loading if you have many custom sceneries added. I do this every time after adding a new scenery.

 

Try to optimize your Windows here https://tweakhound.com/ I'm using it for years and it works great with FSX.

 

Hope this helps

Share this post


Link to post
Share on other sites

I switched to steam edition recently, and after experimenting a lot and after reading complete steam changelog, my conclusion is that dovetail have done a great job - You don't need to tweak steam edition anymore. The only tweak i use is:

[bUFFERPOOLS]

Usepools=0

 

This helps fps and smoothness with complex airliners over payware scenery. It gives me fps boost in DX9 only - if you try it, water should be set to at least high 2x with this tweak to avoid flashing on autogen loading. There's no flashing with DX10, but also no fps boost.

 

No other performance tweaks are needed, highmemfix is added by default(coded, not visible in fsx.cfg), affinity mask is set by installer based on your CPU, other tweaks for better scenery loading are applied etc.

 

I'm not sure about one thing, it may be fixed by now - if your AI traffic(or other objects)are not visible / popping up when you are close, add SmallPartRejectRadius=1 under [sCENERY] section. There was a problem with some AI, this value was set to 4 in steam, default was 1 in fsx boxed. I don't use AI traffic now, so i can't check this.

 

About DX10, i allways had a better performance with DX9(probably becouse bufferpools tweak works in DX9 only), so i don't use it. You have a much better GPU then mine, so maybe your system can handle it better.

 

Another things to consider - i've found a post here on Avsim - there was a problem with Windows update service, at least for Windows 7. Even with updates set to manual or disabled, service was active and was using some important amount of CPU resources. I disabled it and i get about 4-5 more FPS at complex addon sceneries like Frankfurt or Heathrow - the only places where my fps goes down from 30(locked), so now i see 26-27fps instead of 22 and that is smooth enough. Just set Windows Update service to manual, that means it's not going to start with windows anymore, but it will be available if you need it.

 

Download scenery config editor https://sourceforge.net/projects/fs-sceditor/ After you install it, under menu go to "actions" and run "reset area and layer numbers and reorder the file". This should help scenery loading if you have many custom sceneries added. I do this every time after adding a new scenery.

 

Try to optimize your Windows here https://tweakhound.com/ I'm using it for years and it works great with FSX.

 

Hope this helps

 

 

Hey mate, thank you so much(99e20 times!) for your help!. That actually worked!! 

 

 

Ok so let me tell how I solved this. I turned off DX10 and used only Bufferpools=0. That was the only tweak I used and I got back to normal.   Once again, thank you so much!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this