Sign in to follow this  
wde12

Saitek Rudder Pedal Toe Brakes

Recommended Posts

Greetings all,

 

This issue is not unique. I have seen it posted in multiple forums (through Google searches). Many of the posts gave conflicting information and were very dated (circa 2008). A search on this forum yielded nothing (although I may have missed something).

 

I am using Saitek Pro Rudder Pedals (and Yoke / Throttle quadrant FWIW). The button assignments are currently through FSUIPC. The calibration is through FSX. I have previously calibrated through FSUIPC, but there was an issue (I believe) with Windows. If I recall correctly, I had to recalibrate and even re-assign the whole setup each time I booted up Windows. Moreover, Pete Dowson at FSUIPC said that in general, calibrating through FSX is totally fine. 

 

The basic problem is that when I apply the toe brakes, some or all of that brake application remains on or applied, even after I release the toe brakes. The only way to fully release the toe brakes is to apply the parking brake, disengage, and re-start my taxi. I cannot figure out why it is doing this.

 

Some have suggested it's a problem with sensitivity and null zones. I have adjusted these settings in FSX too many times to count. It seems that no matter what I do, the problem remains. And FWIW, the pedals are configured properly (and I am using the Win drivers, not Saitek/SST/Madcats).

 

Anyone know the best solution? I am using Win7. Can use FSUIPC if needed. 

 

Thanks in advance

William 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Fsx > settings > controls > select pedals from drop down menu.

Check to see if any assignments are made through fsx control inputs and if so clear all as you have already done this through fsuipc and may have 2 inputs for 1 command confusing each other.

Share this post


Link to post
Share on other sites

I have also seen this with the Saitek pedals, but on my rig it seems to be aircraft dependent. Recently I have been flying the PMDG 737NGX and this aircraft handles perfectly and the brakes work perfectly. On some other payware aircraft I find it necessary to apply and release the parking brake to release the toe brakes. Wierd.

Share this post


Link to post
Share on other sites

Hi,

 

In FSX go to your main setting screen.

 

From the main setting screen click on the sensitivities icon

 

From the Controller - Sensitivities page click on the drop arrow next to the box called 'Joystick Type' in the  upper right of the screen, when the arrow is pressed a drop down menu will appear listing the game controllers connected to your PC.  In this list you will see the Saitek Pro Flight Rudder Pedals.

 

Click on this controller, on the screen you will see Simple and  Advance radio buttons, make sure the simple radio button is selected.

 

Just under and to the right of the simple button you will see two sliders, one marked Sensitivity - all axes and the other marked Null zone - all axes.  Move the sensitivity slider ALL the way over to the right and move the Null zone slider about 3% to the left, click OK and the toe brakes should now work.

Share this post


Link to post
Share on other sites

Hi William,

 

Have you tried reversing the axis?

 

I use FSUIPC & unless I select the reverse axis box my brakes remain on.

 

Ross

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this