Sign in to follow this  
jay281

FAO: G-Sync Monitor Users

Recommended Posts

Hi All,

 

Whilst messing around in Nvidia Profile Inspector i noticed that even tho i had G-sync to work in windowed mode set in NCP, it was not set in Inspector (showed fullscreen mode only). After correcting and applying the setting in Inspector i was amazed by the change in P3D smoothness especially when taxying around Payware Airports.

 

I also have triple buffering and V-Sync set to on in NCP and in P3D.

 

Kind Regards

 

James

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi James,

 

I do not use NVI so cannot compare: in NCP I keep V-Sync off, in P3D V-Sync / triple buffering off with unlimited frames (G-Sync obviously enabled in full+win).

Also pretty satisfied with what I see indeed (tearing, stutters).

 

Enjoy your flights then.

 

Cheers,

Share this post


Link to post

Hi,

 

You could download NVI and try it, if only you change that setting.  That said i was happy until i found out about the G-Sync setting in NVI.

 

Kind Regards

 

James

Share this post


Link to post

Hi James,

 

I abandoned GSync with P3D some time ago as I soon discovered that it was only effective when frame rates >=30 can be maintained. If your running sim is rarely heavily loaded then, of course, this is perfectly possible. Naturally I was disappointed at the time as I was not aware of this limitation at the time of purchase. However, on the plus side it works great with games! The only other game I'm aware of where GSync gets in the way is Skyrim. Skyrim runs very well without visual/audio artefacts using Adaptive (half refresh rate), Monitor = Fixed Refresh. Monitor has been set to always refresh at 120Hz.

 

However, that said, if I'm honest I often forget to activate GSync these days as everything runs very smoothly with it off. Still, it's nice to have that option.

 

Regarding P3D, I run Unlimited Frame Rate with VSync = ON and No Triple buffering.

Also, I use what many would regard as being a 'Maverick' setting of 21760 for Affinity Mask with Hyperthreading = OFF in the System BIOS. This gives me the greatest fluidity with with remarkably few long frames (micro-stutters). Just emphasises how each system can differ in the way it responds to settings and how important it can be to experiment until you find the best setup.

 

Regards,

Mike

Share this post


Link to post

 

 


Just emphasises how each system can differ in the way it responds to settings and how important it can be to experiment until you find the best setup.

 

+1  :Applause:

Share this post


Link to post

 

 


I also have triple buffering and V-Sync set to on in NCP and in P3D.

 

I thought the whole point of G-Sync was to be able to turn V-Sync off?

 

gb.

Share this post


Link to post

The point of G-Sync is for the monitor to respond to new frame timing when the frame rate drops below the set frequency. As Mike says currently they only drop down to 30Hz. Weirdly though P3D VSync setting is not the monitor refresh vsync, but synchronises the GPU timing from the game generated framerate.

Share this post


Link to post

I thought the whole point of G-Sync was to be able to turn V-Sync off?

 

gb.

 

Correct gb.

 

G-Sync enabled via NCP in full+windowed mode and V-Sync off in P3D works fine for me. You may experience little flickering (barely noticeable on my monitor) if your fps go below 30. If your system's able to maintain >30 fps, no flickering of any sort and no tearing even with V-Sync off and panning around like crazy.

 

Cheers,

Share this post


Link to post

...The P3D VSync setting enables the GPU to be limited to the monitor refresh, otherwise with Unlimited fps slider setting the frame rate will run above the monitor refresh rate with VSync off.

Share this post


Link to post

Hi,

 

Ive now dissabled V-Sync and Tripple Buffering (P3D), i only have G-Sync enabled Windowed+Fullscreen in NCP. But i also have the same setting in NVI. I truly believe setting windowed and fullscreen G-Sync in NVI is the key to maximising G-Sync through the full range. Before i had it set in NVI (by default it was set at fullscreen) i was still getting stutters.

 

As we know P3D runs a fake fullscreen.

 

Sorry if this isn't articulated well, im typing on my phone.

 

Kind Regards

 

James

Share this post


Link to post

Yes that's key to understanding how P3D works, there's only a desktop window or a full size window with borders and caption bar removed. The monitor VSync is tied to the desktop, this isn't controlled by the VSync setting in P3D display settings as I mentioned earlier.

Share this post


Link to post

Steve,

 

Thats why i mentioned that in the NVI profile for P3D G-Sync is set by default to fullscreen mode only. Even tho its set correctly in NCP.

 

Regards

Share this post


Link to post

Yes an astute observation    :smile:

Share this post


Link to post

After i changed it to fullscreen and windowed in NVI all was butter smooth.

Share this post


Link to post

Many thanks to the OP and others for the info on this topic!  Very timely for me as I have a 32" G-sync capable monitor on the way; I'm not buying it specifically for P3D but naturally I was hoping I might see some improvements there as well.  The tips and insight offered here will certainly be of help when I get down to configuring things.

Cheers! 

Share this post


Link to post

James (OP),

Can I ask in which part of NVI you are seeing the entry for G-sync being selected to fullscreen or fullscreen + windowed mode?  I have it set to both in NCP, but I'm only seeing entries for G-sync being on or off in NVI unless I'm just missing it; nothing for selecting the display mode.  I'm on driver version 372.70, if that makes a difference.  Thanks,

Kevin

Share this post


Link to post

Thanks for this post. I am fighting with P3D to get eid of the microstuttering and can't. Will test tonight.

Share this post


Link to post

James (OP),

Can I ask in which part of NVI you are seeing the entry for G-sync being selected to fullscreen or fullscreen + windowed mode?  I have it set to both in NCP, but I'm only seeing entries for G-sync being on or off in NVI unless I'm just missing it; nothing for selecting the display mode.  I'm on driver version 372.70, if that makes a difference.  Thanks,

Kevin

Kevin, 

 

You need to get the latest version of Nvidia inspector, download and check it out.

 

I too didn't see those G-sync items listed in NVI, yes they are in the Nvidia Control Panel

 

but when i got the latest inspector they are there.

 

Interestingly for me, they say exactly what is in the control panel i.e. full and window 

 

There appears to be 2 categories in the NVI setting, both of mine where set to fullscreen and windowed, so no mismatch for me.

Share this post


Link to post

Okay, updated NVI and now as you say the entries are there (and quite obvious!)  Also like you my NCP and NVI G-sync settings seem to track each other so no problems with them being mismatched so far.

 

Thanks for the heads up!

Share this post


Link to post

I'm having a lot of "barber-polling" issues with my monitor that uses G-Sync technology to help my GTX 970 nVidia card.  One suggestion made was that I increase my antialaising settings.  I'm not sure if I'm supposed to do that through nVidia Profile Inspector or through Prepar 3D or both.  Any help on increasing the settings appropriately would be welcome.  Thank you.  Scott :)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this