Sign in to follow this  
theskyisthelimit

P3D v3.3.5 to 3.4.9 possible issue with NOT updating the content (FSDT menus etc)

Recommended Posts

I recently did the update of the client to 3.4.9.. it was advised by many here, to just do the client, dont worry about the content or scenery portions. 

 

In fact, at one point, I acronis'd my image and decided to try the content update to see what would happen.. at first everything seemed fine.. then as i tested airplanes such as the Legacy.. they threw errors on effects missing, sound files missing.. as it appears updating the content actually removed those portions?

 

Unsure if in this case i could have just recopied the old content folder over the new and somehow had a good merging?

 

At any rate.. I found another issue.. hot keys for things like GSX and youcontrol, xpoi commands menu etc, will not work.  According to a few random notes i can find, it appears its because the content portion needs updated for these plugins to work correctly.

 

GSX.. customize aircraft works.. clicking show gsx menu by passing you-control does nothing.. 

XPOI,... show XPOI commands menu does nothing

COUATL .. show Youcontrol menu does nothing

 

 

 

Mine show up in the menu system, but the hot keys dont work or in some cases the windows dont pop up either, even when directly clicked..

 

Anyone else noticed this and found a workaround, perhaps avoiding content update?  Anyone found a way to update content without blowing up existing aircraft?

 

Does anyone know the specific list of folders affected by a content update?

 

 

Thanks in advance

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I always update client and content. No problems with GSX menus. Have you checked whether you have conflicting hotkeys in the controler section of P3D?

Share this post


Link to post

I always update client and content. No problems with GSX menus. Have you checked whether you have conflicting hotkeys in the controler section of P3D?

Yeah i'm not sure why my first attempt at a content update broke things.. ill have to check in the controller section and see if there is a conflict (control f12 etc).

edit: everything looks pretty default in keyboard settings to me.

 

Im assuming shift + contrl + f12 just brings up the aircraft config window from GSX customize aircraft?   (unclear like with KMEM what brings up the tower view from inside for fsdt or the keyboard commands view for XPOI)

 

Control + f11 should bring up xpoi commands (it doesnt) and Control F the youcontrol menu (it doesnt) (is there a click way to bring this up)?

Share this post


Link to post

Hi,

 

My understanding is before you update the content package you need to back-up your effects and autogen folders and when the update is complete, copy back the files (but don't over write) and add in the missing files. This could explain why you're having these issues. If you imaged your drive, try just going to your effects and autogen folder in the backup file and copy them back into your P3D folders.

 

M

Share this post


Link to post

Hi,

 

My understanding is before you update the content package you need to back-up your effects and autogen folders and when the update is complete, copy back the files (but don't over write) and add in the missing files. This could explain why you're having these issues. If you imaged your drive, try just going to your effects and autogen folder in the backup file and copy them back into your P3D folders.

 

M

 

Would it also affect Aircraft, Gauges, modules, simobjects, sound, and texture.. yeah ill redo the update and restore the folders without overwriting.. thanks for the tip

Share this post


Link to post

I referred to this guide http://www.avsim.com/files/file/87-avsim-prepar3d-guide/ and updated successfully from P3D 3.3.5 to 3.4.9 with no issues what so ever.

I suffered from g2d.dll errors in P3d all versions right till v3.4.9. refer http://www.avsim.com/topic/489722-p3d-v32-33-g2ddll-error-exception-code-c0000005-exception-offset-000d7803/page-4#entry3485627

 

Now my settings are quite high and no CTD's. Yes there are a few stutters but after being unable to complete any flight to occasional micro-stutteres; I welcome the latter any day!!

Share this post


Link to post

I referred to this guide http://www.avsim.com/files/file/87-avsim-prepar3d-guide/ and updated successfully from P3D 3.3.5 to 3.4.9 with no issues what so ever.

I suffered from g2d.dll errors in P3d all versions right till v3.4.9. refer http://www.avsim.com/topic/489722-p3d-v32-33-g2ddll-error-exception-code-c0000005-exception-offset-000d7803/page-4#entry3485627

 

Now my settings are quite high and no CTD's. Yes there are a few stutters but after being unable to complete any flight to occasional micro-stutteres; I welcome the latter any day!!

All good now, i uninstalled/backed up/updated and restored and the pop windows now work.

 

Thanks for the tips

Share this post


Link to post

I should add, that on the content update.. i backed up the autogen and then did the restore of that folder plus the other related content ones, telling it to NOT overwrite..

I thought this was done and good.. i did get fsdt menus etc.. however..

 

PNW was messed up autogen wise.. running ftx central 2 with a sync did NOT fix it in my case.. so i ended up copying WITH overwrite the autogen folder i backed up, and now it all looks good again.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this