Sign in to follow this  
bonchie

Bad stutters with the XP11 Demo?

Recommended Posts

Downloaded the demo to check out the new lighting and I'm getting bad stutters every two seconds or so.

 

I never had stutter or FPS issues with XP10 and it seems like between the stutters in XP11 the FPS itself is fine, so I don't think this is necessarily performance related. I can turn down settings and it still happens.

 

2500k at 4.6Ghz, 16 gigs of RAM, Windows 7, and a GTX 970 (4GB) is my system.

 

I updated my drivers to the latest but nothing changed. Tried turning Threaded optimization to off but no change. I haven't seen anyone else complain about this, so it's gotta be something weird with my system.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The first thing you could do is to set all rendering options to minimum and then increase them one by one to see if the stutters are related to one specific setting (useful even if you'll report it as a bug).

 

You could also try to show FPS (CTRL + SHIFT + F) and see if there are spikes in the CPU or GPU usage during stutters.

 

Maybe you'll have to report this as a bug.

Share this post


Link to post
Share on other sites

Frames show 38-45 FPS.

 

CPU is .025 and GPU is .018.

Nothing appears to be wrong with the performance except the stutters, which is why it's so weird.

Share this post


Link to post
Share on other sites

Have you set Threaded Optimization off in your nvidia control panel?

Share this post


Link to post
Share on other sites

Yeah, I said that in the OP.

Made no difference. I've tried all the obvious stuff. So if anyone has any more obscure suggestions, that'd probably be what I'm looking for.

I may just try a reinstall and see if something go corrupted.

Share this post


Link to post
Share on other sites

Ooops sorry did not read the whole post..   :fool:

 

How about Texture Quality, you have 4gb vram, make sure you have it one notch down from Maximum (uncompressed), 

Share this post


Link to post
Share on other sites

I tried all the lowest settings on all the sliders.

 

It doesn't appear to be performance related in a traditional sense. FPS are very high. Something else is going on.

Share this post


Link to post
Share on other sites

One last suggestion before you re-install.

 

Assuming you have a 60Hz monitor, have you tried to lock to Half-of-refresh?

Share this post


Link to post
Share on other sites

With beta 1 I have the same problem,I uninstall nvidia drivers and install the more old drivers that a can use with my GPU now is perfect.

 

Sorry for my english.I hope can help.

Share this post


Link to post
Share on other sites

Trying to love it...but like the OP bad stutters ...yes it is a Beta...but as soon as you put any clouds in you can kiss performance goodbye!

 

There is a bad pause every so often which I am sure LR are aware.  however I noticed that my i7 2600 OC 4.6 is being worked very hard ...69% all of the time on all cores!...not sure what my GC is doing 970 4GB.....a wait and see what happens..all sliders in the sim are not at max as that would be a non starter all set low or moderate.

 

The pain the pain!

 

will have to beef up the system but not until I see the finished product out then I will make the call...

 

All the best

 

Mark

Share this post


Link to post
Share on other sites

Wht about your nvidia controlnpanel 3d settings, can you share them? Do you have dsr enabled by any chance?

Share this post


Link to post
Share on other sites

Try clear skies and see if you still get the stutters.  I am getting them with default clouds but they go away when using either SMP v3 or xEnviro or with clear or mostly clear skies.

Share this post


Link to post
Share on other sites

ok this is weird!.following on from my earlier post.....just gone into my NCP and re set the x plane exe to default setting....started it in window mode full screen windowed with overcast...and wham! 30 fps? steady, so just tried full screen non windowed....30 fps steady!.....only thing I have set is thread optimisation to off as advised....yes it still has small stutters but that is to be expected it is Beta.. and I do not have the most powerful set up...but hey...this is so much better than what I was getting a few hours ago....

 

this sim could be just great once finely tuned to RTM version...looking forward to that!....

 

will keep doing my 15 min demo until I am comfortable with everything..

 

 

All the best

 

Mark

Share this post


Link to post
Share on other sites

ok this is weird!.following on from my earlier post.....just gone into my NCP and re set the x plane exe to default setting....started it in window mode full screen windowed with overcast...and wham! 30 fps? steady, so just tried full screen non windowed....30 fps steady!.....only thing I have set is thread optimisation to off as advised....yes it still has small stutters but that is to be expected it is Beta.. and I do not have the most powerful set up...but hey...this is so much better than what I was getting a few hours ago....

 

this sim could be just great once finely tuned to RTM version...looking forward to that!....

 

will keep doing my 15 min demo until I am comfortable with everything..

 

 

All the best

 

Mark

yes this happened to me also and seems the performance is improved by setting up 3d settings in nvidia control panel.

Share this post


Link to post
Share on other sites

One other point. HDR will cause a strain on a weaker system. GPU usage will skyrocket.

Share this post


Link to post
Share on other sites

One other point. HDR will cause a strain on a weaker system. GPU usage will skyrocket.

in my case highest HDR+SSAO is indispensable because it adds the occlusion which makes a big difference in the visuals, so i decided to put the reflections on minimal which still gives PBR and it looks great, higher reflections settings seems FPS consuming in my case and bit buggy at this stage.

Share this post


Link to post
Share on other sites

Like I said, it's not a normal performance issue where I'm just running things too high.

 

My system could handle HDR just fine anyway but I did try it off with no difference.

 

I'm gonna try an older nvidia driver and see if there's a difference. I have nothing set in Nvidia inspector but I did try some of the common suggestions and nothing helped.

 

I'll get it figured out.

Share this post


Link to post
Share on other sites

This might be a problem which is not even directly related to X-Plane but possibly something going wrong in your OS / Hardware.

A classic issue would have been, if you machine starts to swap for some reasons ... but with 16 Gbytes that shouldn't happen so quickly (but it depends ... if something else would gobble up most of the RAM on your PC, then swapping would be inevitable).

Or do you maybe have some problems with a virus scanner or other "security" software?

Share this post


Link to post
Share on other sites

in my case highest HDR+SSAO is indispensable because it adds the occlusion which makes a big difference in the visuals, so i decided to put the reflections on minimal which still gives PBR and it looks great, higher reflections settings seems FPS consuming in my case and bit buggy at this stage.

 

P3D was the same way reflections was a killer - but in low they still look great

  • Upvote 1

Share this post


Link to post
Share on other sites

I updated my drivers to the latest but nothing changed. Tried turning Threaded optimization to off but no change. I haven't seen anyone else complain about this, so it's gotta be something weird with my system.

 

Don't know about your system but I have similar problems with frequent long frames, what I did to get the FPS back to "normal" is bring up Settings and re-select the same graphics mode (in my case it was 3840 x 2160 60Hz) and return to flight.  I tried all the other settings, 1/2 refresh rate, set mode to single monitor performance, thread optimization on/off, etc. ... none of that help ... only re-selection of graphics res/hz made a difference.

 

Also, if I disable Vsync that can remove the stutters but I will get screen tearing.

 

This is with the new Beta 2 of XP11.

 

Still lots of issues, terrain shadows seem to follow my aircraft and still see lots of clipping of terrain from within the VC and the night time moon/gradient/banding ... but again this is still all Beta so hopefully all the kinks get sorted out.

 

Cheers, Rob.

 

 

in my case highest HDR+SSAO

 

I've tried HDR+SSAO and it works fine (no performance hit) outside of the VC, but as soon as I enter the IXEG VC performance drops by almost 50% ... can you point out the visual benefits, I honestly didn't see any with HDR+SSAO?  Or is a XP11 restart required?

 

Cheers, Rob.

 

EDIT: I can turn reflections to max and haven't noticed much of a difference in FPS but I read somewhere that a re-start is required in order for these settings to take effect?

 

 

P3D was the same way reflections was a killer - but in low they still look great

 

I'll disagree with you there, no problems with reflections at max in P3D (SLI - made several videos showing reflections on cockpit canopy) ... it was only a performance hit when running NI SGSS AA at 4X or higher.  In XP11 I'm running 2X SSAA+FXAA and reflections (any setting) have no impact on FPS so far.  I think what some are seeing is that XP11 is making use of the GPU much more, so stronger GPUs will tend to show their abilities better.

 

The FPS consumers in XP11 seem to be AA and HDR+SSAO for my system.  Also tried Max objects and still no difference in reported FPS.

 

Cheers, Rob.

  • Upvote 1

Share this post


Link to post
Share on other sites

Also, if I disable Vsync that can remove the stutters but I will get screen tearing.

 

Is triple buffering enabled when enabling Vsync? In my case (AMD card) there's a specific setting in the AMD control panel to activate OpenGL triple buffering, don't know abnout nVidia though.

Share this post


Link to post
Share on other sites

Check to make sure your not using all your Vram I was getting stutters and checked my Vram usage...8.5gb lowered turned compression on stutters fixed

Share this post


Link to post
Share on other sites

I've tried HDR+SSAO and it works fine (no performance hit) outside of the VC, but as soon as I enter the IXEG VC performance drops 

 

Same here

 

I think what some are seeing is that XP11 is making use of the GPU much more, so stronger GPUs will tend to show their abilities better.

 

Good to know

 

Hmm didnt try max objects have to try that

 

No stutters here unless I use HDR full in VC then it gets sluggish 

Share this post


Link to post
Share on other sites

 

 


Is triple buffering enabled when enabling Vsync?

 

Tried with On and Off, On made performance a little worse but I expected that as I would need to hit just a little over 30 FPS (33+ FPS) in order to effectively use Triple Buffer to smooth things out.

 

Switching to 1080p (1920 x 1080) from 4K I only saw about 2-3 FPS difference ... I expected more of an increase to be honest.

 

As I understand it LR/XP11 are using OpenGL and not Vulkan?  I know AMD GPUs perform considerably better with Vulkan.

 

I'm upgrading to a single Titan X Pascal to see if that does anything as my current Titan X's (non-SLI per profile) is pegged at 100% utilization.  This will also allow me to use the more recent nVidia drivers that have broken SLI.

 

Cheers, Rob.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this