Sign in to follow this  
dazza1980

The Old P3D Stutters

Recommended Posts

Hello,

 

Recently I had issues with P3D and Windows 10 identifying my main monitor as monitor 1. This was due to me playing around and trialling a 4K  monitor.

My current monitor set up is, main monitor (For P3D) ASUS 32 inch 2k, second monitor is a run of the mill Samsung 32 TV with just full HD (1080).

To get my windows to recognise the 2K as monitor 1 again, I had to reinstall the Nvidia G Force and drivers, I have a GTX 980.

However, since doing so I have had an awful constant stutter when panning or moving the camera around. Not your usual loading stutters, but something to do with refresh aspect of things.

I run anywhere between 20 to 80 and upwards FPS depending on location/aircraft.

I am running with the same settings as before, so dont believe changing them  would help.

 

I have tried all kinds of game and Nvidia settings, but none seem to help (Likes of V-Sync, AA, Limited frames). This leads me to the a driver issue maybe?

 

I understand system are all different and what works for one wouldn't necessarily work for another.

 

My question is, would rolling back GPU drivers help? And if so, is there a driver that people use that works?

 

Any other suggestions would be welcome, I miss my stutter free (ish) P3D!

 

Other usefulness - Orbx Global, Vector, EU (at low settings). Various payware aircraft/airports (stutter happens regardless. Tried default P3D config.

 

Thank you for taking the time to read!

 

Darren Palmer

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


Tried default P3D config.

 

What about deleting the Shader Cache?

Really should be done after any cfg change.

 

gb.

Share this post


Link to post
Share on other sites

Yes indeed I have deleted the shaders.

 

I have tried altering so many options , but nothing seems to have any effect.

 

The stuttering besoms much more noticeable at lower FPS, and quite bad if locked at 30 or lower.

 

Darren Palmer

Share this post


Link to post
Share on other sites

Hello 

 

You have probably done this already, But you have deleted your Prepar3D.cfg and let it rebuild again Yes ? 

 


Tried default P3D config.

 

*EDIT

 

 Oh sorry I see you have done this already 

Share this post


Link to post
Share on other sites

Hi Elaine,

 

Yes I had tried that, made things worse!

 

Rather than a stuttering, I think I would re-word it more like a shimmering. Sitting at EGLL with UK2000, when panning around everything appears to shimmer, with the odd micro stutter.

Its the shimmering that looks awful!

 

Darren Palmer

Share this post


Link to post
Share on other sites

Its the shimmering that looks awful!

 

Did you have spare grid transparency supersampling on before and now in NI?

That's the usual shimmering cure.

 

go.

Share this post


Link to post
Share on other sites

Yes i have tried SSG at all values and it makes no difference.

 

What I have noticed is that as soon a I get under 60 FPS, the stutters start.

 

At 59, the stutter is every few frames, the lower the FPS the worse the stutter/shimmer gets.

 

Limiting the FPS to 30 both in game and or with NI turns it into a mess.

 

Darren Palmer

Share this post


Link to post
Share on other sites

Yes i have tried SSG at all values and it makes no difference.

 

What about going back to using just one monitor to see if that helps.

Then add the second back in.

 

gb.

Share this post


Link to post
Share on other sites

I have yes. Also tried with both display port and HDMI.

 

Monitor is only capable of 59,60 or 75 HZ.

 

Darren Palmer

Share this post


Link to post
Share on other sites

I have yes. Also tried with both display port and HDMI.

 

Monitor is only capable of 59,60 or 75 HZ.

 

Darren Palmer

 

 

Hmm... what about disabling Orbx Global / Vector?

 

gb.

 

Edit: Are you testing from saved flights?

These can be messed up after significant changes.

Share this post


Link to post
Share on other sites

I mentioned this in another thread but Windows 10 has an Xbox feature that records your gaming. People have reported stutters with this setting enabled. I turn it off.

 

Very easy to do

 

Hit start button, click the green xbox icon

 

in the x-box app hit the gear at the bottom, at the top of the new window that opens it says game DVR at top, click that and then flip the switch to off.

 

It doesn't matter if you have an x-box or not,

Share this post


Link to post
Share on other sites

Well I have tried all.

 

I have just also tried, running P3D on the second monitor which is just 1080. That TV can run at 30HZ, so I set it to that and limited P3D to 30FPS. And its smooth as silk!

 

So, the issue I guess is the refresh rate?

 

My main expensive Asus 2k monitor is useless for P3D as it doesnt run anything lower than 60HZ. Also, as P3D isnt truly fullscreen, there is no way of forcing half refresh rate?

 

Darren Palmer

Share this post


Link to post
Share on other sites

 

 


Hit start button, click the green xbox icon

in the x-box app hit the gear at the bottom, at the top of the new window that opens it says game DVR at top, click that and then flip the switch to off.

It doesn't matter if you have an x-box or not,

 

I have never signed into Xbox and there is no gear icon on the sign-in screen.

So can I assume it is not recording anything?

 

Thanks,

gb.

Share this post


Link to post
Share on other sites

Did you try to leave the frames unlimited?

 

I do have a 4k with 60hz and any limitation of the frames gives me stutters. With frames unlimited all is running nicely.

 

Gruess

Dani

Share this post


Link to post
Share on other sites

Yes I have tried with unlimited frames, and whilst its running at 60 or above its perfect.

 

The minute it drops below, the stutters appear.

Share this post


Link to post
Share on other sites

Did you try temporarily removing your dll.xml and exe.xml from your setup to disable all your addons so you can see if it's a addon problem or a sim problem? That would be a good first step in getting to the bottom of this.


I have never signed into Xbox and there is no gear icon on the sign-in screen.

So can I assume it is not recording anything?

 

Thanks,

gb.

 

Correct -  I think that also gets enabled if you sign into a microsoft account too but not 100% certain of that

Share this post


Link to post
Share on other sites

Correct -  I think that also gets enabled if you sign into a microsoft account too but not 100% certain of that

 

Ok, thanks,

gb.

Share this post


Link to post
Share on other sites

I have managed to eradicate many of the background stutters by tweaking the cfg file according to the AVSim Guide.

Flying along the sim runs as smooth as anything from 20 fps upwards. 

However, I am still stuck with the panning issue. I believe its purely related to the refresh rate of the monitor, which doesn't want to ply ball regardless of what I do.

Share this post


Link to post
Share on other sites
On 1/26/2017 at 10:00 AM, dazza1980 said:

I have managed to eradicate many of the background stutters by tweaking the cfg file according to the AVSim Guide.

Flying along the sim runs as smooth as anything from 20 fps upwards. 

However, I am still stuck with the panning issue. I believe its purely related to the refresh rate of the monitor, which doesn't want to ply ball regardless of what I do.

Care to explain what you did? :) 

Share this post


Link to post
Share on other sites

Well mostly I adjusted a number of settings describe int eh AVSim guide.

What I found gave me reduced stutters were,

Max Regions Purge Per Frame - 8

TextureMaxLoad - 6

Ground Shadow Texture - 512

Cloud Shadow Texture - 256

The latter two are quite low and do give a little flickering, but have such a good impact on frames and stutters I though it worth sacrificing.

Also, having the right Affinity Mask worked well. Mine is set at 85

Turning of volumetric fog had a decent impact on frames, up to 8 FPS.

 

I also used Frooglesim's Nvidia settings too:

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this