Sign in to follow this  
Rene Scharlach

Problem with FSX.SE and ASN.SE

Recommended Posts

Today I had got the following error:

 

HgiFAZt.jpg

 

Pressing Yes crashes FSX. Pressing No makes ASN shut down itself after it detects that it cannot connect to FSX.

 

Yesterday, the same was running with no problems.

 

Any help for this? Thanks.

 

Rene

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you tried updating to the latest version of ASN?

Hifi Downloads Section

 

It says, updates are handled by Steam. I did an update there by un-checking the addon and checking it again, which causes a new download. However, it still does not work. Note that I had the problem before and it went away by some mystery. I will try to fix the cfg files later (removing the permissions from fsx.cfg etc.) 

 

I would be willing to buy AS16 if I knew it works with Steam and does not have the same problems. Probably, I will try their evaluation today. I'd rather have my Steam version fixed because it worked with no problems at all before.

 

Rene

Share this post


Link to post
Share on other sites

As 2016 works great with Steam Edition I can confirm. Sorry for dumb question but do you have all your simconnect modules from sdk installed?

Share this post


Link to post
Share on other sites

Hi,

 

Sometimes various add-ons can crash and become blocked by FSX.  We've seen this occasionally in the case of a file access/AV issue for example, where our ASConnect module gets "modified" by the security software (attempting to block it), which crashes, then FSX adds a "blocking" entry, causing this error to show up.

 

The solution is to first try running as_btstrp_config_manager.exe located in the [sim]\as_srv folder.  This can sometimes resolve the issue just by running this once.  If the issue continues, you can manually remove the blocking entry which is located in 2 places in the registry:

 

1) HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers (you'll see an entry for fsx.exe with as_btstrp.dll in the Value data.  Remove the IgnoreFreeLibrary<as_btstrp.dll> portion (or remove this entry entirely, and re-set any compatibility settings for fsx.exe after if desired)

 

2) HKML\Software\Wow6432Node\Microsoft\microsoft games\flight simulator\10.0\Launch (you'll see an entry for as_btstrp.dll, remove this).

 

Once this is done, there will be no more blocking or error shown and things should load.  HOWEVER, the original problem may still exist causing interference of our module, so I recommend ensuring you have all of FSX and ASN "trusted/excluded" in your security software before performing these steps.

 

You can open a ticket at http://support.hifitechinc.com for direct assistance.  Hope that helps!

Share this post


Link to post
Share on other sites

Thanks, HIFI, for your answer. None of your registry keys were present.

 

I have some Odyssee behind me. First, I installed AS16 with a trial key. Worked well, but I decided to give the AS SE another chance.

 

So I uninstalled, rebooted and removed the traces in FSX.CFG, DLL.XML and EXE.XML. Reinstalling the AS SE is not as easy to find as I thought. In the end, I installed via the Tools box in Steam, and by unchecking and checking the box in the FSX game menu. It then downloads the DLC/364340 again, so that everything can be started again. There are currently no more crashes.

 

The remaining topic is that I get ask to start as_bootstr every time. Annoying, but okay with me.

 

Rene

Share this post


Link to post
Share on other sites

 

 


The remaining topic is that I get ask to start as_bootstr every time. Annoying, but okay with me.

 

Is the following red word in your exe.xml file False? it should read True to get rid of that startup message.

 

<?xml version="1.0" encoding="WINDOWS-1252"?>
-<SimBase.Document version="1,0" Type="Launch">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>True</Launch.ManualLoad>
-<Launch.Addon>
<Disabled>True</Disabled>
<ManualLoad>False</ManualLoad>
<Name>Addon Application</Name>
<Path>C:\MyPath\Addon.exe</Path>
<CommandLine> </CommandLine>
<NewConsole>True</NewConsole>
</Launch.Addon>
-<Launch.Addon>
<Name>as_btstrp_config_manager</Name>
<Disabled>True</Disabled>
<Path>as_srv\as_btstrp_config_manager.exe</Path>
</Launch.Addon>
</SimBase.Document>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this