Sign in to follow this  
EuroTruckGuy

HELP! FSX:SE Graphics Have Gotten Worse

Recommended Posts

Hi,

I have recently noticed that my graphics and frame rate have decreased. I did not install any new addons, update fsx, or even do anything different on my pc! One night, my graphics and fps were good (as usual), but I shut down my pc, and the next day when I powered on my pc and loaded fsx, I had lost at least 10 fps, and the textures in FTX Global had a noticeably lower resolution, and there were pop-ins EVERYWHERE! Does anyone know what is going on? Thanks.

 

Pictures: http://imgur.com/a/ZXBs7

 

UPDATE: The only thing that changed between when I had good fps+graphics to bad fps+graphics was that vPilot came out with an update, which I didnt install.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I just did some testing, and if I pause the sim and sit there for a minute, everything pops in, and my graphics are back to looking amazing. But, if I keep flying, everything keeps popping in, close to my plane.

Share this post


Link to post
Share on other sites

Did you updated you graphic driver recently?

No, I did not change anything on my pc. One day everything was fine, the next day there are pop ins everywhere.

Share this post


Link to post
Share on other sites

That's strange.... But looking at the pics I can't see what is the problem, both pics look good to me. As per FPS,  Is that FSLab Airbus? Did you updated to v.197? You are on P3D or FSX......?

Share this post


Link to post
Share on other sites

That's strange.... But looking at the pics I can't see what is the problem, both pics look good to me. As per FPS,  Is that FSLab Airbus? Did you updated to v.197? You are on P3D or FSX......?

I am on FSX Steam Edition, and that is the Aerosoft Airbus a320. I figured out that the graphics look worse because the textures and autogen are rendering in much closer to my aircraft than before. For example, things used to look blurry about 50 miles out, and now they are blurry about 3 miles from my aircraft. If I pause the sim for a while, the correct texture resolutions and autogen finally pop in, and the sim looks stunning again. As soon as I unpause and fly above new ground, the same thing happens again, with blurry textures and autogen popping in very close to me.

Share this post


Link to post
Share on other sites

It looks like some autogen issue....I had some similar issues recently and after a while...  save your .cfg, delete and start all over again and tune it little by little. Nothing can happen and it is quick diagnostics. You are running DX10 I assume and Steve's Fixer?

Share this post


Link to post
Share on other sites

It looks like some autogen issue....I had some similar issues recently and after a while...  save your .cfg, delete and start all over again and tune it little by little. Nothing can happen and it is quick diagnostics. You are running DX10 I assume and Steve's Fixer?

No, Im currently not running the DX10 fixer, or DX10 preview mode. I would, but its kinda expensive for a tweak. I will try reverting back to my default config, but like I said, this started happening without me changing a single thing. Thank you for helping me so far!

Share this post


Link to post
Share on other sites

No problem.....But you should consider DX10,,,,,

Sure! I would, but I really don't see any advantages to it. What does DX10 change in terms of graphics and performance? Will I get better fps? Also, I reverted back to by old config for testing, and the autogen/texture problem is still happening. I only had 2 config edits in the first place LOL. I will try to record a short video for you, but fraps is acting up a bit!

Share this post


Link to post
Share on other sites

DX10 has a better graphics and makes VAS and FPS more usable and better performance. Also with a fixer you have your graphics config at a glance and all important graphics accessible and adjustable i.e. lights, clouds, etc. after all it's not that pricey.

Share this post


Link to post
Share on other sites

DX10 has a better graphics and makes VAS and FPS more usable and better performance. Also with a fixer you have your graphics config at a glance and all important graphics accessible and adjustable i.e. lights, clouds, etc. after all it's not that pricey.

Cool! I will definitely look into it. My video is currently uploading so you can see exactly what is happening to my fsx. (its only 30 seconds) I'll link it once its up!

Share this post


Link to post
Share on other sites

Look for other programs running in the background.. it seems like something is taking away CPU cycles..

 

Use Task Manager, Performance Tab to see what is consuming CPU cycles.

 

... or your system is overheating..

  • Upvote 1

Share this post


Link to post
Share on other sites

Look for other programs running in the background.. it seems like something is taking away CPU cycles..

 

Use Task Manager, Performance Tab to see what is consuming CPU cycles.

 

... or your system is overheating..

I ran task mamger while playing fsx, and FSX never used more than 38% of my cpu! That explains why my pc is freezing cold when it runs fsx, but heats up a bit while playing EuroTruckSim......

Share this post


Link to post
Share on other sites

Look for other programs running in the background.. it seems like something is taking away CPU cycles..

 

Use Task Manager, Performance Tab to see what is consuming CPU cycles.

 

... or your system is overheating..

 

 

It looks like some autogen issue....I had some similar issues recently and after a while...  save your .cfg, delete and start all over again and tune it little by little. Nothing can happen and it is quick diagnostics. You are running DX10 I assume and Steve's Fixer?

Here is the link to my short video showing my issue: 

Share this post


Link to post
Share on other sites

Popping autogen is not an issues to be fixed (in FSX), it is an inherent way of

how FSX is programmed.  If you load up the CPU enough, it cannot keep up and

popups that are usually a bit further out, move into close range.. and can become

quite visible, and annoying...

 

P3D is better in this regard.

Share this post


Link to post
Share on other sites

Popping autogen is not an issues to be fixed (in FSX), it is an inherent way of

how FSX is programmed.  If you load up the CPU enough, it cannot keep up and

popups that are usually a bit further out, move into close range.. and can become

quite visible, and annoying...

 

P3D is better in this regard.

Thanks, but I don't know why my autogen is popping in closer than it was before, seeing as my cpu usage has not changed. Is there anything else I could try?

 

 

Thanks for your help.

Share this post


Link to post
Share on other sites

Please!? Anyone.... I've been trying to troubleshoot and solve this problem for 4 1/2 hours with no luck! I don't know what else to do. :(

Share this post


Link to post
Share on other sites

Hi, well first of all: relax young rocket. It's not the end of the world. ;-)

 

What version of Windows are you running? Windows 10 for example updates drivers automatically. A rollback may be required. What are your hardware specifications?

 

Did you try to exclude the fsx.exe proces in your antivirus? This sometimes helps.

 

FSX:SE is running on Steam. Doublecheck if Steam hasn't updated your graphic drivers for you. (It's a feature in Steam that's on by default). It would do this in the background which would X-Plane (....I'm hilarious...) why you wouldn't even know it happened ánd why it suddenly happened after a reboot.

 

You say 'nothing changed'. Well, something obviously did change so let's find out what that is. In the mean time, get yourself p3d (...I just wet myself!...) for the circumstance that you just need to learn and live with this. It's normal behaviour for FSX tot pop-in its autogen this way because, like Bert said, it's just the way FSX is coded. To be honest: I have never seen it differently.

 

Keep us posted!

Share this post


Link to post
Share on other sites

Hi, well first of all: relax young rocket. It's not the end of the world. ;-)

 

Lol I'm sorry, I guess I've been spoiled with games that have no issues in the past, and now a bug appears, and I go crazy :) .

 

I am running Windows 10, and I have Windows

Updates turned off, and none of my driver's were updated within the past 3 weeks (I went through the entire drivers page selecting every item, is there an easier way to do this?!)

 

My specs are: Intel core i3 6100 (it works REALLY well for a dual core) 8gb ddr4 RAM, 128gb SSD (only 17gb left Lol), MSI GTX 1050ti, and a corsair spec 01 case.

 

Did you try to exclude the fsx.exe proces in your antivirus? This sometimes helps.

 

Since installing Fsx, I have had my Windows Defender antivirus disabled.

 

I will check the steam thing you talked about, and I WOULD LOVE to get p3d (I wanted to get it originally) but I really can't afford it right now. (Flight lessons are EXPENSIVE!)

 

Thank you, so far you are the most helpful person!

Share this post


Link to post
Share on other sites

Have you tried removing your current fsx.cfg and letting it rebuild?

I have tried reverting back to my original config that didn't have any edits (I have it backed up), and it didn't help. My GPU drivers were not updated, and I am testing fsx as I write this. I was on the forums and I read this:

 

 

"There are some things that can alleviate the popping of AG however. If the AG loads quicker, it will not be quite so apparent. The longer AG takes to load then the nearer it will be to the aircraft, due to the delay and so you become more aware of it. So, it's once again horses for courses. Take some opf the CPU intensive work from the framerate and give it back to scenery loading and it will help. It will also help with blurries too. If you run your LOD at 10.5 you will inevitably end up with problems, I promise. I have experimented extensively and to be absolutely honest, while there is a difference between say the default 4.5 and 7. it will not be very apparent. So as the other guys suggested, 5.5 is a good compromise, but to be honest I'd be surprised if you see more than a very small difference. My advice would be to lock frames at 25 or 30, I have mine locked at 26 and see my sig! it was the best thing I've ever done. It's given back some of the CPU power back to loading scenery. So as an experiment, I suggest, you lock your framerate at 25, set your AG slider at normal, LOD at 5.5, untick all the relevent boxes in FSX CP and then let us all know how you get on."

Share this post


Link to post
Share on other sites

Dont just copy paste an older cfg file from before. As counter intuitive as it sounds, you need to remove whats there completely and let the sim rebuild it from scratch. Try it again like that before you HAND TYPE your edits back into the new one.

 

Secondly are you using Nvidia Control Panel or Nvidia Inspector? Make sure power management mode is set to max performance.

Share this post


Link to post
Share on other sites

Dont just copy paste an older cfg file from before. As counter intuitive as it sounds, you need to remove whats there completely and let the sim rebuild it from scratch. Try it again like that before you HAND TYPE your edits back into the new one.

 

Secondly are you using Nvidia Control Panel or Nvidia Inspector? Make sure power management mode is set to max performance.

Ok, ill do that right now. I am not using nvidia inspector. Will post results soon!

Share this post


Link to post
Share on other sites

Well, after looking at your video I have to say that that's how FSX works...LOL... Try lowering your scenery and texture load....

But you might not accomplish much......I have heavy scenery and I haven't been able to solve that  problem. In terms of CPU usage, FSX is very Hungry....and it will use CPU. Along with everything else running in background, cold get high. You have to see what is in the background and decide what you need and what is important or not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this