Sign in to follow this  

Flight 1 King Air Problem

Recommended Posts



I've posted my questions on the Flight 1 support forum but have had no reply. If you'll forgive me I'll post my issue here in hopes someone can shed some light  on what's going on.


  • Latest version of the Flight 1 King Air B200 installed and reinstalled using exact instruction from their website.
  • Dialed down all P3D settings.
  • Disabled Addon scenery
  • No weather (AS16)
  • Desolate area.
  • GPS decluttered and zoomed out.
  • Inset GPS decluttered and turned off.


I get solid 30 FPS outside the aircraft (FPS locked at 30.)

Inside the aircraft, once I turn on the Battery Master the FPS drops to about 9. It generally remains around 9, and sometimes will move up to 15 for a few seconds.


Above 10k the FPS improves a bit to an average of <19 FPS.


Checking my CPU/GPU loads, they are both quite low. The GPU doesn't surprise me, but the low CPU does; around 54% load. Usually with complex aircraft I see a CPU load of near 90-99% spread across the 4 cores.


I have an appropriate affinity mask set in the config file.




I read time and again that people I trust really like this aircraft and have seen youtube videos where all looks fine. So, it must be something unique to my setup.


Any help would be appreciated.

Share this post

Link to post
Help AVSIM continue to serve you!
Please donate today!

You should be getting more with that somewhat dated but powerful system.  The G1000 is definitely one of the toughest avionics in FS I've ever seen, the fps on my end are erratic (stutters etc), but I generally have a lot more than 9 fps even in dense payware.  Well maybe not a lot, but 12-15 if in dense weather/payware etc.  You can try disabling the right side PFD, instructions are in their forums I think it's been so long.  Also try disabling the obstructions from the MFD, I think it's declutter -1 or -2.


So I just ran it just now. Default cessna at a rural airport in VC: 120 fps.  King air: avg of 47.  fps variance 33% (that's big - that means stutters).  KA has always done that to me.  My CPU doesn't like the glass I guess.

Share this post

Link to post

What Ryan said...get rid of the obstacles.  Declutter them down with the buttons at the bottom of the MFD or create an empty Obstacles file in the gauges directory.

Share this post

Link to post

Also try checking the "remove smudges from G1000" option in the config. For some reason this overlay can eat FPS.


PS... In the latest version, the "remove copilot PFD" option is included in the maintenance module, accessed via the P3D main menu > Addons > Flight 1 King Air B200.

  • Upvote 1

Share this post

Link to post

All the comments above are good suggestions.

I get excellent frame rates with the F1 B200 on a very similar system.  What are your AA settings?  What camera addon (if any) do you use? 


I use EZCA2 now as a late December update of Chase Plane caused stutters for me (very noticeable in the B200).



Share this post

Link to post

Thanks for the replys.


I've tried the above suggestions with no joy; including no camera tool.


I'll probably try again at some point. I really like the aircraft and I generally can't let something go until I've solved the problem or simply collapse into a pile twitching despair.

Share this post

Link to post



 or simply collapse into a pile twitching despair.


That's the spirit!  Surprised the declutter didn't work.  Try zooming out.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this