RXP

RXP GTN 750/650 Touch v2.4.2 available

Recommended Posts

Hi,

Before an official release, I wanted to let you try the v2.4.2 release candidate! If there are no 'crash' reports, it will become officially released.

List of changes since v2.4.1:

  • added support for mouse click-spots in 3D and 2D panels
  • fixed issue with transparent/last screen image when powering off/on the device.
  • new render targets option: "PANELS" supports both 3D and 2D panels at once.

List of the changes since v2.4.0:

  • Massive performance gains: our tests systems show minimal to nearly no FPS changes from 1 to 2 GTN (and even up with 2GNS + 2GTN in some cases - YMMV).
  • TCAS missing targets corrected.
  • Revisited and greatly improved all 'panel instruments links', with support for mixing GNS and GTN devices (GPS datarefs, HSI datarefs, NAV datarefs and related instruments).
  • Always On option: now you can opt to have your devices 'always on' regardless of the avionics switch. This shall help with 3rd party aircraft with custom/non-standard electric buses.

Additional notes:

The list of panel types has been extended and now supports the following (frame.type) :

WINDOW, PANEL2D, PANEL3D, PANELS

The new 'PANELS' helps for aircraft with only a 3D cockpit, as there is no need to configure 2 separate INI file render targets entries for the 3D and the 2D panels. A single entry covers both.

Mouse support in 3D/2D panels comes in the form of new settings in the INI file.

For frame.type = 'WINDOW' comes a new setting (default shown):
; enable mouse clickspots if true, disable if false (use SHIFT to override)
usemouse = true 

When true, the popup window supports clickspots as before. When false, you have to depress the SHIFT key while clicking to temporarily override the restriction. This might become useful in the future for panels where you'd expect disabling all mouse interactions with the device (hardware controllers?), but don't want to have it in the virtual cockpit.

For frame.type = 'PANELS' (or PANEL2D/PANEL3D) (default shown):
; enable mouse option: NONE,POPUP,TOUCHSCREEN
usemouse = TOUCHSCREEN

This lets you select if the screen should only toggle the popup window, or if you want full touchscreen support in the virtual cockpit!

Download link for both e-commerce installers

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

@bluebell2

I've tried adding the usemouse = TOUCHSCREEN to your C172 modded GTN750+650 panel.  I've added this line to 

[GTN_750_1.PANEL3D]

But I'm not able to use my mouse on the screen.  Is it something built into the .obj files that would have to be changed?  I don't know anything about XP11 modelling.

Share this post


Link to post
Share on other sites

Tested both the GNS 430/530 and GTN 650/750 and all is working great for me apart from when I switch OFF the avionics in the GTN the last screen on the popup window and the 3D window stays and does not go to black. So if I have the map page showing and switch off the avionics the map stays. If I then switch on the avionics the GTNs reboot.

The touch screen in the 3D cockpit works great and it is good to have.:biggrin:

Share this post


Link to post
Share on other sites
9 hours ago, ryanbatcund said:

I've tried adding the usemouse = TOUCHSCREEN to your C172 modded GTN750+650 panel.  I've added this line to 

You need to edit the Cessna_172SP_GTN_cockpit.obj file with text editor and delete lines:-

ATTR_manip_command hand RXP/GTN/TOGGLE_WINDOW_1 

ATTR_manip_command hand RXP/GTN/TOGGLE_WINDOW_2 

 

Share this post


Link to post
Share on other sites
4 hours ago, bluebell2 said:

The touch screen in the 3D cockpit works great and it is good to have.:biggrin:

I share this feeling too! Even tough we've been implementing the feature and shouldn't be surprised too much, this just gives so different a feeling to using the gauges it got me excited using it!

As for the 'last screen showing when powering off', I honestly fail to apprehend what could be the culprit for now. There was an issue with the previous builds: the first time it powered on, when there was no 'screen' data see yet, or when cycling power, the texture pixels where set as transparent black instead of opaque black (a bug in one of our low-level lib in 64bits, fine in 32bits).

This is now corrected and tests with the default baron for example prove to be fine. Is this happening on your system even when replacing the baron GPS screen with the GTN? Here is the rect for the default B58:

frame.rect = 275,668,260,195

Could this be a 'material' in your 3D model which is not UV mapped when power is off, but mapped when power is on, which in turn doesn't give a chance for the 'black' screen texture to be drawn?  Something to cross-check: you might want to try adding a border colour to the panel section, like this:

; screen only border size (pixels).
border.size = 20
; screen only border color (#RGB or #RGBA).
border.rgba = #FF0

This will draw a 20 pixels yellow border around the screen. The border is first drawn then followed by the screen texture. If the border also disappear, then it is most likely a 'material' problem. If the border stays and the last screen freezes, then it is most likely a bug in our plugin, or a bug with the gfx driver of some sort, because in this case, the border tells it is drawing to the screen, and the frozen texture tells the texture pixels where not updated with 'black'.

 

Share this post


Link to post
Share on other sites
2 hours ago, RXP said:

Could this be a 'material' in your 3D model

It is also the same in the popup window and tested with default Cessna. I can easily put a fix in the 3D window with hide/show dataref but can do nothing with popup window. GNS switches off with no problems.

Share this post


Link to post
Share on other sites

Have you tried the yellow border?

Share this post


Link to post
Share on other sites
3 hours ago, RXP said:

This will draw a 20 pixels yellow border around the screen. The border is first drawn then followed by the screen texture. If the border also disappear, then it is most likely a 'material' problem. If the border stays and the last screen freezes, then it is most likely a bug in our plugin, or a bug with the gfx driver of some sort, because in this case, the border tells it is drawing to the screen, and the frozen texture tells the texture pixels where not updated with 'black'.

Yellow border on 3D window all the time, power off, power on, power off. Still the last screen to be displayed stays with power off.

Share this post


Link to post
Share on other sites

So this confirms the texture pixels are not updated, and I'm starting to wonder if your video card is not the culprit (especially given the previous problems you've had with the ATI card / latest drivers).

I see no particular reason though, because if the screen texture gets updated when the screen content changes, how come it is not updated when the screen content is black pixels. A driver optimization bug which detects all black pixels and stops the texture pixels update?!?!

Can you give me access to your aircraft for me to compare and try out? Maybe Ryan could jump in and try out on his system as well?

Any other one with the same problem?

Share this post


Link to post
Share on other sites

Hope to release the GTN/GNS version of Bell 429 (freeware) later next week on www.x-plane.org. Will add my own Fix to 3D panel. You will still see if there is a problem with popup window,

Share this post


Link to post
Share on other sites

Should I change all the PANEL3D sections of the .ini files to the new PANELS type?  Or does it not matter?

Share this post


Link to post
Share on other sites

Aircraft with only 3D panel use the 3D panel to render the 2D panel with a fixed angle. In this case, instead of creating duplicate sections with the same settings, just use 1 section with frame.type = PANELS and it covers both at once!

Aircraft with actual 2D panel and 3D panel need separate sections, because the co-ordinates and the mapping are different.

frame.type = PANELS is useful when you don't want to duplicate a PANEL3D to a PANEL2D section with the same parameters.

Obviously, if you want different 'usemouse' or any other different parameters in 3D and 2D, even though the 2D panel is a pseudo 2D from the unique 3D panel, then you use 2 sections each one with its PANEL#D type.

Share this post


Link to post
Share on other sites
16 hours ago, bluebell2 said:

You need to edit the Cessna_172SP_GTN_cockpit.obj file with text editor and delete lines:-

ATTR_manip_command hand RXP/GTN/TOGGLE_WINDOW_1 

ATTR_manip_command hand RXP/GTN/TOGGLE_WINDOW_2 

 

@bluebell2

I don't have those in my file.  I have two very similar lines though.  I added a # sign to comment them out.  The ones that exist in mine are:

ATTR_manip_command button RXP/GTN/TOGGLE_WINDOW_1

ATTR_manip_command button RXP/GTN/TOGGLE_WINDOW_2

After I commented them out the mouse DID NOT work.  However something took effect because I couldn't popup the GTN anymore (makes sense reference the lines above).

For clarity....  here's my GTN_750_1.PANEL3D lines:  Is the last entry the only line I need to add?  

[GTN_750_1.PANEL3D]
; display window if true.
visible = true 
; show screen only gauge if true.
nobezel = true 
; display type: WINDOW,PANEL2D,PANEL3D,PANELS
frame.type = PANEL3D
; display position and dimension (left,top,width,height)
frame.rect = 0,1024,517,627
; screen only border size (pixels).
border.size = 0
; screen only border color (#RGB or #RGBA).
border.rgba = #000000
; enable mouse option: NONE,POPUP,TOUCHSCREEN
usemouse = TOUCHSCREEN

EDIT!! 

So the file I needed to edit was actually called Cessna_172SP_750_cockpit.obj.  And this is where the plot thickens.  I must have downloaded both of your GTN mods.  One has the 750/650.  Opening that associated .obj file (it's called Cessna_172SP_GTN_cockpit.obj) - DOES NOT reveal those lines you wanted me to edit.  But the other model I have has 2x GTN750's.  That associated .obj file is called Cessna_172SP_750_cockpit.obj.  Editing out those lines (they are present) makes the GTN750 now react to mouse clicks in the virtual cockpit.  But the #2 GTN750 is all black (except for a thin line of pixels I can see moving in sync with the upper GTN750).  It's quite odd.  Here's a pic of my file folder.  Maybe I should start over.  What's the best way to get the default C172 back and install your mods?

gtnmodded.jpg

 

EDIT AGAIN:  SO I think I can't run two mods at the same time?  The ini file from the dual GTN's of course contains two instances of the GTN750.  But I'm running the ini file with the GTN750 and GTN650.  That's why the model with dual GTN750's is showing blank on the bottom unit.  Great.  Still I'm unable to get click spots working for the GTN750/GTN650 model.  The two lines you wanted me to edit out are not present in that file at all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now