jsg0813

Chaseplane & P3d v4 Crash

Recommended Posts

Hello all,

 

i am experiencing issues with chaseplane and P3D v4 as there are instances I change cameras and P3D stops responding. Just thought I'd give this info while chaseplane is still in alpha for v4. Any ideas? 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I've also had this happen today in the TFDI717, was starting decent on a 2 hour flight then i changed to cockpit and it crashed.

Share this post


Link to post
Share on other sites

Me too.   TFDI + Chaseplane + 40-minutes of flight = CTD   I can't finish a flight.   Has anyone seen any confirmation from either TFDI or FSFX on this issue?

Share this post


Link to post
Share on other sites

Brian Shaw

Also happens to me in any payware or default aircraft. I use it with trackir. Once chase plane crashes trackir doesn't work

Share this post


Link to post
Share on other sites

Hi,

We fixed a memory leak in the latest version, potentially causing this issue. Let me know if the it's resolved now!

Regards,
Keven

Share this post


Link to post
Share on other sites

Hiya

I too have been experiencing a CTD when in the TFDi 717 (8 flights so far only 2 completed) with the last CTD being last night at 1900 (ish) UK time.

I felt it was when I moved from an internal view to an external view? Whilst frustrating as I love the aircraft and really want to complete a flight I understand new sim etc etc (I'm on V4) so I'll try another flight tonight and see if I get the same issue. Someone said to me that if they completed a flight with just an internal camera (chaseplane) it doesn't crash so they seem to back up my thinking just as an f.y.i.

 

Cheers

Paul

Share this post


Link to post
Share on other sites

Pf... i was thinking about something in my pc. "Glad" i'm not alone.

TFDI + Chaseplane = random crashes during camera change, usually 20-30 minutes of flight, but somethimes even on the runway.

Hope this gets sorted asap.

 

Share this post


Link to post
Share on other sites
On 17/6/2017 at 7:52 PM, Keven Menard said:

Hi,

We fixed a memory leak in the latest version, potentially causing this issue. Let me know if the it's resolved now!

Regards,
Keven

Hey Keven,

it crashed on me even yestrday. Chaseplane updated itself automatically using the built-in updater. I chose to not use experimental features, yet i experienced the same crash after 30 minutes.

It seems switching from external to internal randomly causes this.

Share this post


Link to post
Share on other sites

Bought ChasePlane today...  it's great BUT it has crashed on me at least 10 times today!

Seems to crash when switching between P3D and ChasePlane (ie I'm going into CP a lot to configure cameras).  If I just switch between camera's using the assigned keystrokes then there is no problem.

Using P3Dv4 and PMDG 747v3.

Share this post


Link to post
Share on other sites

Hey Matt, i have the issue even using the configured keystrokes. I agree that it's less frequent than when using the central mouse button and selecting the camera visually, but it still does it.

Share this post


Link to post
Share on other sites

I should add its crashing during a flight when I'm trying to set up cameras.

Maybe I should just start P3D, load the 747, get all my cameras configured (and switchable using hotkeys)... and then restart the sim and do the flight (and not try to use CP at all, except for the view switching using my hotkeys).

Seems to me that CP seems to crash when there is lots of focus switching happening between P3d and CP.

Also sometimes P3d is actually shutting down (and not the CP gui)....  but im sure that CP is the cause.

Really annoying because CP is excellent (apart from the crashing) and has made the 747 a breeze to fly!

Share this post


Link to post
Share on other sites
1 minute ago, MatthewS said:

Also sometimes P3d is actually shutting down (and not the CP gui).... 

For me P3d always shuts down and CP remains opened, but i agree that is CP causing the issue. I didn't have the issue before installing it.

Share this post


Link to post
Share on other sites

People having issues with CTD on v4, try disabling Advanced Features from the Preferences. Let me know then if the CTD issue persists

Share this post


Link to post
Share on other sites
12 hours ago, Keven Menard said:

People having issues with CTD on v4, try disabling Advanced Features from the Preferences. Let me know then if the CTD issue persists

I disabled "Advanced Features" and no more CTD.

However I notice there is a black flash when switching camera if Advanced Features is disabled, so after setting up my cameras, I put Advanced Features back on.

 

Share this post


Link to post
Share on other sites

I also had CTD a few days ago after 12h fliying :angry: the PMDG 744 on P3D v4. At the time of this reply I had an app failure again and stop working but fortunately P3D didn't crash and seems I'll finally get my destination. CP made a crash log .txt file which already sent to the oldprop staff. Hopefully this will help to solve this annoying issue.

Share this post


Link to post
Share on other sites

Nothing seems to prevent this from crashing my p3d. Just re-crashed after 2 minutes from landing, as usual from outside to cockpit view. I'll try to complete a flight without using views. Super-annoying issue.

Share this post


Link to post
Share on other sites

My P3D V4 doesn't crash but there is defently another memory leak in the latest experimental release.

Chaseplane starting at 100 Mb memory usage and after 1 hour it already creaped up to 270. Eventually it will crash.

Share this post


Link to post
Share on other sites

If you are experiencing crashes with Advanced Features disabled, the issue is not with ChasePlane. We are sending basic data through SimConnect using traditional methods. That alone will not cause a P3D CTD. We use the exact same methods and data we used since v0.1.0.

Share this post


Link to post
Share on other sites

Hi All,

 

Perhaps someone can help with this one...

I use Chase Plane (Stable not experimental) with P3DV4. 

4 out of 5 times, Chase Plane fails to start up and gives the "Oops. something unexpected happened" error.

Then the Chase Plane interface seems to be all frozen. From inside the sim, the views and all works fine and camera movement according to the set preferences work fine, but if you enter the chase plane interface, it seems entirely disconnected, it does not reflect the aircraft type, and the green logo that signifies the connection is still red...

Anyone experienced similar problems and managed to fix it?

(P.S, i have uninstalled and reinstalled Chase Plane... makes no difference)

Share this post


Link to post
Share on other sites

I have always used the experimental with no issues. Chase is constantly updating their product

Share this post


Link to post
Share on other sites
On 6/16/2017 at 6:01 PM, pchimbolo said:

Me too.   TFDI + Chaseplane + 40-minutes of flight = CTD   I can't finish a flight.   Has anyone seen any confirmation from either TFDI or FSFX on this issue?

Thought it was just me. I haven't been able to complete a TFDI 717. The last 4 flight all crash when changing views and its always when I am a good hour or more into a flight. The sim will freeze when changing views then a few seconds later P3Dv4 will close and I get a message that says chase plane has stopped responding.

 

Share this post


Link to post
Share on other sites

We are aware of that issue bit has been confirmed that the issue occurs even without ChasePlane.

Most likely something in the P3D code. Check this week if it was fixed in 4.1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now