cpt_muggz

Prepar3D v4 Blurries

Recommended Posts

Hey guys! I hope you're doing well, so i have blurries in my p3d, here's screenshot.

 

Spoiler

9c34e0304c1988071d9fcaeb3a6b1c30454.png

When, i takeoff from any airport the ground looks good, bet when i flew about 200 miles, all scenery becames blurry.

 

I've tried:

 

Deleting Prepar3d.cfg

changing nvidia settings

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

A little bit more info would be helpful.

Systemspecs, cleaning shaders, addons, other settings, just to name a few.

Share this post


Link to post

My specs are:

Intel I5-7600K

Nvidia Geforce 1060 6gb

16gb of ram

Addons:

ASv4

ASCA

PMDG 777 and 747.

Settings:

Spoiler

776822630c5e144d09ef585172b50ba7722.png

Spoiler

7041a2fe8557465e857b32d49f1f5f12646.png

Spoiler

0d6a57e55c2fef0109d9627f3069c75e857.png

Spoiler

a44e8b7af481b9d8f4062cc3aa2625f0849.png

 

Share this post


Link to post

For your rig, your settings are way too high.draw back your cloud draw to 70Mi.shadow receive(uncheck a few) as well.also switch to 4x ssaa easier on fps.if you dial back a bit,you can put on vsync and triple buffering.also noticed Autogen draw distance.dial that back to high.hard to see that far anyway.

try this and see if it helps.

 

steve

 

Share this post


Link to post

Limit internally yout fps to 60, set VSYNC and check again. It should work

 

Rado

Share this post


Link to post

Delete the prepar3d.cfg and change only following (I would say leave rest as is):

- fxaa off, msaa 4x

- 4096 texture resolution

- 16x aniso

- limit FPS to 30

- set LOD RADIUS to max

- check use high resolution textures

- uncheck 3d autogen vegetation

- HDR off

- quit p3d, delete shaders folder

- restart and try again

If it doesn't work, you have other problems than P3D (aka computer-problems), IMHO.

Share this post


Link to post

Enable hyperthreading in your bios and remove the affinity mask setting in the p3d cfg file

Share this post


Link to post

I dont have affinity mask in my p3d.cfg, i will try enabling HT in my bios.

Share this post


Link to post

Try a higher anistropic setting to 16x but dial the autogen distance slider back to the middle. In Nvidia Inspector turn off the shadercache for the Prepar3D profile.

Share this post


Link to post

In your cfg try

TEXTURE_SIZE_EXP=8 - under terrain

FIBER_FRAME_TIME_FRACTION=0.80 - under main 

TEXTURE_BANDWIDTH_MULT=200 - Under display

These are the entries I've edited - I have a 1060 3GB and an i7 -4790K and get good fps and stunning scenery except for texture_size_exp I have that at 9 which you could try to make it look better since you have the 6GB version of the 1060

And for your FPS sake turn off dynamic lighting - its unoptimised by Prepar3D and will be fixed in the hotfix next week

Share this post


Link to post
6 minutes ago, Clashin_Jon said:

In your cfg try

TEXTURE_SIZE_EXP=8 - under terrain

FIBER_FRAME_TIME_FRACTION=0.80 - under main 

TEXTURE_BANDWIDTH_MULT=200 - Under display

These are the entries I've edited - I have a 1060 3GB and an i7 -4790K and get good fps and stunning scenery except for texture_size_exp I have that at 9 which you could try to make it look better since you have the 6GB version of the 1060

And for your FPS sake turn off dynamic lighting - its unoptimised by Prepar3D and will be fixed in the hotfix next week

Remove the texture exp line and uncheck detailed terrain in the p3d scenery options menu it does the same thing.

Share this post


Link to post

So HT didnt help me, im trying to tweak my P3D.cfg with ur tweaks i. Thanks a lot!

Share this post


Link to post
1 hour ago, 777200lrf said:

Remove the texture exp line and uncheck detailed terrain in the p3d scenery options menu it does the same thing.

I will when I can fix this ntddll.dll crash :)

Share this post


Link to post
34 minutes ago, cpt_muggz said:

Didn't help me again, i still got blurred textures.

Don't try to enable HT in BIOS, you have i5, there's no HT for i5. Rebuild(delete)your p3d.cfg and scenery indexes. Then try my settings 

The only difference - set shadow quality and shadow draw distance to medium. I use that now, no fps hit. After you set them, load the flight and close the sim. Rebuild(delete)shaders(shaders from AppData).

Try it again. If you still get the bluries, close the sim, open p3d.cfg and change TEXTURE_BANDWIDTH_MULT=30 to 150. 

If you get stutters, lower the value to 120 or 90. If you get low FPS after that, add FIBER_FRAME_TIME_FRACTION=0.15 under [MAIN] section of p3d.cfg. If you get blurries, increase it. Values from 0.15 to 0.20 should work fine. Don't use Affinity mask - it works until you add some quality addon sceneries, then will cause blurries. Hope this helps

P.S. Download Avsim P3D guide, and AVSIM latest CTD Guide - You will find here how to install latest C++ redistributables(allways install them after installing new addon)and many other usefull things

 

  • Upvote 1

Share this post


Link to post
4 minutes ago, lodestar said:

Don't try to enable HT in BIOS, you have i5, there's no HT for i5. Rebuild(delete)your p3d.cfg and scenery indexes. Then try my settings 

The only difference - set shadow quality and shadow draw distance to medium. I use that now, no fps hit. After you set them, load the flight and close the sim. Rebuild(delete)shaders(shaders from AppData).

Try it again. If you still get the bluries, close the sim, open p3d.cfg and change TEXTURE_BANDWIDTH_MULT=30 to 150. 

If you get stutters, lower the value to 120 or 90. If you get low FPS after that, add FIBER_FRAME_TIME_FRACTION=0.15 under [MAIN] section of p3d.cfg. If you get blurries, increase it. Values from 0.15 to 0.20 should work fine. Don't use Affinity mask - it works until you add some quality addon sceneries, then will cause blurries. Hope this helps

 

I did not look at the hardware close enough did not see the i5 that should mean he has to set very light autogen and a texture multiplayer 90 to start.

Share this post


Link to post

What version of Windows are you using? 

What version of NVidia drivers do you have installed?

Share this post


Link to post

lodesta! Thank you very much! I've tried your settings and my blurries are gone! Thank you!

Long and good life, Captain!

Share this post


Link to post
6 hours ago, lodestar said:

Don't try to enable HT in BIOS, you have i5, there's no HT for i5. Rebuild(delete)your p3d.cfg and scenery indexes. Then try my settings 

The only difference - set shadow quality and shadow draw distance to medium. I use that now, no fps hit. After you set them, load the flight and close the sim. Rebuild(delete)shaders(shaders from AppData).

Try it again. If you still get the bluries, close the sim, open p3d.cfg and change TEXTURE_BANDWIDTH_MULT=30 to 150. 

If you get stutters, lower the value to 120 or 90. If you get low FPS after that, add FIBER_FRAME_TIME_FRACTION=0.15 under [MAIN] section of p3d.cfg. If you get blurries, increase it. Values from 0.15 to 0.20 should work fine. Don't use Affinity mask - it works until you add some quality addon sceneries, then will cause blurries. Hope this helps

P.S. Download Avsim P3D guide, and AVSIM latest CTD Guide - You will find here how to install latest C++ redistributables(allways install them after installing new addon)and many other usefull things

 

Locking my FPS causes stutters on my system.  Do you get stutters at all?  It's perfectly smooth for me when I run unlimited with vsync at 30hz but locking it at any amount with or without vsyc causes stutters no matter what.  V3 I could lock and not get them but on V4 I do.  I get blurries on approach but takeoff is fine.

Share this post


Link to post
10 hours ago, sfgiants13 said:

Locking my FPS causes stutters on my system.  Do you get stutters at all?  It's perfectly smooth for me when I run unlimited with vsync at 30hz but locking it at any amount with or without vsyc causes stutters no matter what.  V3 I could lock and not get them but on V4 I do.  I get blurries on approach but takeoff is fine.

No, i don't get stutters, i can notice some mictostutters only if i look to the side when i am close to the ground in dense areas. Locking FPS improves scenery loading, i prefer it like this. It's a shame that we don't have real full screen with P3D, i miss 1/2 refresh rate from FSX, but ok :happy: Smooth enough if you don't overload P3D / system with extreme settings

Share this post


Link to post
4 hours ago, lodestar said:

No, i don't get stutters, i can notice some mictostutters only if i look to the side when i am close to the ground in dense areas. Locking FPS improves scenery loading, i prefer it like this. It's a shame that we don't have real full screen with P3D, i miss 1/2 refresh rate from FSX, but ok :happy: Smooth enough if you don't overload P3D / system with extreme settings

I only did testing at heavier airports because that's most of my compatible addons at this point.  But, I tried locking at a less demanding one and there were far less stutters.  I guess it's the same thing I had to do with V3.  In heavier areas run unlimited and deal with the blurries and with the less demanding areas I can lock it which helps a lot with sharper terrain.  Since the only airports I have working are FSDT and FB I suppose I'll have to wait until the smaller airports get updated installers before I do further resting.

Share this post


Link to post
1 hour ago, sfgiants13 said:

I only did testing at heavier airports because that's most of my compatible addons at this point.  But, I tried locking at a less demanding one and there were far less stutters.  I guess it's the same thing I had to do with V3.  In heavier areas run unlimited and deal with the blurries and with the less demanding areas I can lock it which helps a lot with sharper terrain.  Since the only airports I have working are FSDT and FB I suppose I'll have to wait until the smaller airports get updated installers before I do further resting.

Well, i tried locking my FPS to lower value in areas with FPS hit, and there are no stutters at all, as long as i can mantain target fps. But i'm not willing to go lower then 25fps, so i tried something else.

I played with some AFCAD files and i found they give me stutters and FPS hit until i recompiled them to new P3D V4 format using beta ADE for v4 - yes, there are some changes in BGL's from v3 to v4, see fsdeveloper forums. I'm waiting for some other tools there to be updated. 

My test was with some AFCAD file for EHAM. I had 18-23fps with original version on departure and approach. Then i recompiled AFCAD and FPS stays stable at 30(locked), no fps drop at all. 

I had FSDT and Flytampa installed, but i uninstalled them for now. They work, but i want to be sure all BGL files are recompiled for P3D V4.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now