urgeflaske

Moving shadows

Recommended Posts

Hi!

Im experiencing something weird in my P3D V4. When looking outside there are shadows from the clouds on the ground. But when i move around the shadows kinda follows my movement. They get bigger, smaller, changing shape and so on. I think it looks really bad and im wondering if anyone else see this in their sim?

Here the shadows look good. But just when i look either left, right, up or down the shadow changes it shape:

http://i.imgur.com/6KxSHdY.jpg

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

this problem was in v3 as well. apparently nothing can be done for it. It looks terrible

Share this post


Link to post

Oh really. That sounds bad.. best thing is to just turn off shadows then?

Share this post


Link to post

Yep same here I posted a video in another thread, immersion killing.  Imo the shadows are kinda messed up in P3Dv4.  I've come from FSX SE with the DX10 fixer and the shadows imo were much better in the VC.  In P3D v4 I have shadows appearing/disappearing when I pan around, depends on the angle of the sun/time of day etc its really annoying.

Share this post


Link to post

I can't say I've noticed shadows moving around.  And I've never seen them appear and disappear....I'll keep an eye out for this phenomena.

Share this post


Link to post
41 minutes ago, sidfadc said:

Yep same here I posted a video in another thread, immersion killing.  Imo the shadows are kinda messed up in P3Dv4.  I've come from FSX SE with the DX10 fixer and the shadows imo were much better in the VC.  In P3D v4 I have shadows appearing/disappearing when I pan around, depends on the angle of the sun/time of day etc its really annoying.

Could you post the video? I cant seem to find it

Share this post


Link to post

Another annoying problem is the shimmering of cloud shadows, or when the clouds are near or touching mountain peaks, they flicker and it looks bad. I wonder when LM will finally fix these annoyances once and for good. i really hope P3D v4.1 will finally address these shimmering shadows/clouds issues.

Share this post


Link to post

This as fixed somewhat by increasing my shadow draw quality but its still not completely eliminated

This one is apparently just how it is, hope there is a fix soon

The cloud flickering across peaks is annoying as well, something which used to really bother me in FSX and I believed was a non issue in P3D because the clouds are volumetric.

Share this post


Link to post

The second video shows what is really annoying also on my end. I do not really understand that not more people are complaining about this issue.

EDIT: you should use the second video in the P3D forums to get some feedback from there. I wonder if they are aware of this...

What I also have in addition to this: I often see some kind of squeezed shadows when looking around out of my vc that move along the ground just next to my plane, an issue already existed in v3 and also never resolved. Hard to describe, I might also make a movie to illustrate it.

  • Upvote 1

Share this post


Link to post

Yea I will post the 2nd video over at LM, someone else suggested that on the other thread.  I believe there are some fundamental issues fixed in 4.1 so be interesting to see what they are.  For me DL lights takes too much of a toll on FPS particularly using 4 x SSAA (I have a 1070).  4 x SSAA is needed to cure the horrible flickering and shimmering at night time.  Anything less and it looks a complete mess.  Not to mention these dodgy shadow issues as well.

  • Upvote 1

Share this post


Link to post

You should post both videos up. I also get that annoying rain issue where it randomly stops and comes back for no reason, not sure whats causing that. Really hope LM will fix these issues once and for all.

Share this post


Link to post
3 hours ago, sidfadc said:

This as fixed somewhat by increasing my shadow draw quality but its still not completely eliminated

This one is apparently just how it is, hope there is a fix soon

The cloud flickering across peaks is annoying as well, something which used to really bother me in FSX and I believed was a non issue in P3D because the clouds are volumetric.

About the first video: try increasing cloud shadow cast distance. Should solve the problem.

Happy Flying,

Share this post


Link to post

Yes this is what I said in my post above "This as fixed somewhat by increasing my shadow draw quality but its still not completely eliminated"

Share this post


Link to post

Increasing shadow quality isn't a fix, its just a temporary workaround. LM needs to fix this once and for good. Some people don't want to run with a setting of higher or above for shadows due to an affect on system performance.

Share this post


Link to post
59 minutes ago, sidfadc said:

Yes this is what I said in my post above "This as fixed somewhat by increasing my shadow draw quality but its still not completely eliminated"

edit: humbly apologize gents, "shadow draw distance" not "cloud shadow cast distance" (that was for V3.x).

Share this post


Link to post

@sidfadc: do you use PTA? I got this possible fix from the P3D Forums:

"in the cloud section, deactivate "cloud shadow depth" and "cloud shadows extended size"

I will try this as soon as I am home, as I use PTA, I hope this will fix it on my end.

Share this post


Link to post
34 minutes ago, AnkH said:

@sidfadc: do you use PTA? I got this possible fix from the P3D Forums:

"in the cloud section, deactivate "cloud shadow depth" and "cloud shadows extended size"

I will try this as soon as I am home, as I use PTA, I hope this will fix it on my end.

Yes I do, thanks will check out my preset.

Share this post


Link to post
1 hour ago, AnkH said:

@sidfadc: do you use PTA? I got this possible fix from the P3D Forums:

"in the cloud section, deactivate "cloud shadow depth" and "cloud shadows extended size"

I will try this as soon as I am home, as I use PTA, I hope this will fix it on my end.

Interesting, I'll have to try this as well with PTA.

Share this post


Link to post

Interesting discussion.

I set my cloud shadows to the max I haven't noticed this yet.

I'm going to trying flying today and see if I can replicate this and the rain thing.

Bryan

Share this post


Link to post

 

21 hours ago, AnkH said:

@sidfadc: do you use PTA? I got this possible fix from the P3D Forums:

"in the cloud section, deactivate "cloud shadow depth" and "cloud shadows extended size"

I will try this as soon as I am home, as I use PTA, I hope this will fix it on my end.

I only have cloud shadows extended size checked in PTA.  Unchecking this didn't make any difference.  I still see cloud shadows popping up and disappearing when I pan around.

Share this post


Link to post

Same here, unchecking this option does not fix it. I will try with PTA completely deactivated once and see, if this helps. I start to guess that without fix from LM, we will always see this "effect" to a certain amount. It seems that it is related to the fact that the engine does render only cloud shadows that are in sight to reduce load, this would explain the phenomenon.

Share this post


Link to post
Quote

What I also have in addition to this: I often see some kind of squeezed shadows when looking around out of my vc that move along the ground just next to my plane, an issue already existed in v3 and also never resolved. Hard to describe, I might also make a movie to illustrate it.

I think that I know what you mean by this. I only just realised this weekend that I did not have shadows enabled for my UK2000 airports (I needed to activate Sim Objects to receive shadows), and I noticed a shadow "blob" to the left of my aircraft during push back. I also noted that shadows of various objects moved when I changed position (eg. the shadow of a light post moved down the side of the terminal building at EGPD Aberdeen as I pushed back from the gate).

Very strange indeed. I am seeing this in P3D v3.3.5, so evidently the issue has not been corrected for v4.

My shadow quality is set to High.

Share this post


Link to post

Does anyone know what is the reason for this little visual bug? Check shadows on the left, just above the grey marks of the parking positions. Those shadows move around when flying and are only visible at certain view angles.

2017-8-11_17-35-51-343pb79.jpg

Share this post


Link to post

AnkH is that on a 3rd party airport, if it is it may be 3rd party's problem. I see the oil marks on most of the parking spots I see in the pic. It could be the settings they used to make oil spots to look more real.

Share this post


Link to post

Regarding the rain starting and stopping, may I ask if you are using Active Sky? I see this only when flying with AS running. I believe this is the way that AS presents intermittent rain showers. If you look at the radar, you should see the small clusters of rain showers moving across the screen. I'm not too fond of the abrupt start and stop of the rain, but I doubt that Hifi can do very much to control it. That is something that LM would have to implement.

ps, this is with detailed precip enabled.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now