bhorv67

P3d v4 4k 30hz monitor quetions

Recommended Posts

I run v4 on a 4k monitor which has the capability to run at either 60 or 30hz. I've seen posts where 30hz can give a very smooth result, but I can't seem to get the settings figured out. 

My system:

Asus Z87 Pro

i7 4790k OC @ 4.8

Strix 1080ti OC @ 2g

16g DDR3 2133 ram

500g SSD - Win 10, 1tb HD - P3d

Most of the time, I'm getting about 20fps on the ground, but there's a lot of stutters when the camera moves around. In the air in dense scenery, I'm getting 40-50+

I tried running the monitor at 30hz and the only change I made in P3d was to turn vsync and triple buff on, leaving framerate at unlimited. The result was pretty bad. The stutters were worse and half way through a flight p3d crashed. I tried uninstalling and reinstalling the p3d client, as I've heard this may fix issues with stutters some have had - didn't help me.

The graphics settings are pretty much all on max, with autogen at high (buildings 2 clicks below max). Textures are set to 4k, anti-aliasing is SSAA 4x. FXAA is off. Haven't messed with nVidia inspector at all. 

I've seen settings in the nvidia control panel that vsync can be set at 1/2 refresh, which seems really confusing. If the monitor is running at 30, does that mean vsync will lock to 15? Or do I leave the monitor refresh at 60hz, and run 1/2 refresh locking to 30?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Set in game sync to on with triple buffering on. Try lock frames from 30-33 or unlimited.  Set everything to default in inspector. This works for me with monitor at 30 hz 

  • Upvote 1

Share this post


Link to post

Will do thanks. I've read that setting the frame limiter to anything but unlimited can have undesirable affects on performance, but I'm going to try and see what happens.

Share this post


Link to post

Locking frames to 30 gave me 5-7 fps in the sim. Unlimited is where it should be. With vsync on, I'm locked at 30. 

Share this post


Link to post
7 hours ago, bhorv67 said:

The graphics settings are pretty much all on max, with autogen at high (buildings 2 clicks below max). Textures are set to 4k, anti-aliasing is SSAA 4x. FXAA is off. Haven't messed with nVidia inspector at all. 

Not sure why you would need SSAA x4 with 4k monitor, i recon that would be a big unnecssary performance hit. 

I have 4k monitor (30hz) and run MSAA x 4 with slight shimmering, however can maintain 30fps with relative ease.

Share this post


Link to post
3 hours ago, branks737 said:

Not sure why you would need SSAA x4 with 4k monitor, i recon that would be a big unnecssary performance hit. 

Well that would depend on the size of the 4K monitor.
A big 4K could have a pixel density similar to a small 1080p monitor so it might need a similar AA.

gb.

Share this post


Link to post
11 hours ago, bhorv67 said:

I've seen settings in the nvidia control panel that vsync can be set at 1/2 refresh, which seems really confusing. If the monitor is running at 30, does that mean vsync will lock to 15? Or do I leave the monitor refresh at 60hz, and run 1/2 refresh locking to 30?

Unfortunately NVCP 1/2 refresh does not work with P3D.

gb.

Share this post


Link to post

I never could get my 4K running decent at 30 hz. Even after dropping all the sliders to the left. I went back to 60 and turned all sliders to the right and have been happy ever since.

Share this post


Link to post
15 minutes ago, JasonW said:

I never could get my 4K running decent at 30 hz. Even after dropping all the sliders to the left. I went back to 60 and turned all sliders to the right and have been happy ever since.

Stupid question: How does one set the refresh rate of the TV?

Share this post


Link to post
2 minutes ago, Canuck said:

Stupid question: How does one set the refresh rate of the TV?

Nvidia control panel should list all of your monitors options

  • Upvote 1

Share this post


Link to post
12 hours ago, JasonW said:

I never could get my 4K running decent at 30 hz. Even after dropping all the sliders to the left. I went back to 60 and turned all sliders to the right and have been happy ever since.

I'm having the same issue - 30hz is not working out well. Even with vsync on (in p3d), I'm getting a lot of stutters, long frames, and the 1080ti is not performing well. 

Putting the monitor back to 60hz, I still get 15-25 on the ground, but north of 70 in the air. There's either something in the cfg that's not right, or something running in the background on my system that's using too many resources. 

Share this post


Link to post

First go to an airport which gives the worst framerates. Adjust your setting, so that you have there 30+ FPS, afrter this try again with VSync and Triple and unlimited frames the 30 Hz. This should be easy with your system. I do this with same cpu at 4.4Ghz and a 1070.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now