N2382R

Navigraph Extension CTD

Recommended Posts

Recently installed a fresh copy of P3D4 along with the Phenom 300 and the Navigraph Extension. Bird loads fine and flies fine. However, any time I try to enter a flight plan, after entering the waypoint and hitting enter, I get a CTD. Anyone encountered a similar issue? I've installed the Carenado Meridian along with its Navigraph expansion and that operates flawlessly without any CTDs.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi.

Yes I am having the same issue.

It occurs if you hit the FLP button too straight CTD.

I'VE told Carenado about this but I have no doubt they will deny any fault/bugs as they usually do.

The aircraft in it's current state is buggy and not fit for purpose, very annoying.

 

Share this post


Link to post
Share on other sites

Hi.

I haven't had the time to make a test flight yet but what kind of CTDs did you get?

Cheers,

Cees

Share this post


Link to post
Share on other sites

For me at least, the CTD would originate then I enter my desination airport. It would be a symmap.dll error. I did a complete reinstall of everything and am now getting a CTD when I try to select a procedure for any field. The CTD varies between different dlls.

On a side note, the updated install is also missing the "Takeoff Okay" or "No Takeoff" soundbites.

This is one of my favorite birds and it's frustrating to be grounded.

Share this post


Link to post
Share on other sites

I have tested the aircraft with both navigraph extension installed and without both with fresh installs.

If you press any keys on the G1000, ie FLP, PROC keys to access the FP or Procedure pages the aircraft will CTD no matter if you are on the ground or in flight.

No matter what I do I always suffer a CTD.

I honestly believe there is a problem with the G1000 as this is the only thing that causes a CTD for me anyway.

More annoying is Carenado must know this.

As of yet (3 days) I have had no reply from them.

My first and last purchase which is a shame as the detail is stunning but eye candy is all well and good but if the thing is unusable then that means nothing,

Any solution to this would be good.

Surely other users must be experiencing this issue.

 

 

Share this post


Link to post
Share on other sites

The interesting bit is that I have the Meridian with the Navigraph extension, and short of a few annoying bugs (the first key stroke when entering a navaid always results in a double letter entry for example) it works flawlessly. No CTDs or anything. So I think that either the update to the G1000 on the Phenom was botched, or it still isn't fully x64 compatible. Needless to say, I'm more and more tempted to just install the GTN mod.

Share this post


Link to post
Share on other sites

Looks like the Phenom 100 is plagued by the same problem.

 

Glad it's not just us.

Share this post


Link to post
Share on other sites

Do you Guys see the waypoint namens in the G1000? 

If not it's maybe a Fonts Problem 

Bruno

Share this post


Link to post
Share on other sites

HI,

Yes the waypoints are visible on the FP page.

It seems to make no odds if you create the plan through P3D without the Navigraph extension installed then the plan is automatically seen on the FP page but you try go to the PROC page bang CTD.

Attempt to create a FP without Navigraph and not through P3D press FP/PROC keys bang CTD.

Then install Navigraph extension attempt a FP/PROC guess what yep CTD!!!!!

The plane is faulty simple as and the developers at Carenado need to sort it out or do some testing.

I've even tried it  without third party add ons, sigh!!!!!!!!! CTD!!!!! 

Share this post


Link to post
Share on other sites

Same problem here.

After different test flights I also got the Symmap.dll CTDs.

The only thing we all can do is to report it to Carenado. They will come up with a fix.

Cheers,

Cees

Share this post


Link to post
Share on other sites

I am also getting the symmap.dll CTD.  Everyone who is suffering from this crash should run AppCrashView - http://www.nirsoft.net/utils/app_crash_view.html and look for the faulting module.  Let's see if everyone is getting the same faulting module.  I have been researching this crash over the past few days.  The symmap.dll CTD has been around for awhile with no known solutions found.  Individuals would go to Lockheed Martin forums and complain about the crash but no solution found and the individuals did not indicate what aircraft or what they were doing when the crash occurred. 

I load P3DV4, the Phenom 300, Location KDCA (using Drzewiecki Wash X).  I also have UTX2 installed and running.  I set up a flight from KDCA to KJFK (Drzewiecki Airports 2).  I use the default flight plan provided by the G1000 by clicking on Proc, going to Departure, and then clicking ENT all the way down to Load.  If I click on FPL and then go down to the waypoint SIE, it may or may not crash immediately but, if I continue to go up and down around waypoint SIE, it crashes.  If I do not use the FPL and just set up Departure and Arrival and take off, no problems until near the approach at JFK and then crash.  Same faulting module.

If I disable Airports 2 and Washington X and UTX2, I have no problems with the FPL.  Enable them again and the crashes continue.

The G1000 works perfectly so do not think that's the problem.  I think it is in the problem is with the Navigraph installation (not the Navigraph Extension).  I just reinstalled the Phenom 300 and the Navigraph Extension.  Ran the same scenario as above and I cannot replicate the crash anymore.  So it appears, with the default Navigraph Extension Nav Data, there is no issues. Only after installing the updated AIRAC from Navigraph.  

When the Navigraph Extension is installed, I have the following directory:

CarenadoNavigraph

   Navigraph

       NavData

           PROC

The database file "carenavigraph" is located under the CarenadoNavigraph directory.

When I download the latest AIRAC from Navigraph, it installs another directory under the NavData folder above as follows:

   Navigraph

       NavData (PROC folder under here (default)

          NavData (PROC folder under here (Navigraph)

So I think the G1000 is seeing two different NAVDATA and that's causing the CTD's.

The placement of the folders is probably my fault as I did not show where the Addon was located on my Drive properly.  I had it pointed to the NavData folder under Navigraph instead of the Navigraph directory.  I don't remember if I did that or Navigraph did that (I'll blame Navigraph :biggrin:).  I corrected this at Navigraph and it now overwrites the default NavData and Proc folders.  Now need to test to see if this fixes the problem.

Best regards,

Jim

EDIT:  Got the CTD with the latest AIRAC data from Navigraph.  Returned to the default NavData I had saved.  CTD.  Do not know why it worked when I first reinstalled it and now, returning back to the default data, it crashes.  This is all way above my paygrade. 

EDIT2:  Copied all fonts in the P3DV4 directory to the Windows/Fonts directory as suggested by Carenado.  Still have crashes.

EDIT3:  I have FSX set up the same as P3D with the same scenario as above when making a flightplan.  No CTD's.  The G1000 works flawlessly and I can add waypoints, delete waypoints, go through the FPL without any problems.  Flew to JFK successfully.

EDIT4:  Have the Carenado 46 Malibu Meridian installed with the Navigraph Extension.  Loaded a FPL as above from KDCA to KJFK.  No problems.  No CTD's.  CTD's are only occurring in the Phenom 300 and Navigraph Extension installed in P3DV4.  This narrows it down to the G1000 in the Phenom 300 for P3DV4 as the Malibu Meridian also uses the 64 bit gauges and carenavagraphx64.dll.

EDIT5:  Just noticed that Carenado installer put an entry in the dll.xml for the wrong version of the CMeteoXml.dll.  The entry shows CMeteoXml.dll should be loaded.  P3DV4 is 64 bit and the CMeteoXmlx64.dll should be loaded instead.  Going to see if this makes a difference.  Still did not see crashes in Malibu Meridian but then, I had disabled the CMeteoXml entry in the dll.xml. 

EDIT6:  Loading the CMeteoXmlx64.dll did not fix the problem.  Will report issue to Carenado.

Share this post


Link to post
Share on other sites

Finally an answer from Carenado,

 

 

Good Morning.

I would like to make you aware of a serious bug in the above aircraft.

Once in flight if you select the flight plan it causes a CTD.

Reading the forums this is a major issue with the aircraft and I am not alone.

Can you test or advise re the problem as the aircraft is not flyable.

Regards

Wayne.

Carenado Support Yesterday at 12:15

Greetings,
This is a known issue, caused by P3dV4 and will be corrected in the next version P3Dv4.1 releasing soon.
Regards

Carenado.

Add file or drop files here

  • Upvote 1

Share this post


Link to post
Share on other sites

Like others, I have been encountering similar CTD's re: the Phenom 300 G1000. I had read recently in the forums where the symmap.dll errors were a known issue, and being reviewed by LM. While we wait, has anyone heard any rumors/chatter/etc. as to when a v4.1 upgrade might possibly be released? I certainly understand the uncertainty of rumors, but just trying to get a rough picture. Is this something that is short enough that we can wait on, or is it time to move on to another P3D aircraft, i.e. TDFI Boeing 717?

Mike

 

Share this post


Link to post
Share on other sites

Not to add insult to injury, but has anyone else noticed that the "T/O Okay" or "NO Takeoff" sound files are missing in P3dV4? Or is it just me?

Also, on those that have the Meridian with the Navigraph extensions installed, are you getting the annoying double press on the first letter of an entry? Minor annoyance, but would definitely save some time if there's a way to fix it.

Share this post


Link to post
Share on other sites
On 9/4/2017 at 8:12 PM, Redders9606 said:

This is a known issue, caused by P3dV4 and will be corrected in the next version P3Dv4.1 releasing soon.

So this is a P3DV4 issue vs Carenado.  Good news about an update to P3D soon!

On 9/5/2017 at 11:20 AM, orbmis said:

I had read recently in the forums where the symmap.dll errors were a known issue, and being reviewed by LM.

I believe I was the starter of this rumor in the AVSIM CTD Forums but believe it is simply a rumor.  I have tried to find the link where it stated it was a known issue and LM was working on it but Google won't show it to me anymore.  It would be nice if this is fixed in the next version of P3Dv4.  But, during my Google searches, I have seen this crash as happening back in previous versions of P3D too and no known fix.  Of course there is a fix.  It's just that no one may be working on one.

I installed and uninstalled the Phenom 300 and Navigraph Extension so many times times I have run out of installs and have requested more (okay, just checked my e-mail and my installs have been reset - fast action by Carenado.  Thanks!).

EDIT:  It was fixed by LM in P3DV4.1 as stated above.

Share this post


Link to post
Share on other sites

I just installed P3Dv4.1 and so far I do not get the problems with the crashes associated with the NavData and modifying the FPL.  I tried everything to cause the crashes I was getting in the past and could not get the sim to crash.  So, it looks like the response from Carenado, as posted above, that it was a problem with P3Dv4 and it would be fixed in v4.1 was correct.

Share this post


Link to post
Share on other sites
50 minutes ago, Jim Young said:

I just installed P3Dv4.1 and so far I do not get the problems with the crashes associated with the NavData and modifying the FPL.  

Hi Jim,,

That is very good news. To help along the way, did you do an uninstall client, followed by a new install client, or did you do a full 100% clean re-install?

Thanks,

Mike

 

Share this post


Link to post
Share on other sites

I uninstalled Client, installed new Client.  Nothing else.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now