Hayden Robertson

0xc00005 - FSX:SE CTD every flight

Recommended Posts

Hello, up until a few weeks ago when i reinstalled FSX:SE it's been crashing to desktop every flight, I have a few addons in FSX but not many, I can tell for sure that none of my addons are causing it because I tried it with no addons and it still crashes to desktop.#

Addons:

PMDG 777

PMDG 737NGX

GSX

AS16 

Aerosoft a318/a319/a320/a321 

Aerosoft Genoa X

UK2000 Manchester

 

System Specs:

i5 4460k 3.2GHZ

Geforce GTX 960

126GB SSD

16GB  RAM

 

FSX is installed on M:\Steam\steamapps\common\FSX

I've reinstalled FSX at least 10 - 12 times, at this point I don't even know at this point.

The CTD happens when I'm on a flight on VATSIM and displays the exception code 0xC000005 

Log Name:      Application
Source:        Application Error
Date:          29/09/2017 18:47:20
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      DESKTOP-NU7SUG9
Description:
Faulting application name: fsx.exe, version: 10.0.62615.0, time stamp: 0x559f9a9a
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc000041d
Fault offset: 0x142c50b0
Faulting process ID: 0x22b4
Faulting application start time: 0x01d33948f2ed3473
Faulting application path: M:\Steam\steamapps\common\FSX\fsx.exe
Faulting module path: unknown
Report ID: 95bab142-e6e7-4459-9389-518fdfdf9465
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2017-09-29T17:47:20.679573300Z" />
    <EventRecordID>3633</EventRecordID>
    <Channel>Application</Channel>
    <Computer>DESKTOP-NU7SUG9</Computer>
    <Security />
  </System>
  <EventData>
    <Data>fsx.exe</Data>
    <Data>10.0.62615.0</Data>
    <Data>559f9a9a</Data>
    <Data>unknown</Data>
    <Data>0.0.0.0</Data>
    <Data>00000000</Data>
    <Data>c000041d</Data>
    <Data>142c50b0</Data>
    <Data>22b4</Data>
    <Data>01d33948f2ed3473</Data>
    <Data>M:\Steam\steamapps\common\FSX\fsx.exe</Data>
    <Data>unknown</Data>
    <Data>95bab142-e6e7-4459-9389-518fdfdf9465</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

In this case it's a 0xc000041d exception but it's either a 0xc000041d or 0xc00005

 

EDIT: I've noticed a "pattern " the exception code switches between 0xc000041d and 0xc00005 {don't if that is coincidence or what}

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There is no solution for exception code 0xc0000005 (Memory Access Violation) .  Same goes with Exception Code 041d (STATUS_FATAL_USER_CALLBACK_EXCEPTION).  Means nothing and the information is insufficient to find a solution.  The exception codes are common, especially 0005, and appear in almost every crash, not only for FSX-SE, but crashes involving any Windows application ever developed.

In your case, when the crashes occur in VATSIM, it is most likely an issue with the client that you use to use VATSIM (PCPilot?)  You need to go to VATSIM and find out why your client is crashing.  Did you install all of those legacy Simconnects in the FSX-SE folder?  I do not own FSX-SE but if FSX-SE is not communicating properly with VATSIM, you will crash everytime.

Best regards,

Jim

 

Share this post


Link to post
Share on other sites
2 hours ago, Hayden Robertson said:

vPilot is used to connect to VATSIM, the simconnects install automatically when FSX Steam is installed.

Yes, yes!  That's the name of the client!  Thanks.

Share this post


Link to post
Share on other sites

Installed again, and nope - still doesn't work. I'm actually thinking of uninstalling and just leaving it in my steam library seen as it doesn't work still. 

Share this post


Link to post
Share on other sites

Had he had the chance, I'm sure Jim might have told you that uninstalling and resinstalling FSX:SE wouldn't work for this problem.

I just wanted to check a few things.

1. Is User Account Control Disabled (Slider set all the way down)?

2. Were you running FSX:SE "As Administrator"?

You might also take a screen shot of the MS C++ Redistributables that are installed on your system (under the Windows Control Panel and Programs and Features).

 

 

Share this post


Link to post
Share on other sites

Couple of things:

FSX:SE only installs 62615 (SE) and 61259 (XPACK) because it is the full FSX package includes Acceleration. However with older addons often 61242 (SP1) is used because they Also work with only FSX when Acceleration in not installed, even 60905 (RTM) might be used in rare cases. So Installing FSX:SE DLC will work but some addons might need one of the others so that's a possible source of errors.

Normally FSX:SE is set to run as administrator since it is specified in the exe file manifest, when the icon is used it elevates to admin. Mostly due to its interaction with the steam menu. Since it runs as admin it acquires access to the ProgramData folder through Admins, FSX:SE does not have User group access there where the scenery config is found. So it's possible an addon that's not savvy and does not self elevate to admin does not install or set something in the scenery.cfg or that folder. So that's a possible source of errors.

Even though set to run as admin the Program Files folder Users group has the Modify permission in the steamapps folder so installing addons into the FSX:SE folder that need write permission already work.

Run the sim stock to test it before adding any addons use only vPilot, I think that works OK and on 61259 but don't quote me.

 

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now