Zimmerbz

Strange with 4.1

Recommended Posts

Question for you all.  I installed 4.1 by downloading and running the full install.  I was thinking I would have to re install and update all of my addons. After running the exe, I load up P3d and everything is still there.  All of my add on airports and planes are still there. I checked and it said 4.1. I did the asca and AS16 updates but nothing else.  It even appears that Orbx is running even though I didn't update. Same with black marble.  Could this be right?  Or did I do something wrong?  I was going to install the pta update but thought I'd check first. Thanks

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I did the same thing and it's a well known fact that I don't do anything wrong. :cool: Actually, I ran the full installer over the existing install. All good. Then I read somewhere that you shouldn't do that, so I uninstalled everything via Programs and Features then REinstalled the full Monty. Still 'All Good'.

Relax.

  • Upvote 1

Share this post


Link to post

Easiest way to check is go into the start menu, type "Add or Remove programs" into the search bar, then find P3D in the list of programs and it will show the version number beside it. The one you are looking for is the one with the biggest file size. If that says 4.1 then you're golden. Or if you just installed the client then check next to the client and vice versa.

Share this post


Link to post

When you uninstall P3D using control panel - uninstall, it only removes what P3D installed and leaves everything else (add-ons) untouched including those in the P3D folder. 

I did Poppets procedure and did a complete uninstall mainly to see how it would work. I was happy to see add-ons installed in P3D 4.0 were still good in 4.1. Just make sure when reinstalling to install into same folder location.

With Orbx you have to run FTX Central to reactivate that scenery.

Share this post


Link to post

Ok so I checked in the add/remove programs and it says Prepar3d v4, client, scenery, content with a date of 10/10. I don't see 4.1 there.  However, when I am in the sim and go to help, about, while in the sim it says version 4.1.7.22841.  Am I good? 

Share this post


Link to post
16 minutes ago, Zimmerbz said:

 ...in the sim it says version 4.1.7.22841.  Am I good? 

If anything should know, P3D should know. Have a look in Options\Weather and see if there's an option for windshield effects. And yes, all my add-on are there.

Share this post


Link to post
24 minutes ago, Ron Attwood said:

If anything should know, P3D should know. Have a look in Options\Weather and see if there's an option for windshield effects. And yes, all my add-on are there.

Yes, windshield effects are there. 

Share this post


Link to post

This has worked this way for years. I *rarely* have to reinstall addons when I do a full install as long as I keep my folder structure intact. If an addon modifies any core files or if it does version checking, those will have to be reinstalled. At max I can do a complete reinstall in less than an hour including all my addon aircraft and sceneries.

Usually the problem comes with an addon that is "compatible" with P3D but wasn't designed for it and might have custom files here and there, like Tongass.

Vic

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now