samjb

my fsx se runs rubbish, why?

Recommended Posts

my fsx se with the pmdg 737 runs at 10-15 fps with default scenery and no other add-ons. my pc is an amd 8 core processor 4.2ghz and 16 gb of ram and a gtx 1060 3gb. can someone help me solve this issue.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Within FSX:SE what are your graphics sliders set to?

Turn your ground traffic right down - that is an fps killer. Tone down AI and airport ground traffic too, as well as ships & boats.

 

Oh and as it's your first post - WELCOME TO AVSIM!!

Share this post


Link to post
Share on other sites

The animated jetways are also CPU cycle eaters, I keep those turned off.  Ground shadows and aircraft self-shadowing will also eat up CPU cycles.  My advice, start FSX with all of the sliders set to the left, then slowly increase each setting and test to see how it impacts your computer.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now