Rocky 114B

UK Scenery and Airports

Recommended Posts

Hi Folks,

Just transferred over to P3D V3 from FSX and looking for some good UK scenery and airport files.

I have the FSX versions of VFR photographic scenery and UK2000 airports, but not too sure if I can use these directly with P3d v3, and if so with the install pick up I'm using P3D and not FSX.

Any help and advice - much appreciated.

Rocky 114B

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

UK2000 scenery works well with P3D, but why are you using v3 when v4.1 is 64 bit and so much better?

Bertie Goddard

Share this post


Link to post

Gary does not charge separately for FSX and P3D versions of his airports. He has now created a universal installer that checks which flight simulator you have installed (P3D/FSX/FS9), so you only need to download the updated versions of each of your airports (assuming that you have the latest versions of each of them; this will not work with older versions).

Share this post


Link to post

Just beware that if you have Playsim DVD versions of the UK2000 scenery rather than the downloads you can't get updates and have to do some kludges to get the originals to work in V4.

Fine in V3 though.

Cheers
Keith

Share this post


Link to post
4 hours ago, Christopher Low said:

Gary does not charge separately for FSX and P3D versions of his airports. He has now created a universal installer that checks which flight simulator you have installed (P3D/FSX/FS9), so you only need to download the updated versions of each of your airports (assuming that you have the latest versions of each of them; this will not work with older versions).

I don't think this is 100% true. I had to pay a fee of 10 quid or so for the 64 bit Gatwick. Although yes, the other airports I had were free upgrades.

Share this post


Link to post

That's because you upgraded from Gatwick v3. This discounted price is available to ALL users of Gatwick v3 (whether they are using FS9, FSX, P3D v3 or P3D v4).

Share this post


Link to post
Just now, Christopher Low said:

That's because you upgraded from version 3 to version 4. 32bit users of Gatwick v3 also have to pay an upgrade fee if they want to use v4.

Yeah that was it. Sorry Christopher, I didn't mean to come across as harsh. I'm loving the new Gatwick. I was only saying it because as far as I can see, there is no way possible to use the old Gatwick in P3Dv4, like I can with other UK2000 airports. In other words, Gatwick was the only v3 airport that didn't get a free upgrade.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now