flightwise

Flight crashes in cockpit view.

Recommended Posts

I recently upgraded to windows 10 and have the latest creator update, I just installed Flight and the latest toolkit but for some reason when I switch to to cockpit view, flight crashes, I have tried 3 different aircraft but same thing happens, I was thinking maybe I should uninstall toolkit and see if it does it without it but not sure if that's the way to go. I didn't try Flight before installing the toolkit but why remove the toolkit if it may not be the cause. If I removed the non GWFL install of toolkit do I just reinstall toolkit if I want to install the GWFL version?  I don't remember where error logs for flight are kept? Also did multiplayer ever get pursuit with Toolkit is or that just not going to happen?

I would appreciate any help.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There are log files in %userprofile%\AppData\Roaming\Microsoft\Flight. Maybe the game reports the error in ContentErrors.log.

You need GfWL mode for multiplayer.

  • Upvote 1

Share this post


Link to post
Share on other sites

Unfortunately checking ContenErrors.log shows nothing, I understand you need GFWL for multiplayer but is there a server or do you have to find others to connect with? I guess I will uninstall FlightKit and see if Flight is still doing that, I will report back when I know. Thanks for trying.

Share this post


Link to post
Share on other sites

So I uninstalled FlightKit and the problem persists so it must be something with Flight, it worked fine on Windows 7 so I can only conclude it's either Windows 10  or has something to do with my now having a AMD GPU/Freesync, I have disabled Freesync changed video settings to minimum no joy, I should mention the behavior is not a crash to desktop, it goes back to the Yellow Load Banner and just keeps trying to reload and hangs, any thoughts? I could just use it without the cockpit view but the problem is if you cycle through the views it gets stuck there and stops responding.  Is there another place I should be posting this, is Stonelance still monitoring bugs? 

Thanks

Share this post


Link to post
Share on other sites

I have now uninstalled Flight and reinstalled, still same issue, I'm out of ideas if anyone has the slightest hint as to what's causing this please let me know. One last thought and observation in Task Manager Flight shows as 32 bit, from what I understand a lot 32 bit applications have problems with Win 10, I have tried running in compatibility modes Win 7 and Vista but still no joy.

Thanks

Share this post


Link to post
Share on other sites

Hi

If it is of any help, I'm running Flight with win 10 (64bit) and the latest Autumn creators update and it's running fine, even in cockpit view.

-eelis-

Share this post


Link to post
Share on other sites

When you went to Windows 10 did you do the online upgrade from Windows 7 or did you purchase and reinstall a complete package?

The reason I ask this is I did the online update from W7 Pro and all was well until one of the updates earlier this year created a huge number of problems. Apparently my system configuration and the update didn't agree with a number of programs. It took me a good amount of time to establish what was causing the problem by isolation programs. I never did find the root cause other than the update and an incompatibility somewhere in my system. 

I finally did a complete system rebuild and installed W10 Pro from a purchased disk.  Absolutely no problems since.

This may not be your problem, however. But in any case I wish you luck.

 

 

Share this post


Link to post
Share on other sites
11 hours ago, eelis said:

Hi

If it is of any help, I'm running Flight with win 10 (64bit) and the latest Autumn creators update and it's running fine, even in cockpit view.

-eelis-    I suppose that may rule out Win 10 being the culprit than, I'm thinking it might be related to my GPU.  Thanks for the input.

 

Share this post


Link to post
Share on other sites
9 hours ago, 188AHC said:

When you went to Windows 10 did you do the online upgrade from Windows 7 or did you purchase and reinstall a complete package?

The reason I ask this is I did the online update from W7 Pro and all was well until one of the updates earlier this year created a huge number of problems. Apparently my system configuration and the update didn't agree with a number of programs. It took me a good amount of time to establish what was causing the problem by isolation programs. I never did find the root cause other than the update and an incompatibility somewhere in my system. 

I finally did a complete system rebuild and installed W10 Pro from a purchased disk.  Absolutely no problems since.

This may not be your problem, however. But in any case I wish you luck.

 

 

Its a clean Windows 10 that came with this new PC all I did was update twice the last being Creator Update, also with what 188AHC shared I'm starting to to doubt it's Win10 and more likely related to my GPU, thanks for the info, I hope I can figure it out as I would like to still be able to enjoy Flight and with this bug it's going to be impossible.

Thanks

Share this post


Link to post
Share on other sites
On 27.10.2017 at 10:43 PM, flightwise said:

Unfortunately checking ContenErrors.log shows nothing, I understand you need GFWL for multiplayer but is there a server or do you have to find others to connect with? I guess I will uninstall FlightKit and see if Flight is still doing that, I will report back when I know. Thanks for trying.

The game still connects to Microsoft's own multiplayer servers.

By the way, I also just played the game again with the Fall Creators Update being installed on my PC, and everything still works fine here including cockpit views.

Share this post


Link to post
Share on other sites

Still connects to the MS MP servers, I did not know that, well I hope I can get to try that, I don't think I have the Fall Creators Update yet in fact I'm about to install it tonight, so maybe that will help although I'm still wondering if it has something to do with my GPU.

Share this post


Link to post
Share on other sites

Well I now have the Fall Creators Update and sorry to say still  have the same issue, I wish I could get some kind of advice on how to fix this?

Thanks

Share this post


Link to post
Share on other sites

Maybe try a different version of the driver.  If you look in the windows error logs it should show what the crash information is, but usually that is not helpful.  If you are able to get a crash dump, then I might be able to take a look at it to see what the problem is.  These instructions should hopefully work:

- Open regedit and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps\Flight.exe.  You will probably have to create the Flight.exe folder
- Create a string key called DumpFolder with the path to a folder where you want the dump saved
- Run Flight.exe and recreate the crash
- Check the dump folder for a .dmp file.  You'll need to upload it somewhere and post the link here, or sent the link to flighttoolkit@gmail.com (the file is probably too big for email)

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Stone, thanks for the reply, so it's working now, all I know is that I recently updated to creator update and I think updated my GPU driver I can't say which one did it but it's working, I will use the info you gave me here for future reference. One thing I'm stuck on right now is I would like to try the Multiplayer server via the GWFL option and every time I start Flight it takes me to the the dropdown GFWL login and results in asking for a Product Key, I have read where you said to to the the NON-GWFL first and then change it in in Flight Toolkit which I have but it doesn't seem to work.  I have also read that just entering 1's works but it didn't work for me, is there something I'm missing here? Also I tried to install the latest Toolkit not sure what version but when I try to install it, it says MS Flight 1.1.1.31063 must be installed in order to use Flight Toolkit, the version of Flight I have is 30063, Do I have to re download it and install that version? The current version of Flight Toolkit I have now is 1.1.3.1.37625. By the way I would like to thank you for bringing back to life a most loved flight sim for all of us! Thanks Ken

Share this post


Link to post
Share on other sites

If it is asking for a live product key then you are out of luck and can't use multiplayer.

I recommend installing Flight with these instructions to get the latest version:
Installing MS Flight:
Make sure you have the latest GFWL client installed: http://go.microsoft.com/fwlink/?linkid=128962 (or www.flighttoolkit.com/flightInstallers/gfwlivesetup.exe)
You can download\install Microsoft Flight from here: http://go.microsoft.com/?linkid=9800616
Even though Flight is free, GFWL needs to generate a key for it so it can connect to the service. I have heard of people having problems getting one. If you run into this after installing Flight and haven't ever installed it before, make sure you use the Non-GFWL mode of the Flight Toolkit. You will be prompted for it at the end of the installation process of the Toolkit.

Installing the Flight Toolkit (Requires Vista or newer OS):
You can download the latest tools here: http://www.flighttoolkit.com/Downloads/FlightToolkit_1_1_32.zip (If you have a problem where GFWL says you need a key to play, make sure you use the Non-GFWL mode. You can change this after installation from the Addon Manager)
Website for the Flight Toolkit: www.flighttoolkit.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now