ironhide80

Preview DirectX 10 checkbox missing in FSX-SE

Recommended Posts

Hello everyone!

I used to have Preview DirectX10 checkbox in settings but now it's gone missing. I did extensive research online but none of the fixes that helped others is working for me. 

I'm running FSX-SE on Win10.

Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz
NAVIDIA GeForce GTX 860M, 

16GB RAM.

I already fully uninstalled it and reinstalled but it didn’t help.

I was looking for SweetFX files like some other users were reporting on other forums but I have none of those files.

I feel like I run out of other options besides formatting everything which I’m trying to avoid.

Any help would be really appreciated!!!

Thanks!

20080520_111320_FSX_settings_1.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

No, I'm not using it. At this moment after re-installing I have no add-ons at all. 

I did however installed Qualitywings 787 few weeks ago, and it caused problems with level D 767 dll file. I ended up uninstalling 787 and I had to reinstall FSX to run 767 again. I'm not sure if I had Preview DirectX 10 checkbox after reinstalling few weeks ago.I just discovered it missing yesterday.

Edited by ironhide80
Added more info

Share this post


Link to post
Share on other sites

If you're intending to use DX10 mode, the Scenery Fixer really is the way ahead. With this in mind, I'd still be tempted to go to Steve's official support forum as a potential customer and see if he has any ideas for how to get the preview button back.

Share this post


Link to post
Share on other sites

Thank you very much for all replies!

Unfortunately, I was unable to bring back that checkbox via troubleshooting. I had to clean install win10 and that brought the checkbox back. 

 

Since the checkbox went missing I've noticed a big drop in FSX performance. I thought that the missing DircectX 10 Preview was the reason because I always had it checked. However after installing windows 10 from the scratch and getting DirectX10 preview back the performance is still pretty bad. I'm not sure what happened but some time ago there was Windows update that could have caused performance degradation. I'm not a computer wizard so at this point I'm going to put the FSX aside. 

 

Once again, thanks a lot for all the input!

 

Share this post


Link to post
Share on other sites

Hello ironhide80,

Just spit balling an observation from your opening post something doesn't look quite right.

In your opening post you quoted your system specs as follows:

On ‎4‎/‎12‎/‎2017 at 2:50 AM, ironhide80 said:

I'm running FSX-SE on Win10.

Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz
NAVIDIA GeForce GTX 860M

16GB RAM.

Your Graphics processor GPU is quoted as an 860M on a laptop computer, clearly capable of DX9 DX10 DX11 & DX12 API. In order to show the PreviewDX10 option in FSX you need to have a graphics card and driver fully compliant with DX10 and FSX running under Win10.
But when looking at your attached picture

On ‎4‎/‎12‎/‎2017 at 2:50 AM, ironhide80 said:

20080520_111320_FSX_settings_1.jpg

it is showing an Nvidia 8800GTX when viewing the FSX Display settings Graphics panel, as this 8800GTX GPU is the very first DX10 compliant Nvidia card, Perhaps your Nvidia Driver for the 8800GTX is not compatable with Win10.  I wonder if your driver needs updating or you have selected the wrong graphics Card, should it not be using the 860M dedicated GPU on the laptop where FSX is installed.
You could always check the graphics settings device dropdown arrow for the correct Graphics adapter 860M, then restart your sim and see if Preview DX10 option returns.

Failing that you could go to your  C:\Users\yourusername\AppData\Roaming\Microsoft\FSX\FSX.cfg rename it to FSX.cfg.testDX10,  start your sim and let FSX create a fresh copy with the correct Graphics card automatically detected. You may need to do a little work accepting all the trusted files and slider settings and checkboxes once you restart the sim.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now