Carob

FS9 Lighting

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Hi, for virtual cockpits, it's a pain. For 2d panels, I make darker overlay bmp's of all the Fixed views because the ambient lighting is too high in Fs9. For more info search "lighted panel notes" in 'panels and gauges'....

Share this post


Link to post
Share on other sites
1 hour ago, Dave Morgan said:

Carob, it could be worth you reading through this old thread (there should be a HUUUGE smiley for replies like this)

 

It's RUNWAY_LIGHTS_SURFACE_SCALAR in fs9.cfg

 

https://www.avsim.com/forums/topic/458705-light-intensity/

 

 

Best regards,

D

 

That's my old thread for aircraft lighting.  This particular issue is for runway lighting.  I've already tried changing the

RUNWAY_LIGHTS_SURFACE_SCALAR
RUNWAY_LIGHTS_VASI_SCALAR
RUNWAY_LIGHTS_APPROACH_SCALAR
RUNWAY_LIGHTS_STROBE_SCALAR

numbers but it doesn't seem to be doing much.

Here's another example...
https://www.dropbox.com/s/fywlpdb5mujfw4d/Lights2.jpg?dl=0

Share this post


Link to post
Share on other sites
12 hours ago, hgschnell said:

Check your halo.bmp in FS9\texture folder. It looks changed...

It is changed.  To something much more realistic (dimmer).  I don't remember where it came from but I'm sure it was from the library here at some point.

Share this post


Link to post
Share on other sites

There are several different halo.bmps in the library.

Find the one you like best or go back to the default.

You have to adjust the scalar values for brightness, especially if the new halo.bmp has a different solution (512x512 vs 256x256 default)

 

Share this post


Link to post
Share on other sites
1 hour ago, hgschnell said:

There are several different halo.bmps in the library.

Find the one you like best or go back to the default.

You have to adjust the scalar values for brightness, especially if the new halo.bmp has a different solution (512x512 vs 256x256 default)

 

As noted above, the scalar adjustments were already looked at.

Share this post


Link to post
Share on other sites
On 12/17/2017 at 2:36 PM, Carob said:

Hello.

Can anyone remind me how to fix this lighting issue in FS9 of being too bright?

https://www.dropbox.com/s/bjwdakno0a3svyh/lights.jpg?dl=0

I can't seem to recall.

Thanks!

That looks like a 3rd party addon airport in which case the scalar adjustments won’t work if the developer used their own custom lights. Some devs use their own taxiway/runway lights, like the the case of Simwings Gibraltar that are really big and bright. You’d have to find the halo.bmp they used and adjust it manually. Personally I hate when they put lights in airports like that as they are way to big compared to real life lights.

Share this post


Link to post
Share on other sites
1 hour ago, cmpbellsjc said:

That looks like a 3rd party addon airport in which case the scalar adjustments won’t work if the developer used their own custom lights. Some devs use their own taxiway/runway lights, like the the case of Simwings Gibraltar that are really big and bright. You’d have to find the halo.bmp they used and adjust it manually. Personally I hate when they put lights in airports like that as they are way to big compared to real life lights.

I thought I mentioned this earlier but it is at any airport.  Default or otherwise.

Share this post


Link to post
Share on other sites
5 hours ago, Carob said:

I thought I mentioned this earlier but it is at any airport.  Default or otherwise.

Sorry I didn’t notice. I thought you were talking about the runway/taxiway lights.

Share this post


Link to post
Share on other sites
6 minutes ago, cmpbellsjc said:

Sorry I didn’t notice. I thought you were talking about the runway/taxiway lights.

I am.

Share this post


Link to post
Share on other sites
1 minute ago, Carob said:

I am.

In that case, what I said earlier still stands.

Both shots you posted look like they are 3rd party addon airports that could be using their own custom lights to which the scalar adjustments aren’t working. However you stated that this happens at both addon airports as well as default. The scalar adjustments should be working to reduce the size at the default airports but you hadn’t posted a shot of a default airport to see how it looks.

The other question i would ask, if this just started happening one day, what was the last thing you changed before the lights started looking like this? Have you changed any video card settings like AA or AF or any FS9.cfg parameters that effect video settings? Using a different halo.bmp that works for default airports should still let the scalar settings work.

Share this post


Link to post
Share on other sites
16 minutes ago, cmpbellsjc said:

In that case, what I said earlier still stands.

Both shots you posted look like they are 3rd party addon airports that could be using their own custom lights to which the scalar adjustments aren’t working. However you stated that this happens at both addon airports as well as default. The scalar adjustments should be working to reduce the size at the default airports but you hadn’t posted a shot of a default airport to see how it looks.

The other question i would ask, if this just started happening one day, what was the last thing you changed before the lights started looking like this? Have you changed any video card settings like AA or AF or any FS9.cfg parameters that effect video settings? Using a different halo.bmp that works for default airports should still let the scalar settings work.

I didn't post any others because it doesn't matter.  They are all the same.

No, it just didn't start happening.  It's not my system that has this issue.  I was/am trying to help someone else.

Share this post


Link to post
Share on other sites
22 minutes ago, Carob said:

I didn't post any others because it doesn't matter.  They are all the same.

No, it just didn't start happening.  It's not my system that has this issue.  I was/am trying to help someone else.

Hard to say then if it’s not your system and we don’t know what this other person has done, what settings they use, etc. Perhaps this other person should join Avsim and we can interact with them directly to solve the issue quickly.

Dont have any other ideas in that case, sorry, but if your sure default airports look this as well then it’s probably a setting issue with either the video card settings or FS9 display settings.

Share this post


Link to post
Share on other sites

I am the only one who modifies any of this kind of stuff on it.  It is my father's.

Share this post


Link to post
Share on other sites

Please upload your father's halo.bmp.

Otherwise I see no chance to solve the problem.

Share this post


Link to post
Share on other sites

I'm aware it's not the original.  It's better.  (Read earlier in the thread.)

Share this post


Link to post
Share on other sites

It is a 256x256 halo.bmp with big "stary" lights and it is the cause of your problem.

If you think it is better, you have to live with it.

I prefer a halo.bmp with 512x512 resolution, smaller lights and sharper edges.

Share this post


Link to post
Share on other sites

When I said it didn't just start happening, I meant just that.  It was fine a while back and then this started happening.  Same files though.

I suppose I can test other halo files just to see what happens but since the system is about 1,000 miles away, it will probably have to wait.  When I posted the initial message about this I had access to the system.  Not so much now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now