Recommended Posts

I've been playing P3D, and sometimes, GSX has no sound.

The inly sound I can hear is the "beep" sound and the pushback officer speaking to me.

But, sounds like boarding/deboarding I don't hear.

Sounds with the GSX ground vehicle engine sound I do not hear.

And, I've checked in the GSX settings and the sounds are fully on!

What's going on?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Try asking on the GSX forum. 

Share this post


Link to post
Share on other sites

yep  best place  all the time  to ask  at the fsdt  forum,  probably  would  have  found  your  answer  by now

Share this post


Link to post
Share on other sites
Posted (edited)
On 21.4.2018 at 1:57 AM, Aaron Kim said:

I've been playing P3D, and sometimes, GSX has no sound.

The inly sound I can hear is the "beep" sound and the pushback officer speaking to me.

But, sounds like boarding/deboarding I don't hear.

Sounds with the GSX ground vehicle engine sound I do not hear.

And, I've checked in the GSX settings and the sounds are fully on!

What's going on?

You should also check the sound device that's listed in GSX settings.

For testing purpose set the same playback device as in P3D. If it's already selected, make sure to switch once back and forth in the device list. If you still hear only P3D sounds then you might try the next step below.

If you have more playback devices that are not plugged in, make sure you disable those devices from windows settings

Edited by GEKtheReaper

Share this post


Link to post
Share on other sites

Had that problem, too. GSX was set to a sound device I wasn't using. Since I switch the default output device depending on the plane I fly, it would be great if GSX could just use the default sound device, as others do.

Share this post


Link to post
Share on other sites
11 hours ago, Aaron Kim said:

Ok I will post on the FSDT forums.

Well form your answer I can't conclude if you checked your audio device setting within GSX...

You have to open P3D and go under sound settings to see what device is listed there. If you hear all P3D sounds ok (engine, ATC, ...) go in GSX settings menu and check if the same device is listed there also as playback device. If "yes" then check your sound levels within the same GSX settings window. If everything is set up corectly, you should hear all GSX sounds.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now