Ramonisgek123

Prepar3d Blurry ground textures

Recommended Posts

Dear friends,

I've just installed Prepar3d and I'm experiencing massive blurry ground textures. I've tried almost everything and it's driving me crazy. Fiber texture commands, max load, affinity mask, deleted cfg, all settings maxed out but nothing seems to be working.

This is how it currently looks:
df6261e9f69098dee311bf9bf27ec554.jpg

This is my current CFG.

My setup is:
i7-4670k
GTX970 4gb
16gb Ram DDR3 1600mhz


[GRAPHICS]
SCREEN_CAPTURE_MAX_JOBS=10
VIDEO_CAPTURE_WIDTH=720
VIDEO_CAPTURE_HEIGHT=480
VIDEO_CAPTURE_FPS=30
VIDEO_CAPTURE_BIT_RATE=3200000
VIDEO_CAPTURE_IS_THREADED=True
VIDEO_CAPTURE_INFO_SEND_RATE=20
VIDEO_CAPTURE_MAX_FRAME_SIZE=500000
VIDEO_CAPTURE_TTL=255
HDR_BRIGHTNESS=1.200000
HDR_BLOOM_THRESHOLD=3.000000
HDR_BLOOM_MAGNITUDE=0.050000
HDR_BLOOM_BLUR_SIGMA=0.800000
TONEMAP_DAY_EXPOSURE_KEY=0.280000
TONEMAP_NIGHT_EXPOSURE_KEY=0.130000
HDR_SATURATION=1.100000
MAX_POINT_LIGHTS=250
MAX_SPOT_LIGHTS=250
ViewGroup_Number=-1
MAP_DRAW_THREADED=1
MIPMAP_VC_PANELS=1
TEXTURE_MAX_LOAD=4096
NUM_LIGHTS=4
COCKPIT_HIGH_LOD=1
AIRCRAFT_REFLECTIONS=1
LANDING_LIGHTS=1
DYNAMIC_LIGHTING=1
DAWN_DUSK_SMOOTHING=1
LENSFLARE=1
HDR=1
DYNAMIC_REFLECTIONS=0
SHADOW_QUALITY=1
SHADOW_DRAW_DISTANCE=0
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=0
TERRAIN_SHADOWS_CAST=0
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=0
CLOUD_SHADOWS_CAST=0
PARTICLES_SHADOWS_CAST=0
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOWS_RECEIVE=1
VEGETATION_SHADOWS_RECEIVE=0
BUILDING_SHADOWS_RECEIVE=0
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_ULTRA=12
OPAQUE_SHADOW_TEXTURE_SIZE=2048
TRANSLUCENT_SHADOW_TEXTURE_SIZE=512
OPAQUE_SHADOW_DRAW_DISTANCE=2000
TRANSLUCENT_SHADOW_DRAW_DISTANCE=2000
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
EFFECTS_QUALITY=2
EFFECTS_DISTANCE=1
TEXTURE_QUALITY=3
IMAGE_QUALITY=0
See_Self=1
Text_Scroll=1
[WEATHER]
CLOUD_FACING_MODE=0
MinGustTime=10
MaxGustTime=500
MinGustRampSpeed=1
MaxGustRampSpeed=200
MinVarTime=5
MaxVarTime=50
MinVarRampSpeed=10
MaxVarRampSpeed=75
TurbulenceScale=1.000000
WeatherGraphDataInDialog=0
AdjustForMagVarInDialog=1
DynamicWeather=0
DownloadWindsAloft=0
DisableTurbulence=0
CLOUD_DRAW_DISTANCE=4
DETAILED_CLOUDS=1
OPTIMIZE_DENSE_CLOUDS=0
CLOUD_COVERAGE_DENSITY=6
THERMAL_VISUALS=0
VolumetricFog=1
DetailedPrecipitation=1
WindshieldPrecipitationEffects=1
[DISPLAY]
ChangeTime=4.000000
TransitionTime=4.000000
TEXTURE_FILTERING=16
MSAA=4
SSAA=0
VSYNC=0
FXAA=0
TRIPLE_BUFFER=0
SKINNED_ANIMATIONS=1
UPPER_FRAMERATE_LIMIT=30
WideViewAspect=False
FullScreenBackground=True
FullScreenAutoFill=True
ActiveWindowTitleTextColor=255,255,255
ActiveWindowTitleBackGroundColor=0,28,140,64
NonActiveWindowTitleTextColor=255,255,255
NonActiveWindowTitleBackGroundColor=24,33,87,64
InfoUpperLeftTextColorUser=255,0,0
InfoUpperLeftTextColorNonUser=255,127,0
InfoUpperLeftBackGroundColor=0,0,0,0
InfoUpperRightTextColor=255,0,0
InfoUpperRightBackGroundColor=0,0,0,0
InfoLowerLeftTextColor=255,255,255
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoBrakesEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoOverspeedEnable=True
InfoWeaponSystemEnable=True
InfoCountermeasureEnable=True
InfoUpperRightTextEnable=True
Fullscreen=False
[SCENERY]
AUTOGEN_DRAW_DISTANCE=12000.000000
AUTOGEN_TREE_DRAW_DISTANCE_PERCENT=0.900000
AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000
MaxRegionsPurgePerFrame=16
POP_FREE_AUTOGEN=1
AUTOGEN_BATCH_LOD=2
AUTOGEN_VEGETATION_TYPE=0
IMAGE_COMPLEXITY=3
[MAIN]
User Objects=Airplane, Helicopter, Submersible, ExternalSim, Avatar
LabelsSupported=Airplane, Helicopter
ShowInfoText=1
Location=440,129,1480,908,\\.\DISPLAY2
Maximized=2
HideMenuNormal=0
HideMenuFullscreen=1
[PANELS]
IMAGE_QUALITY=1
SAVE_AND_LOAD_PANEL_STATE=0
MAX_VC_TEXTURE_RESOLUTION=4096
PANEL_OPACITY=100
QUICKTIPS=1
PANEL_MASKING=1
PANEL_STRETCHING=1
UNITS_OF_MEASURE=0
PANELS_ALWAYS_ON_TOP=1
[CONTROLS]
Controls_Default=Standard
Controls_Current=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
[TextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
[TextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
GForce=1,3
FuelPercentage=1,4
HealthPoints=1,5
[TextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
FrameRate=2,1
LockedFrameRate=2,2
GForce=2,3
FuelPercentage=2,4
HealthPoints=2,5
[SlewTextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
[SlewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
HealthPoints=1,3
[SlewTextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
FrameRate=2,1
LockedFrameRate=2,2
HealthPoints=2,3
[Avatar]
DefaultAvatar=Army Infantry
[DynamicHeadMovement]
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
RollAccelOnHeadLat=0.010000
YawAccelOnHeadLat=-0.100000
RollAccelOnHeadRoll=0.100000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
HeadMoveTimeConstant=1.000000
[VirtualCopilot]
VirtualCopilotActive=1
[DISPLAY.Device.NVIDIA GeForce GTX 970.0.0]
Mode=1920x1080x32
[DISPLAY.Device.NVIDIA GeForce GTX 970.0.1]
Mode=1920x1080x32
[DISPLAY.Device.NVIDIA GeForce GTX 970.0.2]
Mode=1920x1080x32
[USERINTERFACE]
SHOW_SCENARIO_WINDOW=1
BroadcastGPSData=0
PAUSE_ON_LOST_FOCUS=1
PROMPT_ON_EXIT=1
RestoreTimeOnMove=1
ScreenshotImageFormat=2
SHOW_MISSION_CAPTIONS=1
Map_Orientation=2
[TrafficManager]
AirlineDensity=0
GADensity=0
FreewayDensity=0
ShipsAndFerriesDensity=0
LeisureBoatsDensity=0
IFROnly=0
AIRPORT_SCENERY_DENSITY=0
[AContain]
ShowLabels=1
ShowUserLabel=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabelDistance=1
ShowLabelAltitude=1
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelFlightPlan=0
ShowLabelContainerId=0
ShowLabelAirspeed=0
ShowLabelHeading=0
LabelDelay=1000
LabelColor=FFFF0000
EnableRibbonVisuals=0
ShowRibbonUserObject=0
ShowRibbonUserAvatar=0
ShowRibbonAircraft=0
ShowRibbonGroundVehicles=0
ShowRibbonBoats=0
ShowRibbonAvatars=0
ShowRibbonWeapons=0
ShowRibbonCountermeasures=0
UserObjectRibbonColor=FFFF0000
UserAvatarRibbonColor=FFFF8000
AircraftRibbonColor=FF0000FF
GroundVehicleRibbonColor=FF00FF00
BoatRibbonColor=FF00FFFF
AvatarRibbonColor=FFFFFF00
WeaponRibbonColor=FF800000
CountermeasureRibbonColor=FF640080
RibbonFidelity=5.000000
RibbonMaxDistance=3218.689941
[TERRAIN]
LOD_RADIUS=4.500000
TESSELLATION_FACTOR=75
MESH_RESOLUTION=25
TEXTURE_RESOLUTION=29
AUTOGEN_VEGETATION_DENSITY=2
AUTOGEN_BUILDING_DENSITY=3
DETAIL_TEXTURE=1
HIGH_RESOLUTION_TERRAIN_TEXTURES=1
WATER_REFLECT_CLOUDS=0
WATER_REFLECT_USERAIRCRAFT=1
WATER_REFLECT_SIMOBJECTS=0
WATER_REFLECT_TERRAIN=0
WATER_REFLECT_AUTOGEN_VEGETATION=0
WATER_REFLECT_AUTOGEN_BUILDINGS=0
WATER_REFRACT_CLOUDS=0
WATER_REFRACT_USERAIRCRAFT=0
WATER_REFRACT_SIMOBJECTS=0
WATER_REFRACT_TERRAIN=0
WATER_REFRACT_AUTOGEN_VEGETATION=0
WATER_REFRACT_AUTOGEN_BUILDINGS=0
ENABLE_BATHYMETRY=0
WATER_CLARITY=30
WATER_DETAIL=1
UseGlobalTerrainView=False
[ATC]
AutoOpenAirTrafficWindow=1
UsePilotVoice=1
ShowATCText=1
PilotVoice=0
COMM_MSG_AI_ATC_COLOR=0XFF8C00
COMM_MSG_ATC_AI_COLOR=0X00008B
COMM_MSG_ATC_USER_COLOR=0X006400
COMM_MSG_USER_ATC_COLOR=0XA52A2A
COMM_MSG_ATIS_COLOR=00000000
[INTERNATIONAL]
ASLAT=2
ASLON=0
MEASURE=0
[REALISM]
PFactor=1.000000
Torque=1.000000
GyroEffect=1.000000
CrashTolerance=1.000000
General=1.000000
UnlimitedFuel=False
AllowEngineDamage=True
TrueAirspeed=False
AutoCoord=False
RealMixture=True
StressDamage=True
GEffect=True
ManualLights=True
GyroDrift=False
CrashWithDyn=True
CrashDetection=True
AvatarNoCollision=False
OnCrashAction=0
[ATTACHMENTS]
WeaponHighlight=False
HighlightDuration=1.000000
AutoWeaponSwitching=False
UnlimitedWeapons=False
UnlimitedCountermeasures=False
IgnoreAttachmentWeight=False
IgnoreAttachmentForces=False
[RECORDER]
RecordAITraffic=True
RecordAirportVehicles=True
RecordLeisureBoats=True
[SIM]
SYSCLOCK=0
OPTIMIZE_PARTS=1
[SOUND]
SOUND=1
SOUND_QUALITY=2
SOUND_LOD=0
PrimaryPlaybackDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoicePlaybackDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoiceCaptureDevice={DEF00003-9C6D-47ED-AAF1-4DDA8F2B5C03}
[STARTUP]
DEMO=0
STARTUP_DEMO=
LOAD_SCENARIO_TOOLS=1
LoadCorePlugins=1
LoadVirtualReality=1
EnableVirtualRealityOnStartup=0
EnableVoiceControl=0
LoadWindow=1
[PointOfInterestSystem]
CycleSetting=0
[FACILITIES]
COUNTRY=
STATE=
CITY=
GTL_BUTTON=4096
[MISC]
Com_Rate=7
[MULTIPLAYER]
FrameSyncRate=0


Does anyone please have an idea what I can still try? It the fiber texture thing really working? Because for me it doesn't seem to. 

Thanks a million.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Try adding this to the [DISPLAY] section in the .cfg:

TEXTURE_BANDWIDTH_MULT=160     

reduce the 160 to 90 if you get stutters.

Also you can add: 

FIBER_FRAME_TIME_FRACTION=0.17 under [MAIN]

These are what I have set on my system and I never have blurries

 

 

Share this post


Link to post

Welcome to the club! Haven't found a fix to this date. 

Share this post


Link to post
14 hours ago, Ramonisgek123 said:

I've just installed Prepar3d and I'm experiencing massive blurry ground textures. I've tried almost everything and it's driving me crazy. Fiber texture commands, max load, affinity mask, deleted cfg, all settings maxed out but nothing seems to be working.

A big warm welcome to the forums. It sounds like you have done a lot of homework already and gathered some good knowledge.

I have been plaqued by blurries for many years in FS9, FSX, P3D until P3Dv4.1 came along and to my surprise out of the box crisp clear textures. Didn’t matter how many addons or where I placed my settings slides I could not get any blurries. Then came alone P3Dv4.2 and back to the blurry textures. Mainly when flying low and fast. 

I have managed to fix it although not perfect using an affinity mask, I had to play around with many numbers before I found my sweet spot.

I fly now using the Pimax 4k VR head set and the blurred textures (if any) are hard to see.

good luck

IM

Share this post


Link to post
Posted (edited)

Could I recommend a little research and reading? Start with the AVSIM P3D guide. There are several .cfg entries mentioned that affect texture blurring. Using this guide helped me (in fact eliminated them in Orbx regions altogether).

 

Edited by Henry Street

Share this post


Link to post
Posted (edited)

What is the ZOOM setting in your Spot View in the picture?  It looks like you are using a Zoom of more than say 0.60 - 0.70.  You seem much closer to the airplane than that in the picture, and the scenery in the picture seems much closer than it normally would.  This causes you to be trying to see far away LOD scenery generation drawn at a much lower resolution at a much closer distance than normal.  

The first thing I would do is make sure your Spot View is no more than about 0.60 - 0.70.  Then see if everything is still blurry like it looks in the distance in your picture.  The closest LOD radius to the aircraft where the highest texture resolutions ("non-blurry textures") will get "drawn" is not that large of a radius from the aircraft.

If the above still confuses you, try this to understand it.  Go to a scenery area where there are mountains in the distance.  Then go to Spot View.  Then zoom in your Spot View as much as you want to try to make those distant mountains get drawn "non-blurry".  You can't.  Regardless of how much you zoomed in, the sim will still only draw those mountains at the LOD level dictated by how far away from the airplane they are.   Many "blurry texture" complaints are about scenery that the user is trying to see "clear" that is in a farther away LOD Radius location.  That scenery will never get drawn "crystal clear" no matter what you do (until/unless you fly your aircraft close enough to it to get it inside the closest LOD Radius to the airplane).  You can increase the LOD Radius level in the sim, but by doing that you also add to the strain on your hardware to draw the scenery at higher levels of detail farther away.  And that just creates other issues.

If scenery CLOSE to your aircraft is "blurry", PAUSE YOUR SIM (and wait a bit) to see what may be happening.  If the scenery gradually gets drawn "more clear" while the sim is paused, it simply means your computer can't keep up with drawing the scenery as fast as you want it too with the scenery settings you are using WHILE you are flying (moving) over the scenery.  You need to fly over the scenery at a slower speed, and/or turn down some of the scenery setting "demands" you are placing on your computer to draw the scenery at the level of detail you want it to with the aircraft you are flying at the time. 

Note:  The list of things you said you have tried may actually be your problem right now (combined with a too zoomed in Spot View).  Very, very few people can "max out" their scenery settings (like you say you have) and NOT get blurry textures when flying over the scenery...even in some SLOW airplanes.  Start from scratch again.  Change you scenery settings to "default", then see if you STILL have "blurry scenery" at a zoom level of 0.60 - 0.70 Spot View while flying over it.  Look DOWN to see this...not 10 miles away in the scenery at a 1.00 zoom level. 

Edited by FalconAF

Share this post


Link to post
56 minutes ago, FalconAF said:

What is the ZOOM setting in your Spot View in the picture?  It looks like you are using a Zoom of more than say 0.60 - 0.70.  You seem much closer to the airplane than that in the picture, and the scenery in the picture seems much closer than it normally would.  This causes you to be trying to see far away LOD scenery generation drawn at a much lower resolution at a much closer distance than normal.  

The first thing I would do is make sure your Spot View is no more than about 0.60 - 0.70.  Then see if everything is still blurry like it looks in the distance in your picture.  The closest LOD radius to the aircraft where the highest texture resolutions ("non-blurry textures") will get "drawn" is not that large of a radius from the aircraft.

If the above still confuses you, try this to understand it.  Go to a scenery area where there are mountains in the distance.  Then go to Spot View.  Then zoom in your Spot View as much as you want to try to make those distant mountains get drawn "non-blurry".  You can't.  Regardless of how much you zoomed in, the sim will still only draw those mountains at the LOD level dictated by how far away from the airplane they are.   Many "blurry texture" complaints are about scenery that the user is trying to see "clear" that is in a farther away LOD Radius location.  That scenery will never get drawn "crystal clear" no matter what you do (until/unless you fly your aircraft close enough to it to get it inside the closest LOD Radius to the airplane).  You can increase the LOD Radius level in the sim, but by doing that you also add to the strain on your hardware to draw the scenery at higher levels of detail farther away.  And that just creates other issues.

If scenery CLOSE to your aircraft is "blurry", PAUSE YOUR SIM (and wait a bit) to see what may be happening.  If the scenery gradually gets drawn "more clear" while the sim is paused, it simply means your computer can't keep up with drawing the scenery as fast as you want it too with the scenery settings you are using WHILE you are flying (moving) over the scenery.  You need to fly over the scenery at a slower speed, and/or turn down some of the scenery setting "demands" you are placing on your computer to draw the scenery at the level of detail you want it to with the aircraft you are flying at the time. 

Note:  The list of things you said you have tried may actually be your problem right now (combined with a too zoomed in Spot View).  Very, very few people can "max out" their scenery settings (like you say you have) and NOT get blurry textures when flying over the scenery...even in some SLOW airplanes.  Start from scratch again.  Change you scenery settings to "default", then see if you STILL have "blurry scenery" at a zoom level of 0.60 - 0.70 Spot View while flying over it.  Look DOWN to see this...not 10 miles away in the scenery at a 1.00 zoom level. 

Very good info, thank you! 

I use ChasePlane and i have my zoom set in ChasePlane at .77 and the zoom in the sim is set to .40. 

Share this post


Link to post
On 6/9/2018 at 1:49 AM, pracines said:

Try adding this to the [DISPLAY] section in the .cfg:

TEXTURE_BANDWIDTH_MULT=160     

reduce the 160 to 90 if you get stutters.

Also you can add: 

FIBER_FRAME_TIME_FRACTION=0.17 under [MAIN]

These are what I have set on my system and I never have blurries

 

 

 

Well tried this and on default scenery I don´t have blurries anymore. However when i´m flying at 37000 feet, the ground below me gets really blurry. 

This was the same flight departing Amsterdam

55c4fba2f7f1be74122d5eca099fcb9f.jpg

 

But on the same flight, ORBX Innsbruck looks like this

97f7de7c19bf7144fe874e0462599772.jpg

This is on spot view, I don't really know the zoom rate. But when zooming in or completely out it doesn't really make a difference. Since I do see the same result in the VC.

@FalconAF

Thanks for your extensive reply. The 'maxed out' settings where just to test if that made a difference. I have almost every setting in the middle. I'll try to increase the LOD radius. However, in FSX i never had a problem at Innsbruck with these kind of blurry mountains. When pausing it doesn't really make a difference. So it just looks like it's a LOD radius problem.

 

 

 

 

Share this post


Link to post
Posted (edited)

You say you don't know what the zoom level is.  When you press the "+" or "-" keys on your keyboard, you don't see a red-letter display in the upper RIGHT corner of your screen showing what zoom level you changed to using the keys?  Should be the same sized red letters as shown in the upper left part of your screen picture above.   But the zoom level will be shown in the upper right part of the screen. It should be enabled by default, so unless you manually turned it off in the .cfg file it should display when you use the plus or minus key.

I'm looking at your above picture, and it sure looks like the default zoom setting of 1.00 to me if it's at Innsbruck.  And those ORBX mountains are photoreal scenery, and with the direction of the picture they appear closer to you than they should.  They are probably in an outer LOD radius area yet, and not being drawn at their highest resolution.  At 1.00 zoom level, they will look "blurry".

Edited by FalconAF

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now