Jump to content

Sign in to follow this  

Reinstall P3D4.3 to an external drive

Recommended Posts

I have been going back and forth with the developer of GSX for WEEKS now since the release of GSXL2 and the constant issues I am having with it mostly pertaining to P3Dv4.3 freezing when clicking "apply" in the GSXL2 gate editor. Since I keep all of my addons in a folder outside of the main P3D folder and outside the Program Files folders (including x86), I thought perhaps uninstalling everything and all addons and moving everything and reinstalling to the bigger external HD would be a decent test to run. Everything gets a clean fresh install and I can just copy/paste my addon folder and only need to make sure the paths are set up in the addon manager.


Well, I reinstalled P3D4.1 into the new drive first (that's the version of P3D i purchased for the 1st time so I wanted to start there), then followed the steps to upgrade to 4.3. I then installed 4 addons but when I went to install the PMDG aircraft, i get an error message which can be seen here: http://prntscr.com/l2ueml


I tried to open P3D and it first asked if I wanted to allow addon FSUIPC, and of course I clicked yes. Then it asked me to register which I did and I got the "Registration successful" message. but then P3D sat on the splash screen for more than 30 minutes before I opened task manager to see if it had froze and it wasn't even showing in task manager, but it does show as an active process on that tab. I closed the process and restarted the computer and tried again, but same thing, P3D just sits on the splash screen with the spinning blue cursor if over the splash screen. The process info and the P3D info being read by Windows does show P3D as version 4.3 .. so my thinking to get PMDG to see the version 4.3 was that I need to launch P3D to get it to finish building all the new files and folders and such for the clean install, but it will never load past the splash screen.


So that leads me to a few questions:

1)The new drive I'm trying to move P3D to is recognized by windows and I've been able to move files back and forth from it to C drive without any issues. But the new drive does not have Windows installed on it. Does it need to have Windows installed it also to have P3D run directly from that drive?

2) The new drive is an external HHD connected thru USB3 ... I know this is slower than a SATA connection, but should it really be that slow that I'm looking at nothing but a splash screen for 30+ minutes? When P3D was installed to a folder on the desktop of C drive, splash screen would only show for a few seconds, never this long.

3)Can P3D even be installed to and ran from an external drive when I boot to C drive, but try to get P3D to run from H drive.


I'd say I'm about average when it comes to tech knowledge. A lot of what I know comes from 20 years of Flight Sim trial and error, but never have I tried installing and running the sim from an external drive, nor have I ever owned more than 1 drive at a time before now. Any help or advice would be appreciated.


Thank you!

Steven Destazio (DVA12924)


"There's not reason to be alarmed, and we hope you'll enjoy the rest of the fight. By the way, is there anyone on board who knows how to fly a plane?" - Elaine Dickinson

We all started learning a product/feature at some point in our tenure within the flight sim community. Please understand that and understand that people come here to learn how to solve problems, not be harassed because you feel you are better than everyone else. We are all equal. Show respect and you'll get respect. Please don't guess at a solution unless trial/error and remember we are here to help each other and learn/teach from each other. Check your ego at the door. We should be interacting as if we will be sitting next to each other on the flight deck, not grade school bullies.

Share this post

Link to post


Yes you can install it in a external drive, mine is, for example, in HD G. But I think you'll have to redo a full re install. There is a topic somewhere in the forum about a

new re install

Intel i9 - GPU RTX 3080 - 32 gig RAM HyperX Fury DDR 4

Share this post

Link to post

You do not have to have Windows installed on the same drive as P3D. 

As for add-ons....I have my P3D installed on a separate SSD, and now generally try to install add-ons outside of the P3D folder structure.

However, last December, I did not have any knowledge of installing add-ons outside of the P3D folder structure.  As a result, in Dec 2017 I installed the PMDG 777 using whatever default settings their installer had -- and it installed into the P3D folder structure (i.e. D:\P3D\PMDG).   This is not how I would install it today, BUT the kicker is, I do not know if the PMDG 777 can be installed outside.  If I were installing it today, I would attempt to do so, and use Lorby's Addon Organizer to set up to various components, if I could figure out what they were.

So in answer to your issue/question re: PMDG 737 -- I would say ask them (PMDG).

I don't think your USB3 connection is the issue.  I think it has to do with the add-on(s) you've installed.  One or more of them doesn't like where you've installed them.  Just a guess though.



i7-8700k @ 5.0 ghz, 32 GB G.Skill TridentZ, 1080Ti, 32" BenQ, 4K res

Share this post

Link to post

Windows does not need to be installed on the P3D drive for it to run. If it's taking 30 minutes at the opening screen, I suspect something else is causing the issue. Possible permissions issue or AV interference with external drive.

But as long as your paths are correct, P3D can be run from an external drive.



RIG#1 - 7700K 5.0g ROG X270F 3600 15-15-15 - EVGA RTX 3090 1000W PSU 1- 850G EVO SSD, 2-256G OCZ SSD, 1TB,HAF942-H100 Water W1064Pro
40" 4K Monitor 3840x2160 - AS16, ASCA, GEP3D, UTX, Toposim, ORBX Regions, TrackIR
RIG#2 - 3770K 4.7g Asus Z77 1600 7-8-7 GTX1080ti DH14 850W 2-1TB WD HDD,1tb VRap, Armor+ W10 Pro 2 - HannsG 28" Monitors

Share this post

Link to post
9 hours ago, samisahusky said:

P3D sat on the splash screen for more than 30 minutes


This could be a sign of a broken or invalid scenery path. P3D likes to "hang" like that if a recently added scenery path points nowhere or is invalid.

You could use the Lorby AddonOrganizer or a similar management tool that will detect invalid content paths.

Best regards


Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.

    $13,405.00 of $25,000.00 Donate Now
  • Create New...