Sign in to follow this  
vincentrouleau

Cabin sound loss on Audio device switch

Recommended Posts

Hi,

I have tried to search a solution for this to no avail. 2 months ago, I got myself a Samsung Odyssey+. Amazing immersion. But I keep loosing internal sounds when swithing on VR. I routine is 1) do pre-flight in 2d, 2) from push-bash to TOC in VR, 3) cruise to TOD in 2D 4) Descend to engine shutdown in VR.

My problem is that is soon as I start WindowsMixedReality on, I loose cockpit sound in the 737,777 and 747. No clicks, no flaps sounds, etc. I tried to search in VR forums until I descovered that it wasn't a WMR problem per say, it's switching audio device from one USB device to an other. I can replicate this just using my Logitech G330. Lauch P3d in 737, flaps makes sounds. Disconnects the Logitech and reconnect it. Sounds come back but without internal cabin sounds.

Is this a known P3dv4.4 bug? Is there any workaround?

Thanks

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

There are three settings that need to have the correct output device set:

windows sound output: set your device as default, if your VR device has speakers like the Rift does, set it as default. Or whatever you want to use as speakers/headset.

 P3D sound settings: must be set to the default device or to whatever you chose in the win settings.

PMDG CDU settings, PMDG options, sound. Same here, set the correct device.

in P3Dv4.4 there should be no issue when that‘s done.

Edited by Ephedrin
Important typo

Share this post


Link to post
8 hours ago, vincentrouleau said:

Hi,

I have tried to search a solution for this to no avail. 2 months ago, I got myself a Samsung Odyssey+. Amazing immersion. But I keep loosing internal sounds when swithing on VR. I routine is 1) do pre-flight in 2d, 2) from push-bash to TOC in VR, 3) cruise to TOD in 2D 4) Descend to engine shutdown in VR.

My problem is that is soon as I start WindowsMixedReality on, I loose cockpit sound in the 737,777 and 747. No clicks, no flaps sounds, etc. I tried to search in VR forums until I descovered that it wasn't a WMR problem per say, it's switching audio device from one USB device to an other. I can replicate this just using my Logitech G330. Lauch P3d in 737, flaps makes sounds. Disconnects the Logitech and reconnect it. Sounds come back but without internal cabin sounds.

Is this a known P3dv4.4 bug? Is there any workaround?

Thanks

 

easy. When reconnecting a device, switch to another audio device in fmc, then switch back to the desired device. Thats what I do when i switch from wired bose headphones to wireless mode while i relax then back to wired mode to land. Be warned, switching audio devices too much can cause the sim to crash. P3D does not like being switched around. if the above doesnt help, pause the sim, save the flight then reload. 

Share this post


Link to post

Tried all of that. Engire sounds are there. Cabin sounds are not

Edited by vincentrouleau

Share this post


Link to post
15 hours ago, vincentrouleau said:

Tried all of that. Engire sounds are there. Cabin sounds are not

Make sure that all your audio device settings are set to 2-speakers and not something like 5.1; I doubt this is the problem but I know that having the wrong speaker configuration selected will result in missing cockpit sounds.

Share this post


Link to post

This will all come down to Win and Sim settings. When you connect a device, the computer needs to know where to route it. If the computer knows, then the sim and our software will follow. Absent that, things get weird.

To be honest, USB - while flexible - is not really meant to do that kind of mid-session switching, at least in the computing paradigm of today. To a computer, most USB audio devices show up as if they were their own sound device. In other words, it would be like (ignoring issues of shorting and so on), plugging in a new sound card in the middle of your sim session, and expecting the computer to handle it gracefully.

The sim won't even properly load new textures mid-session (for aircraft anyway). If you know you'll need the device, plug it in before the session and use that. If you absolutely need to plug/unplug, use something that uses the audio jack and not USB.

Share this post


Link to post

Hi Kyle, 

Thanks for the reply. But let me try to be more descriptive of my problem. I didn't mean that I need to disconnect/reconnect devices. I was just trying to do a recipe to reproduce my problem.

My problem is that I am losing internal sound when using my WMR setup on a Samsung Odyssey on PMDG planes and Majestic Q400. This behavior on not present in default P3D aircraft. I have somewhat mitigated my problem by using earbuds instead of my Logitech G433.

My typical flight would involve:

1) Doing Pre-Setup in 2D

2) PushBack to TOC in VR

3) Cruise in 2D. Enjoy the scenery/bathroom break/ Flight planning/etc

4) Descend/Landing in VR

So I switch a lot from VR/2D

When starting windows mixed reality it creates a new audio device 

 SoundWMR.jpg?raw=1

This becomes the default audio device and the audio is replicated on both devices by WMR:

 

SoundSettings%20(edited-Pixlr).jpg?raw=1

- First Problem: I must make sure that I start WMR prior P3D otherwise I will lose internal cabin sound because of the device creating. Mitigation: start WMR before P3D, no way to regain but restart P3D. But, no problem on default planes

- Second Problem: Using the Logitech G433 as audio device, when I switch to VR mode, I lose the cabin sound from the VR headset. Cabin sounds are still ok in G433. Switch back to 2D, sounds are ok in G433. Mitigation: I now use earbuds rendering my $150 G433 useless in P3D. Cabin sounds are ok in that case

- Third Problem: On long hauls, the VR headset goes to sleep. Or for some reason WMR software loses temporaly contact with the headset. Then the audio device is disable. I will lose cabin sounds permanently, no way to regain but restart P3D

Sound2WMR.jpg?raw=1

 

For the Majestic, it is much worst as I would lose sound from the airplane completly, not just internal sounds.

 

Like I said, I have somewhat mitigated my problems by using an earbud and disably the VR audio. So now in VR, I still keep my earbuds on.

Since this is not the same behavior in simpler plane, I assume that PMDG does have code that handles audio devices. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this