Jump to content

IncreaseVS

Sharp Terrain before Runway | Fix With Pilot's FSG NG Mesh?

Recommended Posts

Hello All,
 
I'm sure this has happened to some of you with high mesh resolution settings. When a user flies over a runway with a "cliff" or sharp terrain changes on final, and at or slightly below the glide slope with a "heavy aircraft"; P3D will suck the aircraft in the ground.
 
Here are various examples of what happens to my aircraft when I fly over a sharp terrain change (1m Mesh Resolution) on final: 
 
https://www.youtube.com/watch?v=-plWAfAxsXY&feature=youtu.be&t=1808 (30:08) if the link does not take you there
 
https://www.youtube.com/watch?v=QAGXbwPtDIA&feature=youtu.be  The video documents FSX however this happens still in P3D using the default mesh. 
 
More specifically, I first experienced it when on a KSFO RW28R final in the PMDG 747-8.  Here are some detailed pictures of problematic areas (from a different user in a P3D bug report thread).
 
izRVCpT.png
 
Qdpb2pz.jpg
 
It appears the only solution currently on the default P3D software is to lower the mesh resolution (higher numerically) which is not much of a fix at all; in addition to changing the scenery to a lower quality.
 
---
 
I having been struggling with this issue for a while and have come upon Pilot's FSG Mesh https://www.pilots.shop/Cms/Ui/Pages/Products/MainPage.aspx?id=ec92ce44-1876-436b-9b16-69793d58be97 Which has more detailed elevation data. I was wondering if a user could confirm this issue to be fixed with his product; its worth every penny of the $80 if it gets this annoying bug fixed!
 
Thanks!

Share this post


Link to post

For few APTS I was able to fix with Vector elevation tool. But with KSEA no matter what I do I have same issue and I am not flying there anymore. I am not familiar with FSG products if you find the fix, please post it. 

Share this post


Link to post
6 hours ago, cyyzrwy24 said:

For few APTS I was able to fix with Vector elevation tool. But with KSEA no matter what I do I have same issue and I am not flying there anymore. I am not familiar with FSG products if you find the fix, please post it. 

Hello, 

 

I sent an email to the the pilots shop a couple days back and they never replied. I would buy the product to try it but I don't fly VFR enough to justify the cost if it doesn't fix anything...

Could anyone who has the product chime in? Also as far as I know, there is no official support forum for "FSG" products either... 

 

Regards, 

Share this post


Link to post
2 minutes ago, pgde said:

Try mesh from Toposim -- can't be beat!

Hey, 

Thanks for your suggestion, does it fix the problem of getting sucked into the runway? 

 

Regards, 

Share this post


Link to post

I don't know since I don't have your problem (I am a non-ORBX user).

Share this post


Link to post
1 hour ago, pgde said:

I don't know since I don't have your problem (I am a non-ORBX user).

Hello, 

 

Oh, this is a base game issue. When yourmesh resolution is higher, you will thus have "clear" terrain which includes jagged edges. Your plane will almost certainly be sucked into the hole on final (larger planes only). 

 

 

Regards, 

Share this post


Link to post
1 hour ago, IncreaseVS said:

Thanks for your suggestion, does it fix the problem of getting sucked into the runway? 

You have an elevation conflict with another scenery.  Some Orbx scenery will cause this and they have a compatibility forum.  If no Orbx, you will need to move all of your addon scenery in C:\Documents\Prepar3D Addons and move all of the addons in this folder to a temporary folder (except the xml for your KSFO).  Is it fixed?  Then there is a conflict with one of the addon scenery, maybe a layering issue where the scenery should load above or below another scenery.  I know Orbx/FTX SoCal scenery has many conflicts with KLAS and KLAX and they have long the fixes in their compatibility forum.  If you have SoCal/NoCal scenery, you might disable that and see if that fixes the problem.  Once fixed, don't forget to return those files from a temporary folder back to the Prepar3D addons folder!

  • Like 1

Share this post


Link to post

Hello,

 

10 hours ago, Jim Young said:

You have an elevation conflict with another scenery.  Some Orbx scenery will cause this and they have a compatibility forum.  If no Orbx, you will need to move all of your addon scenery in C:\Documents\Prepar3D Addons and move all of the addons in this folder to a temporary folder (except the xml for your KSFO).  Is it fixed?  Then there is a conflict with one of the addon scenery, maybe a layering issue where the scenery should load above or below another scenery.  I know Orbx/FTX SoCal scenery has many conflicts with KLAS and KLAX and they have long the fixes in their compatibility forum.  If you have SoCal/NoCal scenery, you might disable that and see if that fixes the problem.  Once fixed, don't forget to return those files from a temporary folder back to the Prepar3D addons folder!

 

Thank you so much Mr. Young! I've been wrong to think that this was a base game issue. I own 4 different scenery enhancements, all of which produced by Orbx: Global, Vector, openLC NA, and Norcal. When I disabled Orbx NorCal I flew into KSFO 28R without an issue; never mind the grass on the runway, one problem at a time 😣!

After I completely disabled Orbx NorCal, I re-enabled it to attempt to adjust the scenery load priority to have the "Mesh" component of NorCal be pushed all the way at the bottom. Although this fixed the grass on the runway, the elevation data confliction problem made a nasty reappearance. After a little more digging I instead moved the "CVX" component of NorCal to all the way at the bottom, which then fixed the elevation confliction, however thus by doing so "sinking" the textures below/ontop of the runway causing a nasty flickering and splotchy grassy runway.  

It's quite frankly disappointing to having seen Orbx as a "one-click" scenery solution but then to find out the problems it causes at the airports I fly into. Especially since spent over $100 and exclusively for Orbx products and their advertised compatibility. I come from X-Plane and was sick of Ortho4XP and downloading 80GBs of uncompressed DDS images 🙃... 

I'll take this over to the Orbx forums for further troubleshooting and cross-post the solution for all to see!

20 hours ago, cyyzrwy24 said:

For few APTS I was able to fix with Vector elevation tool. But with KSEA no matter what I do I have same issue and I am not flying there anymore. I am not familiar with FSG products if you find the fix, please post it. 

Hey Cyyz, 

Unfortunately they did not have KSFO listed as an option airport to "correct" in the AEC tool. I've recently and entirely given up on flying to some of my favorite airports! I've been doing some more reading and FSG replaces the base elevation data for P3D. Orbx also happens to use a version of FSG in the making of their products. I believe this would be an expensive fix. I'll see how far I get on the Orbx forums; if push comes to shove I'll buy FSG in a last ditch effort. I

I'll keep you posted.

 

Regards, 

 

 

Share this post


Link to post

Glad to hear you found the cause.  Orbx has a great compatibility forum as they cannot ensure compatibility with every scenery product.  Holger Sandmann does a great job running this forum.  You also have to know Orbx places their elevation files in P3dV4/Scenery/World/Scenery and one or two of those files probably is causing your aches and pains. 

I've written about this issue on several occasions regarding this scenery incompatibility, especially with FS Dream Team and FlightBeam airports, two of the most popular airport developers in Flight Simulation.  Because of the time it takes to make Orbx scenery work with FSDT and FlightBeam, I have not reinstalled any of my FTX/Orbx scenery.  I think they need to come up with a hotfix or modify their installer to make the necessary changes to make the product compatible. 

Good luck in getting your issue resolved!

  • Like 1

Share this post


Link to post
3 hours ago, IncreaseVS said:

Unfortunately they did not have KSFO

KSFO is fine I have issue with KSEA....no matter what I do.

Share this post


Link to post
5 hours ago, cyyzrwy24 said:

KSFO is fine I have issue with KSEA....no matter what I do.

All airports in FSX/P3D are flat.  Not all airports in the real world are on a flat surface.  There is quite a bit of elevation change at places like KSEA or even KLAS from one end to the other so the little cliffs you see are inevitable.   In fact there are real little cliffs at KSEA, have a look on Google Earth.  If you have Pilot's mesh, there is a tool that you can download from your account AFM2 that can be used to add a sloping region between the airport and surrounding terrain.  I've played with it at a couple of locations and it works pretty good.  About the only drawback is that if there is a pond or lake in the area of the slope that water elevation will not change.  Most of the time, I just get used to this quirk in the simulator.

Share this post


Link to post

Thanks Dan.

No, I don't have a pilot mesh, I will search and see what I can do. For me as I said, only airport is KSEA. I believe that's the only major airport that I don't have as a payware because of elevation issue. Not sure if I would accomplish anything buying payware. Funny, I had same issue when I was on FSX and thought P3D would be different. Sadly it's not.

Share this post


Link to post

 

5 hours ago, downscc said:

All airports in FSX/P3D are flat.  Not all airports in the real world are on a flat surface.  There is quite a bit of elevation change at places like KSEA or even KLAS from one end to the other so the little cliffs you see are inevitable.   In fact there are real little cliffs at KSEA, have a look on Google Earth.  If you have Pilot's mesh, there is a tool that you can download from your account AFM2 that can be used to add a sloping region between the airport and surrounding terrain.  I've played with it at a couple of locations and it works pretty good.  About the only drawback is that if there is a pond or lake in the area of the slope that water elevation will not change.  Most of the time, I just get used to this quirk in the simulator.

Just now, cyyzrwy24 said:

Thanks Dan.

No, I don't have a pilot mesh, I will search and see what I can do. For me as I said, only airport is KSEA. I believe that's the only major airport that I don't have as a payware because of elevation issue. Not sure if I would accomplish anything buying payware. Funny, I had same issue when I was on FSX and thought P3D would be different. Sadly it's not.

Hello,

Yeah... I love X-Plane's scenery system so much more than P3D's: curved runways, etc. I gave-up it up after I saw the lack of quality of their payware developers after buying a couple of their overpriced products. Imagine a 767 selling for $92 for something comparable off rikyooo. Realism for the price is extremely important to me but you only spend 3 minutes on the ground in comparison to 5 hours in the air; thus my switch from X-Plane.

 

I posted a troubleshooting message to Orbx and will see what comes of it. I'll let you know for a fix! I hope it doesn't require spending copious amounts of money, but I'll do it if it fixes it! 

 

Regards,

  • Upvote 1

Share this post


Link to post
On 5/12/2019 at 5:16 PM, cyyzrwy24 said:

Thanks Dan.

No, I don't have a pilot mesh, I will search and see what I can do. For me as I said, only airport is KSEA. I believe that's the only major airport that I don't have as a payware because of elevation issue. Not sure if I would accomplish anything buying payware. Funny, I had same issue when I was on FSX and thought P3D would be different. Sadly it's not.

Hello,

 

Unfortunately, I'm not having too much luck getting support over at Orbx: here is the thread. They even marked my thread as answered and did clearly did not watch the video, I am hoping the developer will chime in eventually...

It looks like the fix is not as easy to obtain as we once previously thought... Also here is a P3D thread where we go in-depth in the issue. There is a debate on whether or not this is a base game issue/Orbx issue. For me, I found it to be fixed by disabling NorCal, for others they have similar issues. 

 

Regards,

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...