Alberto Zanot

[Help] Terrain shadow degradation in v4

Recommended Posts

Posted (edited)

Hello, i've noticed that from the virtual cockpit the ground shadows suffer of a big degradation (see picture)

S0KQltK.jpg

In spot view this degradation is not noticeable, so at first time i thought it was a camera related issue, and i tried every "clipmode" settings for VC (minimum, spot, tower...).

But nothing changed, so i thought it was these settings related in cfg:

OPAQUE_SHADOW_TEXTURE_SIZE
TRANSLUCENT_SHADOW_TEXTURE_SIZE
OPAQUE_SHADOW_DRAW_DISTANCE
TRANSLUCENT_SHADOW_DRAW_DISTANCE

But i can't find a proper setting changing them.

Something to do with LOD?
Do someone know how to fix this degradation?

Thanks!!

Edited by Alberto Zanot

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I think it is related to those cfg entries, yes. Try to increase those, I would however not go above 2048 for the size. I suffered from a huge FPS drop when increasing to 4096 for example. Distance you can try higher values, but also those result in lower performance. Try and error until you find a setting that suits you and is acceptable regarding performance loss...

Share this post


Link to post

I found a way to fix it, and it doesn't have nothing to do with shadow texture size or draw distance.
As i suspected from the beginning actually it was about cameras.cfg as well as p3d.cfg,
If someone need it, i post what i've changed in the cfg's.

  • Upvote 1

Share this post


Link to post
7 hours ago, Alberto Zanot said:

If someone need it, i post what i've changed in the cfg's.

Yes please!

Share this post


Link to post
8 hours ago, Alberto Zanot said:

I found a way to fix it, and it doesn't have nothing to do with shadow texture size or draw distance.
As i suspected from the beginning actually it was about cameras.cfg as well as p3d.cfg,
If someone need it, i post what i've changed in the cfg's.

You should always post your findings without users requesting it!

I would have tipped the clipping mode (that you also mention) but also that you use a camera addon that overrides your settings.

  • Like 1

Share this post


Link to post

I said i would post it, just because i thought it was only a issue of mine.
It works even if you use any camera addon, like ChasePlane or Ezdok.
Here it is:

  • Go in C:\Users\YOUR_NAME\AppData\Roaming\Lockheed Martin\Prepar3D v4
  • Make a backup copy of your prepar3d.cfg and cameras.cfg
  • Open cameras.cfg and find the Virtual Cockpit one. It is the [CameraDefinition.xxx] with the entry "Origin=Virtual Cockpit". If you don't use any camera addon, it should be the first or second one. If you use ChasePlane it is the one with the entry "Description=ChasePlane Virtual Cockpit Camera". Any other camera addon could have different description. Anyways usually it is the first one. Just find yours.
  • In that camera, change the entry: Clipmode=Minimum (add it if you don't have it) and add FarClipOverride=200000 (you find what Far and Near Clip Planes are here)
  • Save, close, and open prepar3d.cfg, look for the entries inside the [GRAPHICS] tag
  • Change these entries like this:
    SHADOW_QUALITY=3
    SHADOW_DRAW_DISTANCE=3
    SHADOW_NUM_CASCADES_LOW=12
    SHADOW_NUM_CASCADES_MID=12
    SHADOW_NUM_CASCADES_HIGH=12
    SHADOW_NUM_CASCADES_ULTRA=12
    OPAQUE_SHADOW_TEXTURE_SIZE=2048
    TRANSLUCENT_SHADOW_TEXTURE_SIZE=512
    OPAQUE_SHADOW_DRAW_DISTANCE=2000
    TRANSLUCENT_SHADOW_DRAW_DISTANCE=2000
    SHADOW_LOG_PARTITION_LOW=0.990000
    SHADOW_LOG_PARTITION_MID=0.990000
    SHADOW_LOG_PARTITION_HIGH=0.990000
    SHADOW_LOG_PARTITION_ULTRA=0.990000
  • Save. Now the quality of the shadow and the fps impact is not depending by "SHADOW_QUALITY" (don't touch it and don't change nothing in the in-game sim menu), but you can set the quality with "OPAQUE_SHADOW_TEXTURE_SIZE". Valid entries are: 512, 1024, 2048, 4096, 8192. In my system 2048 looks nice and have no fps impact. Chose the value that fits best your system. The higher the value, the more defined the shadows (with fps impact).
    SHADOW_DRAW_DISTANCE=3 is the maximum draw distance and if you use the clouds to cast shadows on terrain/sea, 3 is the best setting, otherwise you will see clouds shadows clean cut (ugly).

A note about the FarClipOverride: the value 200000 means that the simulator renders the terrain 200 km far in the horizon. If you fly like 40.000ft high, this is a good setting. But if you go higher and higher you could see the terrain clean cut at the horizon. In this case, try raising the value.

Hope this helps, and if it doesn't work / you don't like it, just restore your cfg backups.

Have a nice flight!

Edited by Alberto Zanot
  • Like 1
  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now