Jump to content

Recommended Posts

Anyone know what might be causing the stutters when I'm panning my views inside the cockpit? I'm getting good frame rates but whenever I look around the cockpit the view will stutter. It mostly happens if I'm flying in a big city or cloudy weather. The forward view seems fine but it's just when I change the view and look out the left or right side of the cockpit...that's when it stutters but the frames rates are still good at the same time. I did change the rendering settings which were on the high side and changed them to one of the lower presets which helped...still get the stutters but not as bad and the flight model seems to have improved along with better frame rates. Are stutters unusual when panning views from inside the cockpit?

Share this post


Link to post
Share on other sites

What are your system specs for CPU, RAM, and graphics card, and what monitor resolution are you using?  That's usually a good starting point for debugging this kind of thing. Also, are you flying one of the default XP11 aircraft or payware aircraft? Some of the payware models can use a lot of GPU vram with high res textures.

FWIW, I never see stuttering when rotating the cockpit view with either the joystick hat or TrackIR, with the system specs listed below.


Primary sim is X-Plane 11 on Windows 10
i7 6700 4.0 GHz, 32 GB RAM, GTX 970 video, 1920x1200 monitor

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry...should have included that. Graphics card is an NVidia GTX 1080...the FPS box says...f-act 35 -40 fps...frame 0.023...CPU 0.023...GPU 0.023. I'm using Carenado's Saratoga TC but when I used a default aircraft like the Cessna 172 or King Air C90...it's not quite as bad. Performance is better with default aircraft but the add-ons look better. I don't remember the resolution but somewhere around 1080 or above but not 4K.

 

UPDATE: Been making some rendering adjustments and that seems to be where the problem is. I had everything set to high...looked beautiful but caused the judders when I panned the view. I lowered the settings to one of the presets...low or med low and it runs better with no judder when panning. The flight model does seemed to have improved too. From here on in I'll have to do my tweaking toward the lower graphics end instead of trying to get away with higher settings which are more than my system can really handle. The improved flight model makes it worth while I think and is an even trade off. I think I can find a sweet spot.

Edited by Will273

Share this post


Link to post
Share on other sites

Texture resolution, reflection detail and anti-aliasing are the biggest performance killers.

I also have stutters when panning the view while running XP11 on my laptop and blame it on the slow RAM (DDR3 2133 MHz), the GTX960M's slow and small VRAM (2 GB plus 2 GB from main RAM if necessary) and slow hard drive on which the page file resides.

Share this post


Link to post
Share on other sites
Posted (edited)

It doesn't have much to do with that, trust me, I've had the same issue with various settings on my high-end system.  Use your mouse instead of the pan and it will be much smoother.  Hold down the right button and move the mouse- same as pan but takes a little getting used to.  You can also adjust the pan rate and that may help, but I can only move fast pan left or right, up or down, not at other angles so I just use the mouse instead.

Edited by dal330200

John Lynch

P3D v4.4

I7 8700k, GTX 1080ti, 16gb Ram

X-plane 11 on disk, P3D and assorted sceneries, aircraft and utilities in the hanger. 

 

Share this post


Link to post
Share on other sites

The answer was given at the Flight Sim Expo in Orlando. The answer is simply that the OpenGL driverputs the not neede4d datat in the system RAM ahnd the used textures in the VRAM. But if you pan the driver suddenly needs these textures so it moves the data from VRAM to the RAM to find space for some textures in the RAM in your VRAM.

They will fix this by putting smaller versions of the textures in the VRAM. So when you are panning it can use these textures till you stop your movement than it can load the needed textures one single time.

  • Like 1

Karsten Schubert

Share this post


Link to post
Share on other sites
On ‎6‎/‎13‎/‎2019 at 6:24 PM, dal330200 said:

It doesn't have much to do with that, trust me, I've had the same issue with various settings on my high-end system.  Use your mouse instead of the pan and it will be much smoother.  Hold down the right button and move the mouse- same as pan but takes a little getting used to.  You can also adjust the pan rate and that may help, but I can only move fast pan left or right, up or down, not at other angles so I just use the mouse instead.

Thanks...can you tell me how to adjust the pan rate? I tried with the mouse but it didn't help that much...adjusting the pan rate might though.

Share this post


Link to post
Share on other sites
On ‎6‎/‎13‎/‎2019 at 6:57 PM, Longranger said:

The answer was given at the Flight Sim Expo in Orlando. The answer is simply that the OpenGL driverputs the not neede4d datat in the system RAM ahnd the used textures in the VRAM. But if you pan the driver suddenly needs these textures so it moves the data from VRAM to the RAM to find space for some textures in the RAM in your VRAM.

They will fix this by putting smaller versions of the textures in the VRAM. So when you are panning it can use these textures till you stop your movement than it can load the needed textures one single time.

 

On ‎6‎/‎13‎/‎2019 at 6:57 PM, Longranger said:

The answer was given at the Flight Sim Expo in Orlando. The answer is simply that the OpenGL driverputs the not neede4d datat in the system RAM ahnd the used textures in the VRAM. But if you pan the driver suddenly needs these textures so it moves the data from VRAM to the RAM to find space for some textures in the RAM in your VRAM.

They will fix this by putting smaller versions of the textures in the VRAM. So when you are panning it can use these textures till you stop your movement than it can load the needed textures one single time.

I did notice if I pan slower...it gives it time to catch up...takes longer to pan but it's not so jerky.

Share this post


Link to post
Share on other sites

Hi all,

After upgrading to a new rig (9600K, 32GB RAM, gtx1070) I noticed that had more (!) stutters when panning around than with my previous rig, although I generally fps was way up.

About a decade ago I had similar issues in FSX, which proved to be related to the screen refresh rate combined with the sim fps, when VSYNC was on. If I turned off VSYNC I had screen tearing when panning instead of stuttering. I solved it by internally limiting the sim FPS to 30 AND setting VSYNC to 1/2 monitor refresh rate (60/2).

I did something similar to Xplane 11. I limited FPS to something like 30,5 or 31.5 in Nvidia Inspector AND set VSYNC to 1/2 monitor refresh rate (standard not adaptive). I also set "threaded optimization" to OFF after testing both options. And now I enjoy incredibly smooth panning at 30fps (Track IR) in Xplane, way smoother than FSX ever was.

  • Upvote 1

Share this post


Link to post
Share on other sites
On 6/18/2019 at 9:45 AM, Will273 said:

Thanks...can you tell me how to adjust the pan rate? I tried with the mouse but it didn't help that much...adjusting the pan rate might though.

Go into the key assignments for the hat switch- look for custom I think, then you can set it for fast panning. 

 


John Lynch

P3D v4.4

I7 8700k, GTX 1080ti, 16gb Ram

X-plane 11 on disk, P3D and assorted sceneries, aircraft and utilities in the hanger. 

 

Share this post


Link to post
Share on other sites
On ‎6‎/‎21‎/‎2019 at 5:48 AM, nikaslan said:

Hi all,

After upgrading to a new rig (9600K, 32GB RAM, gtx1070) I noticed that had more (!) stutters when panning around than with my previous rig, although I generally fps was way up.

About a decade ago I had similar issues in FSX, which proved to be related to the screen refresh rate combined with the sim fps, when VSYNC was on. If I turned off VSYNC I had screen tearing when panning instead of stuttering. I solved it by internally limiting the sim FPS to 30 AND setting VSYNC to 1/2 monitor refresh rate (60/2).

I did something similar to Xplane 11. I limited FPS to something like 30,5 or 31.5 in Nvidia Inspector AND set VSYNC to 1/2 monitor refresh rate (standard not adaptive). I also set "threaded optimization" to OFF after testing both options. And now I enjoy incredibly smooth panning at 30fps (Track IR) in Xplane, way smoother than FSX ever was.

I'm getting  new computer Monday...RTX Pro from XForce PC and hope I don't have that problem anymore. I'll look into your suggestion and see if it helps with X Plane 10...while I'm still using it. I may have also exceeded the texture requirements which I'm going to look at. Thanks for letting me know.

Share this post


Link to post
Share on other sites
22 hours ago, dal330200 said:

Go into the key assignments for the hat switch- look for custom I think, then you can set it for fast panning. 

 

I found it...tried the fast panning and it just sped up the stutters...it was faster but you could still kind of see the stutters...not as obvious as before but they still seemed to be there. Thanks.

Share this post


Link to post
Share on other sites

Yeah, it's just one of those things.  Unless you have all of the eye candy dialed back...Try the mouse option, it's much smoother


John Lynch

P3D v4.4

I7 8700k, GTX 1080ti, 16gb Ram

X-plane 11 on disk, P3D and assorted sceneries, aircraft and utilities in the hanger. 

 

Share this post


Link to post
Share on other sites

Dialing back the eye candy works. Really need to stay within the limits of what the computer can do...anyway hoping the new computer with be enough to give me the eye candy and smooth panning I want...if not I'll need to dial it back again. Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...