Jump to content

Sign in to follow this  
georgiosgiannoukos

P3D4.5 HF3 Controls

Recommended Posts

Hello, someone please for help and advise how to fix a problem with the Sim.

1. Have my own profile in settings and most of the times the profile settings change with no reason to Default.

2. control settings have already exported both a) control settings and b) axis controls.

many times the axis get lost with no reason.

have axis alignment for a) Rudder Petals b) control yoke c) Throttle Quadrant 

Can someone please, if there is a possibility to resolve those issues, to help me?

Thank you,

Geo

Share this post


Link to post

Yeah, this might be an easy one (hoping so).

ESP (FSX/P3D) has a nasty little habit of un-assigning and reassigning control settings anytime it senses controller changes.  This occurs whenever one unplugs and then plugs controllers back in (often to different USB ports) but can also happens if the controllers time out especially if that occurs before P3D is loaded.

The best way to avoid this is always wait until the computer is powered down to unplug controllers and then plug them back in to the same USB ports before power up, and then in the Windows Device Manager USB Settings select each USB Device and if there are Power Settings go there and disable power saving.

I hope this helps!

Best wishes.

 

  • Like 1

Dave-Aerosoft-Signature-500x125.png

Share this post


Link to post
14 hours ago, DaveCT2003 said:

Yeah, this might be an easy one (hoping so).

ESP (FSX/P3D) has a nasty little habit of un-assigning and reassigning control settings anytime it senses controller changes.  This occurs whenever one unplugs and then plugs controllers back in (often to different USB ports) but can also happens if the controllers time out especially if that occurs before P3D is loaded.

The best way to avoid this is always wait until the computer is powered down to unplug controllers and then plug them back in to the same USB ports before power up, and then in the Windows Device Manager USB Settings select each USB Device and if there are Power Settings go there and disable power saving.

I hope this helps!

Best wishes.

 

Dave, thank you so much, I will follow your advise and report back ASAP 

geo

Share this post


Link to post

To obviate the problem, which happened to me regularly, as a SimStarter user I get it to copy a good backup into standard.xml every time I start the sim up.

  • Like 1

Petraeus

 

Share this post


Link to post
Posted (edited)
3 hours ago, Petraeus said:

To obviate the problem, which happened to me regularly, as a SimStarter user I get it to copy a good backup into standard.xml every time I start the sim up.

Thats a good idea - I back up my standard.xml controls file every few days to dropbox - can easily go back to a previous version if a controller gets mismapped

Edited by julian46

Share this post


Link to post

That’s also good solution but so far, using Dave’s suggestions, so far so good.

i give a few days and see how’s going with controllers.

George

Share this post


Link to post
13 hours ago, julian46 said:

Thats a good idea - I back up my standard.xml controls file every few days to dropbox - can easily go back to a previous version if a controller gets mismapped

is backing up the standard.xml the same thing as just going into settings and exporting the controls to a file.  Then importing that back later if needed?  If not how different.  thanks


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM1000x |  240MM AIO.| MFG Crosswind | T16000M Stick | Saitek Throttle Quad | Skalarki MCDU and FCU | Saitek Radio Panel

Share this post


Link to post
11 hours ago, micstatic said:

is backing up the standard.xml the same thing as just going into settings and exporting the controls to a file.  Then importing that back later if needed?  If not how different.  thanks

Yes I think it is - that file gets written to every time you run P3D - so I also the export occasionally for an extra backup - but mainly just make a copy of that standard.xml file (again to Dropbox - where you can restore most recent but also a previous version if req)

Share this post


Link to post
3 hours ago, julian46 said:

Yes I think it is - that file gets written to every time you run P3D - so I also the export occasionally for an extra backup - but mainly just make a copy of that standard.xml file (again to Dropbox - where you can restore most recent but also a previous version if req)

Julian.  Thanks so much.  Had another question from another thread.  But wanted to try with you here:

I have some questions regarding this.  I've always in V4 Exported my presets to a file on my desktop per last post.  Then if something went wrong I would import them back.  Out of knowhere I've had issues with my saitek throttle and also with my xbox controller.  Despite "Re-importing" my saved control settings back into V5 it is not working properly.  For instance I only use the xbox controller for chaseplane.  But it keeps assigning flight control surfaces to the xbox controller.  The import does nothing to help so the last few starts I've had to completely re do them.  Do I also want to save the standard.xml to my desktop and then use it to replace the one in my appdata folder when things go wrong?  Also in the app data folder I noticed there is a standard.xml and a standard.smlx.  Is it normal to have both of these?

 

Question 2: Is there a way to save the sensitivity settings for each device also to import also? 


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM1000x |  240MM AIO.| MFG Crosswind | T16000M Stick | Saitek Throttle Quad | Skalarki MCDU and FCU | Saitek Radio Panel

Share this post


Link to post
9 minutes ago, micstatic said:

For instance I only use the xbox controller for chaseplane.  But it keeps assigning flight control surfaces to the xbox controller.

I use an Xbox controller for CP as well, and since removing the Xbox controller binds in P3D after the first time plugging that controller is it has never happened since.  Of course I have the power saving disabled for the Xbox controller, which is critical in preventing this behavior.

 

  • Like 1

Dave-Aerosoft-Signature-500x125.png

Share this post


Link to post
17 minutes ago, micstatic said:

Julian.  Thanks so much.  Had another question from another thread.  But wanted to try with you here:

I have some questions regarding this.  I've always in V4 Exported my presets to a file on my desktop per last post.  Then if something went wrong I would import them back.  Out of knowhere I've had issues with my saitek throttle and also with my xbox controller.  Despite "Re-importing" my saved control settings back into V5 it is not working properly.  For instance I only use the xbox controller for chaseplane.  But it keeps assigning flight control surfaces to the xbox controller.  The import does nothing to help so the last few starts I've had to completely re do them.  Do I also want to save the standard.xml to my desktop and then use it to replace the one in my appdata folder when things go wrong?  Also in the app data folder I noticed there is a standard.xml and a standard.smlx.  Is it normal to have both of these?

 

Question 2: Is there a way to save the sensitivity settings for each device also to import also? 

Looks like the xmlx is the source file that contains all the mappings the xml is the current active one for your P3d

For Sensitivity I found this - http://www.prepar3d.com/SDKv3/LearningCenter/getting_started/controls/using_a_joystick.html

But I dont see anything in the standard.xml file that mentions it - unless an export import does

 

 

Share this post


Link to post
9 minutes ago, DaveCT2003 said:

I use an Xbox controller for CP as well, and since removing the Xbox controller binds in P3D after the first time plugging that controller is it has never happened since.  Of course I have the power saving disabled for the Xbox controller, which is critical in preventing this behavior.

 

stupid question Dave.  But how do I do this for an xbox controller?  I did it for my usb stuff I think?  It's a wireless one


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM1000x |  240MM AIO.| MFG Crosswind | T16000M Stick | Saitek Throttle Quad | Skalarki MCDU and FCU | Saitek Radio Panel

Share this post


Link to post
3 minutes ago, micstatic said:

stupid question Dave.  But how do I do this for an xbox controller?  I did it for my usb stuff I think?  It's a wireless one

It's under Human Interface Devices.  It takes some work to figure out which device is which so I recommend going through and disabling Power Saving for all the devices listed there.

I did that straight away when I added the Xbox Controller for CP, and I've never had an issue.

Just some history: I was the original person who published this power saving issue many years ago. It's a Windows issue, so nothing for LM to fix per se, however I wish to God they would either remove the "ah-ha! New controller, let's give it the control binds we think it should have" feature, or make it selectable.  I mentioned this to Adam when he was the LM P3D PM (I just slipped back into acronym mode.... LOL), I'll write to Chris soon and ask him to do it.

Hope this is helpful!

 

  • Like 1

Dave-Aerosoft-Signature-500x125.png

Share this post


Link to post

it is helpful thanks.  I had a few things listed that still had power management enabled that could possibly be responsible for some of my issues.  Nothing worse than going to start a flight only to realize your controls are all jacked up again. 


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM1000x |  240MM AIO.| MFG Crosswind | T16000M Stick | Saitek Throttle Quad | Skalarki MCDU and FCU | Saitek Radio Panel

Share this post


Link to post
1 minute ago, micstatic said:

Nothing worse than going to start a flight only to realize your controls are all jacked up again. 

Oh, I think I could come up with a few worse things... LOL!  But I agree, it's a terrible pain in the rear!

 

  • Like 1

Dave-Aerosoft-Signature-500x125.png

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...