Sign in to follow this  
Guest MrBitsy

FSX Automatic Switch To Very Blurred State?

Recommended Posts

Occasionally FSX/SP1 will suddenly switch to an extremely blurred state. The landclass textures, the aircraft textures, and the VC panel textures become very blurred. There is no evident improvement in the visual or flight performance factors to justify this switch. The aircraft flight and the FPS remain the same. While in-flight this occurs without any notable reason. On the ground I can cause it with several objects (hangers, buildings) in view. If I turn off the objects and reset the the flight it usually returns the program to normal textured resolution.Yes, I know that the program probably believed it ran out of some unknown resource or a process was not getting enough run time. That would be quite acceptable but there is no evidence of why it switches. This leaves the customer unable to understand what they should do except begin a pattern of elimination. This blurred condition is at a maximum extreme. It is not the blurring of landclass textures during flight where only those textures are affected and the aircraft textures remain untouched.The most desirable fix would be to allow the customer to override the criteria for this action to see if the results might be acceptable to them. My system is very low-end, as are some other customer's systems. I can achieve acceptable performance with SP1 with normal center of the sliders settings. The FPS is 25>30FPS. No tweaks of the mystery settings in the CFG file. For me an upgrade to PC3200 DDR memory from PC2300 ($45) helped as did turning off the shadowing of video memory in the boot-up BIOS. I almost exclusively use the default Cessna and the Flight-1 172 Cessna. Good FPS and nice panels with apparent good flight modeling. If I could not be plagued by the ridiculous sudden switching to everything going to a maximum blurred state I could wait for DX10 and write a big check to become up-to-date. 2ghz AMD, 1gb memory, ATI 9800SE 128mbRegards,Dick BoleyA PC, an LCD, speakers, CH yoke

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I think I know what you mean.Well.. It happens even on a high end system. I have a 3.4G OC Dual Core. 8800GTX with 650MB. So its not lack of video memory.This typically happens when I switch views. VC, opot, tower (tower usually have had this issue..but when you change back to spot or vc, it gets back to its crisp state).. Yup..it goes complete blurry mess...but it catches up soon after. Provided I don't change views. Its like the system is basically dumping everything from mvideo emory and regenerating and rendering all over again even though you have not moved far from the previous spot using slew.Manny

Share this post


Link to post
Share on other sites

Hi Dick,I get the same phenomenon with my medium system. And the unpredictability of blurries is one of the most frustrating aspects of FSX. I own FSX but do not enjoy it more than 10 minutes when either blurries or 8 fps pops up. All I do is tweak; after an hour or so I go to FS9 and fly terrific aircraft with very acceptable scenery. For me it shares the greatest potential with the greatest disappoint of the entire franchise. I simply cannot use it as a daily sim as it now stands. Bob...

Share this post


Link to post
Share on other sites

This is an unfortunate problem that Microsoft has decided to let their customers fend for themselves. I have seen posts from people who have DuoCore systems with texture issues. SP1 is both good and bad depending.....I have looked at X-Plane as an alternative but it is visually primitive and the default aircraft are sub-standard. So back to FSX. I plan to upgrade my PC after DX10 is released. I do not want to be caught with some more nasty issues that might render a shiny new motherboard unacceptable.My opinion is that Microsoft has gone down the path of marketing to only the computer literate. Problems and solutions are scattered all over the place. Arcane adjustments that may do more harm than good are put into the public domain with little fore-thought or organization. There is no customer service. Microsoft has strategically left that to sites like AVSIM where the customer with a problem must wade through many messages and try to sort out reality from opinion. This is akin to the people who are "shade tree mechanics" who buy a car and really enjoy making it better. However, the majority of car owners simply want transportation. Do the purchasers of FSX want to simulate flight or spend hours trying to improve the program. Or, for many, spend considerable time (and some money) to just try to make it work! Regards,Dick BoleyA PC, an LCD, speakers, CH yoke

Share this post


Link to post
Share on other sites

I was just going to post on this subject until I found this thread. I have the same problem.I did a fresh FSX install (RTM) yesterday because I had the same problem. Fresh install -> fly out of some airport and after 5 minutes, bang all blurred. It indeed happens also sometimes when switching views. When I do alt-enter twice (out of and back into fullscreen) all is back to normal.So this has happend to me on:- RTM FSX after fresh install- FSX SP1 after fresh install- FSX SP1 with UT-X installed.My system: C2D E4300 @ 2.9Ghz, 2GB PC6400 RAM, 8800GTS 320MB (158.22 drivers)I hope someone finds a way to solve this because it takes the fun out of flyingP.S. I have 16xCSAA and 16xAF set in the nVidia control panel and enabled in FSX.

Share this post


Link to post
Share on other sites

by now, i had this phenomen twice with SP1. Suddenly within a second the outside scenery turned into a blurry mess (and i mean REALLY blurry!), including the clouds. The FPS and the flight were unaffected. After a while it catches up and all is well again. Very strange....Otherwise it performes pretty well with most sliders in the high range, without blurries other than the above problem. -MichaelAMD64 3800x2, 2GB memory, geForce 7800GTX

Share this post


Link to post
Share on other sites

Hi guys,with FS9 we had a similar phenomenon if there was an aircraft or object based DXT1 texture that had not been saved with mipmaps. This is a very different issue than the gradual blurrying that happen over time. Are you guys experiencing this issue without any add-ons or do you have add-ons loaded that include objects and/or aircraft repaints? Dick specifically mentions objects and that the issue disappears if those objects are removed. Sounds just like that problem to me. The key in those cases is to make sure that all object textures in the set use mipmaps. Otherwise, the sim gets "stuck" trying to load mipmaps from the file that doesn't have any.Cheers, Holger

Share this post


Link to post
Share on other sites

>Hi guys,>>with FS9 we had a similar phenomenon if there was an aircraft>or object based DXT1 texture that had not been saved with>mipmaps. This is a very different issue than the gradual>blurrying that happen over time. Are you guys experiencing>this issue without any add-ons or do you have add-ons loaded>that include objects and/or aircraft repaints? >>Dick specifically mentions objects and that the issue>disappears if those objects are removed. Sounds just like that>problem to me. The key in those cases is to make sure that all>object textures in the set use mipmaps. Otherwise, the sim>gets "stuck" trying to load mipmaps from the file that doesn't>have any.>>Cheers, Holger>>Interesting. But, now how are we going to figure out the offedning object?

Share this post


Link to post
Share on other sites

>Interesting. But, now how are we going to figure out the>offedning object? Simple:* Disable all add on sceneries.* If you have installed add on AI-traffic/aircraft, set AI traffic to zero.* If you have installed any custom textures, make sure to restore the original textures from your backup copies (sure you take backup copies!).* If you use XGraphics, restore the to the orginial FSX textures.Run FSX to confirm that the problem is gone.Activate each add-on, one by one, and test FSX for each add-on until the problem returns. Most likely the last activated add-on has some texture that causes the problem. Takes some time, but I don't know any better approach.Ulf B :-)

Share this post


Link to post
Share on other sites

Another way to temporarily get rid of the blurries is set up a key stoke like "shift I" for a refresh. Sometimes this can be time consuming waiting for the refresh but it does work. At least for me most of the blurries are 90% gone when I disabled AA and AF at the video card and let FSX control. Unfortunately this has not worked for others. CarlDell E510, P4 3.4g, 3gRam, 7600GS pci.

Share this post


Link to post
Share on other sites

The objects I use are installed By the addon Instant Scenery which is similar to the Microsoft object installer tool. I used many of them in FS9 with the Lago EZ-Scenery. I doubt that the issue is missing mip-maps since sometimes it loads ok. There seems to be a dependency on "resources". It is worse when I get greedy and use Autogen. Another complaint - Microsoft should tell the customer the reason when they invoke aberrant behavior - severe maximum blurring, falling to the desktop are some.Regards,Dick BoleyA PC, an LCD, speakers, CH yoke

Share this post


Link to post
Share on other sites

>The objects I use are installed By the addon Instant Scenery>which is similar to the Microsoft object installer tool. I>used many of them in FS9 with the Lago EZ-Scenery. I doubt>that the issue is missing mip-maps since sometimes it loads>ok. There seems to be a dependency on "resources". It is worse>when I get greedy and use Autogen. >>Another complaint - Microsoft should tell the customer the>reason when they invoke aberrant behavior - severe maximum>blurring, falling to the desktop are some.>Perhaps I still don't want SP-1 :7 FWIW, no sudden shift to a blurred state. No blurries to start with!Some who have seen my screenshots, believe that the fading with loss of resolution in the distance using a somewhat degraded sceenie is blurries; it certainly is not!My FS9 will randomly do it's blurry thing, following a zig zag pattern in the near distance. My FSX does not, and never has. FS9 did it this morning when I wanted to remind myself how inferior it looks compared to FSX in my default flight area of the mountainous KSLC. At the moment, I have FSGenesis mesh and land class, as well as Ultimate Terrain.L.AdamsonAthlon 64 3800+/2Gig/Geforce 7600GS 256meg/1600*1200*32

Share this post


Link to post
Share on other sites

May I add that the complete sudden blurring we are talking about here happend to me on FSX RTM and SP1 "OUT OF THE BOX" (nothing else installed). So it could well be that the problem is not in any addon (or maybe there is a similar error but then it is caused by FSX)!And yes, I defragged (with UDefrag / File-Folder and FSX priority)Regards,

Share this post


Link to post
Share on other sites

I would like to add some screenshots to this topic to illustrate the problem. The best way to reproduce the problem is to cycle the view using the S key past tower view and back to the original view. Most of the time the textures will go blurry and rebuild as you fly on. This also happens at random during flights. It can take 10-20 secs to catch up, not cool!The following 3 screens show a before and 2 after shots (before and after cycling the view)http://forums.avsim.net/user_files/173862.jpgBeforehttp://forums.avsim.net/user_files/173864.jpgAfter view cycle. (Can also happen at random during flight)http://forums.avsim.net/user_files/173865.jpgAnd FSX catched up.You might notice that I have UT-X installed, but as mentioned before, this also happens on RTM and SP1 FSX.I wonder what % of people using FSX have this issue. Either very blurry textures after view cycle or suddenly during flight. Anyone?Regards,C2D @ 2.9Ghz, 2GB RAM, 8800GTS OC

Share this post


Link to post
Share on other sites

Another solution is to remove the tower views from the Cameras.cfg file. I did that a few weeks ago.

Share this post


Link to post
Share on other sites

Please dont think that SP1 did much for us dual core guys. You single core users get much the same performance as we do. The second core may get used but who knows what it is actually doing, maybe counting sheep as it does very little to improve the game. I can disable one core and there is no change in scenery draw or fps ie no difference if i have them both running or not and it seems intel guys have same thing. Although it is nice for the non pc wise guy to look at the charts and say ,oh dosnt that look pretty. Oh yes i get same problem.AMD X2 64 60002 gig ddr2 800 MHZ cas 4 ramAsus M2n moboNvidida 8800GTS 320 meg video ( should of got the 640 )2 X 250 gig SATA hd

Share this post


Link to post
Share on other sites

>P.S. I have 16xCSAA and 16xAF set in the nVidia control panel>and enabled in FSX.16xAA??I have an 7800GT card in SLI and run 4xAA and find it perfectly usable. AA in FSX is switched off and AF set to x16 on card. Try lowering your AA.Ray Keattch.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this