Archived

This topic is now archived and is closed to further replies.

Stuntie

Track IR not working

Recommended Posts

Got Track IR 3 with 6dof attachment.Works fine in FS2004, IL2 etc., but doesnt seem to be picked up in FSX.It's active (LED is on), but no response in FSX.Any settings or anything I need to check?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have a #3 as well and it works fine, you might like to check that you have the latest software: "TrackIR_4.1.030.Final".John

Share this post


Link to post
Share on other sites

Updated and still not working.Did the Simconnect.dll thing from the TrackIR support page as well.Mentions a Simconnect.xml file that may be a problrm, but can't find that even with a full hard drive search.

Share this post


Link to post
Share on other sites

If you are using other products that utilise SimConnect you can end up with a conflict because TrackIR needs a local setting of 127.0.0.1.For good measure, the following SimConnect.xml file should work (it should be in the application data/microsoft/fsx folder where your fsx.cfg file is located) (note that the 192.168.0.200 IP address should be changed to the IP address of your machine):<?xml version="1.0" encoding="Windows-1252"?>SimConnectSimConnect.xmlFalseFalseIPv4global

192.168.0.200
645004096FalseFalseIPv4local
127.0.0.1
645004096FalseAndrew

Share this post


Link to post
Share on other sites

I can't find simconnect.xml in the apps...fsx folder.Should it be there by default?If it is missing where can I install it from.Already did a repair on FSX and that didnt install it.

Share this post


Link to post
Share on other sites

Just cut and paste the above supplied version into notepad and save as SimConnect.xml in the folder I described. See if that helps - if not, it's not the file that is the problem. I don't think you should have a SimConnect.xml file by default but I could be wrong on that ...Andrew

Share this post


Link to post
Share on other sites

Yea, the xml file isn't installed, or used by default. It is only added , by other applications that are using the simconnect app. across the network, besides the local system.....Are you getting a blue LED activating, when you start a flight?FSX is listed on the Profiles page, of the TrackIR software?What antivirus software areyou running?

Share this post


Link to post
Share on other sites

Software and games are up to date V4.1 30.FSX is in the profiles.I have TIR3 Pro with 6DOF vector clip.Yellow light is on.But no movement in FSX.Software is AVG 7.5.Doesnt affect IL-2, CFS3, FS2004, BOB2 or any other TIR game.Most annoying as it was working pre FSX update.

Share this post


Link to post
Share on other sites

Do you check that the TrackIR is working before starting FSX using view/tracking option? I find that I have to disconnect and reconnect my USB connection to get the TrackIR to start properly after I have booted up. I have never seen a yellow light, my colours are GREEN for "All is good", Red when the unit can't see a reflection, a yellow and red or orange when the unit is working but paused. When I start FSX a blue led comes on at the bottom of the unit.John

Share this post


Link to post
Share on other sites

Blue is TIR4 i believe.TIR 3 pro has a top LED that is Red for no reading, Yellow for tracking, and off for off.I get the yellow tracking from before FSX starting and right through till after FSX has shut down.But no TIR in game.

Share this post


Link to post
Share on other sites

Should still be green on the top, and you should also be seeing a blue LED, on the bottom of the TrackIR 3 as well, if the software is detecting the gaming application.OK, one step to try

Share this post


Link to post
Share on other sites

>Should still be green on the top, and you should also be>seeing a blue LED, on the bottom of the TrackIR 3 as well, if>the software is detecting the gaming application.>Yep, I am getting the blue led for games, but not for FSX>OK, one step to try

Share this post


Link to post
Share on other sites

Reinstalled and still no joy.How is FSX detected?Does it use a registry entry at all?Or an ini file?If so can you let me know what it checks for soI can ensuretheyare there correctly.Thanks.

Share this post


Link to post
Share on other sites

It sees simconnect load, in the memory, when FSX starts.Creation date for the simconnect folder?

Share this post


Link to post
Share on other sites

C:WINDOWSWinSxSx86_Microsoft.FlightSimulator.SimConnect_67c7c14424d61b5b_10.0.60905.0_x-ww_429211e9Version 10.0.60905.0C:WINDOWSWinSxSx86_Microsoft.FlightSimulator.SimConnect_67c7c14424d61b5b_10.0.61242.0_x-ww_35e8ee9aVersion 10.0.61355.0 (fsx-sp1.20070510-2038)

Share this post


Link to post
Share on other sites

>C:WINDOWSWinSxSx86_Microsoft.FlightSimulator.SimConnect_67c7c14424d61b5b_10.0.60905.0_x-ww_429211e9>>Version 10.0.60905.0>creation date of the folder above?

Share this post


Link to post
Share on other sites

Does the software main screen say it's connected to FSX when you run everything? It's one thing to have an FSX profile enabled, it's another to have TrackIR actually connect to the software. It should say:Current Game: FSXCurrent Profile: XXX (where XXX is your custom profile)If it says Current Game: None, there's no connection despite the profile.I had this issue crop up just this week as I installed a Logitech MX Revolution wireless mouse, which caused TrackIR to act up. TIR refused to recognize games/sims, and it would crash on exit. I fixed it by downloading the lastest TIR software, removing the current software (which was the same version), unplugging the TIR device, re-installing the TIR software, and plugging in the device again.If this sounds like your issue, then this could work for you. It's pretty much the same as the advice from the rest of the posters, but this was my specific situation. The other thing I can think of is that you should look at the tracking screens in TIR are actually tracking the Vector Clip. I once spent some time and swear words on trying to "fix" the TIR software, when in reality, I had bumped the camera, and it was looking just far enough off to the side to stop tracking my hat. I'm not familiar with the TIR3 lights, though, but I now include a periodic test to see that TrackIR is properly oriented in my pre-flight checklist. Jeff ShylukSenior Staff Reviewer, Avsim

Share this post


Link to post
Share on other sites

Is the blue led coming on, when FSX loads a flight?

Share this post


Link to post
Share on other sites

>Is the blue led coming on, when FSX loads a flight?Sorry for the delay responding. Been a busy weekend.No Blue LED.I get the Blue LED with IL-2 BoB and other games. Nothing with FSX.Tracking is fine.Main tab says current Profile: Default profile.Current game : None

Share this post


Link to post
Share on other sites

>Does the software main screen say it's connected to FSX when>you run everything? It's one thing to have an FSX profile>enabled, it's another to have TrackIR actually connect to the>software. It should say:>>Current Game: FSX>Current Profile: XXX (where XXX is your custom profile)>>If it says Current Game: None, there's no connection despite>the profile.>>I had this issue crop up just this week as I installed a>Logitech MX Revolution wireless mouse, which caused TrackIR to>act up. TIR refused to recognize games/sims, and it would>crash on exit. >>I fixed it by downloading the lastest TIR software, removing>the current software (which was the same version), unplugging>the TIR device, re-installing the TIR software, and plugging>in the device again.>>If this sounds like your issue, then this could work for you. >It's pretty much the same as the advice from the rest of the>posters, but this was my specific situation. >>The other thing I can think of is that you should look at the>tracking screens in TIR are actually tracking the Vector Clip.> I once spent some time and swear words on trying to "fix" the>TIR software, when in reality, I had bumped the camera, and it>was looking just far enough off to the side to stop tracking>my hat. I'm not familiar with the TIR3 lights, though, but I>now include a periodic test to see that TrackIR is properly>oriented in my pre-flight checklist. >>Jeff Shyluk>Senior Staff Reviewer, AvsimCleaned it off, unplugged.Reinstalled replugged.All up to date - both software and game updates.Still not working.

Share this post


Link to post
Share on other sites

1 - Delete the following file folder C:WINDOWSWinSxSx86_Microsoft.FlightSimulator.SimConnect_67c7c14424d61b5b_10.0.60905.0_x-ww_429211e92 - Insert the FSX CD, and run the repair utility. Basically we are looking to reinstall the folder.3 - Hopefully this should remedy the issue. Please let me know if this helps.

Share this post


Link to post
Share on other sites

>1 - Delete the following file folder>> C:WINDOWSWinSxSx86_Microsoft.FlightSimulator.SimConnect_67c7c14424d61b5b_10.0.60905.0_x-ww_429211e9>>2 - Insert the FSX CD, and run the repair utility. Basically>we are looking to reinstall the folder.>>3 - Hopefully this should remedy the issue. >>Please let me know if this helps.>This was mentioned and tried earlier.I tried it again , and still no joy.

Share this post


Link to post
Share on other sites

Are you attempting to use the same USB port?I've had some issues with losing my TrackIR 4 after installing programs, etc. (I don't run a static IP BTW, so my computer may be on one of 3-4 IP addresses).What I've found is sometimes I have to plug the TrackIR into a different USB port, I reboot the machine, it usually finds the TrackIR device, asks if I want XP to search for the drivers, and I allow it to reinstall the drivers automatically. I'm then set until I lose it again.I know I should find a permanent solution to this, but thus far this has worked for me, and does not take too much time.

Share this post


Link to post
Share on other sites