Sign in to follow this  
tf51d

WIll the Lack of SP2 end my future FSX experience?

Recommended Posts

I've had no luck with Acceleration and SP2 installation. It corrupts my FSX installation to total unusability and yes, I have scoured this forum with all SP2 reports and tried them all, including the famous dll.xml thing which was never a problem for me anyway. I must say I have not done a total FSX reinstall and really don't care to at this point. My question is this.....if the separate release of SP2 in December or whenever it's coming along also crashes my FSX and I have to turn back to SP1, is that the end for me? That is to ask, is SP2 something that addon developers will demand is installed in order for me to use future add-on products, esp. from the most major developers represented here on the AVSIM forums?Windows XP Home SPX, whatever is the latestNVIDIA 8800 GTS4 Gig RAMIntel Duo Core, bla, bla,blaRandy Jura, KPDX

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>I doubt it - but I bet if you try a little harder you can>make it work.Any suggestions Tony, or are you just trying to stir the pot again?

Share this post


Link to post
Share on other sites

Stir the pot again.....LOL..........thank you for that...but actually, he's right. The only thing I have not tried "harder" at is a complete reinstall of everything FSX. I'm not doing that yet because frankly I'm a bit terrified at trying. If it doesn't work, my flight simming is toast after some 25 years if SP2 is indeed mandatory in the future. That would be painful. I hope the other answer is correct, that SP2 is just something that might be needed for the highly overrated DX10 "experience" through Vista. I have no interest in Vista for at least another year. And DX10 is definitely not needed,not by me anyway. Randy Jura, KPDX

Share this post


Link to post
Share on other sites

From my side of the view, it is even more complex than SP2 or SP1. Let's wait SP2 release (it is not released yet), to see if this is only RTM, SP1, SP2/Accel versions we have to deal with (3 versions), or, if this is RTM, SP1, SP2, Accel versions we have to deal with (4 versions).You can find on public blogs that there are breaking changes for some of us (at least me) between SP1 and Accel because of new bugs introduced under some circumstances because of modified SDK done to support the HUD of the Accel pack. It is only when Accel pack SDK is released (or when there are insider information on public blogs) that we can assess for sure what is compatible or not.Although SP2 can be seen (and has been interpreted at in this forum) like a core update + addon aircraft/missions/sceneries, you don't know until official release if this is true, or, if SP2 is "almost but not all" of the core updates included in Accel. And from then, will there be breaking changes or not.As of today, I don't use anything more than SP1 requirement though (and I've found a workaround to the new bug in Accel because of the HUD support - info about this here: http://blogs.technet.com/engauged/archive/...t-possible.aspx )Hope this helps!

Share this post


Link to post
Share on other sites

Holy moly......um....I'm kind of speechless. Flightsimming used to be kinda/sorta straight forward for developers and users alike. This is turning into a foreign language of phrases that have kind of intruded on what used to be far easier to understand.....suddenly, I feel very old!Randy Jura, KPDX

Share this post


Link to post
Share on other sites

Jim, I don't know how you know, but until release, no one knows for sure. And we may all be surprised Accel is slightly more than just SP2+content (acft,missions) or not surprised at all with Accel = SP2+content. If the former, there could be some incompatibilities between SP2 users and Accel users, to the point some features could not be supported by developpers. Let's wait SP2 release and I'm sure it will become clearer in the forums from that moment...

Share this post


Link to post
Share on other sites

FSx runs just fine with SP1, and with all the reported problems with SP2, SP2 is going the same way Vista is on my machine, in the trash bin. :-)

Share this post


Link to post
Share on other sites

And I have the contrary feelings : SP2 is shining on my Vista x64 , in both DX9 or DX10 modus. I prefer DX10 preview because of the HDR light effects. Without, planes just look cartoonish. At least, with DX10, they look more real.Only thing : Vista needs all patches installed.Almost all problems I have read about FSX SP2(Acceleration) here on AVSIM or elsewhere, fall into those two categories : - windows XP SP2- Vista without all the fixes and patches installed.Unfortunately, only the second category is easy to fix.Now waiting for NVidia to release a new set of drivers to fix some (for me minor) problems like shimmering textures on runways.Someone did a benchmark, and FSX is actually running faster under Vista x64 when SP1 or SP2 is installed, only RTM is running faster under XP.Just my 2 cents, to ever his view. And personally I would not spent money on Vista just to upgrade to DX10, it can be better spent.Jan

Share this post


Link to post
Share on other sites

Great! I feel relieved. I can't wait trying multiplayer, and shared cockpit sessions between my Accel version, and my co-worker SP2 version then.

Share this post


Link to post
Share on other sites

You guys all need to get on the same page....LOL!!LevelD forums have stated that SP2 is NOT the same as the SP2 in Acceleration and they will not issue a patch until the free SP2 has been released.Which is it....changes or no changes?Glenn

Share this post


Link to post
Share on other sites

Glenn, it is very easy:either you don't have SP2 and need to wait release to be sure, or you have SP2 and thus are under NDA and can't tell...So "no ones knows for sure until release" applies there, although I have a fair idea this might not be the same SP2 than in Accel, otherwise, it would be the same core code branch released almost at same time as Accel, without the extra aircraft/mission/sceneries, and I think I've read in the forum or a blog it is a different code branch, with a different beta testing...Hope this helps!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this