Sign in to follow this  
Guest alexhn

Rather annoying little problem on approach

Recommended Posts

I was inbound last night to Singapore after about 7 hours of flying, and everything was going fine; descent mode active, approach briefing complete, approach and descent checklists completed, and then, when i went to arm the approach mode: "Arming localizer" or something along those lines the captain said, however the LOC mode did not infact arm when i clicked on it. Neither would approach mode. I decided to handfly, however neither the throttle nor flight controls could be controlled by me when the autopilot/autothrottle were disconnected.Any help?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>I was inbound last night to Singapore after about 7 hours of>flying, and everything was going fine; descent mode active,>approach briefing complete, approach and descent checklists>completed, and then, when i went to arm the approach mode:>"Arming localizer" or something along those lines the captain>said, however the LOC mode did not infact arm when i clicked>on it. Neither would approach mode. I decided to handfly,>however neither the throttle nor flight controls could be>controlled by me when the autopilot/autothrottle were>disconnected.>>Any help?>>Bugger. Nothing worse than a long flight only to have a glitch at the end screw it up. From your description the fault appears to be with the PMDG end. FSCrew seemed to be working fine. Remember that there are limitations with what can be read from PMDG 747. I am sure Bryan will correct me if I am wrong but the arming call would be activated by pressing the appropriate button. Normally it would arm and the call reflects this.CheersSteve

Share this post


Link to post
Share on other sites

Hi Alex,Hard to say. Only thing I can suggest is that you confirm you have no keyboard conflicts with APP and LOC and that you didn't try changing the original FS2Crew keyboard assignments.Hope that helps,Bryan

Share this post


Link to post
Share on other sites

I've just noticed this on approach to LEIB. After turning onto an intercept heading for the ILS, press LOC and nothing (except the voice saying "Localiser armed"), same for APP. I decided to hand fly from this point so disconnected autopilot only to find no response from yoke or rudders (CH products) - they had been turned off. Not sure if FS2Crew had pressed something that turned them off but on re-enabling them in the controls menu all was fine.Henry Cleaver

Share this post


Link to post
Share on other sites

Have observered this on my 2 last flights also, into WSSS & RGBB... APP and LOC not arming, but hearing the vocal "Localiser armed" etc.Dan

Share this post


Link to post
Share on other sites

It could be that you have not met the conditions required by the PMDG 747 for APP or LOC to arm or engage via the autopilot, so APP/LOC would not have engaged regardless.In the 2D cockpit, when you press APP or LOC you will always say "Loc/Approach Armed" regardless of whether APP/LOC actually arm.When you press APP or LOC, a simulated keypress is then made that is used to essentially press the LOC or APP button. (Remember that I had to lay a gauge over top of the APP and LOC buttons).APP: CTRL TAB JLOC: CTRL TAB KThe test is to go into the VC and try arming LOC or APP there. FS2Crew could not lay a gauge over top of the APP and LOC buttons in the VC.Cheers,Bryan

Share this post


Link to post
Share on other sites

Interesting. Thanks Bryan. APP and LOC work in the VC... had noticed that to set the "STD" one would need to go into the VC also. Didnt occur to the brain to try APP and LOC!Dan

Share this post


Link to post
Share on other sites

Dan,Double check your keyboard assignments or make sure nothing is intercepting the keypresses (like having Squawkbox in focus or having the FMC set to accept key presses).STD is the same as APP or LOC. I layed a gauge over top of these buttons (2D cockpit only) so a sound could play when you click these buttons. When you press either of these buttons, FS2Crew is making a simulated keypress to activate STD, APP or LOC.I just tested it and it works for me.(P.S. When you don't have an SDK, clever things like this need to be done in order to get any sort of integration.)Cheers,Bryan

Share this post


Link to post
Share on other sites

Hi GuysI had the same problem in terms of activitating LOC and APP - I found that the FO Flight Director switch was not armed?I have also found my joystick disabling without any apparent reason?Control K?Further I cannot set the baro to standard in the 2d cockpit. The display does not show std in the yellow box. I just get the voice saying alt set to 1013 and x checked.The baro press works in the VC (with no voice). I realise that Bryan has overlaid the panel to get the voice onto the baro press but can I get the display to react properly as well?

Share this post


Link to post
Share on other sites

Mike,Make sure the Keyboard Ini file is set to FS2Crew via the Start Center.That would explain why the keypress are not activing LOC, STD BARO, etc.If you're finding your joystick is becoming disabled, check to see if there is a key assignment for it in the FS9 key assignments menu, and delete the assignment. That's my only suggestion as I have never come across that one before.All the best,Bryan

Share this post


Link to post
Share on other sites

BryanThanks for the reply - I had already copied the keyboad file across in the start centre. Restored PMDG selected FS2crew and still have the problem. Can you tell me which default file name is renamed and then copied over by FS2crew keyboard so that I can check what is what?Mike

Share this post


Link to post
Share on other sites

Mike,Send me an email:admin@fs2crew.comI'll send you my copy of the Keyboard Ini file so you can cross check it with yours.Also, just a thought but I seem to recall reading on the PMDG forum that you should install the 744 after installing the 737.Just a wild guess, but did you by chance install/re-install the PMDG 737 after installing the PMDG 747?Chrs,Bryan

Share this post


Link to post
Share on other sites

Sorry to drag this up from a billion years ago, but after days of searching through googles massive Archive of 2-3 generations of flightsim I finally stumbled across this thread.

 

I am having this same problem. Where clicking App on approach plays the sound file but does nothing else apart from disable my joystick.

 

Was there a know workaround to this problem?/ do I just need to look at keyboard Ini files wherever they may be....

 

Thanks!

Share this post


Link to post
Share on other sites

Does your joystick get disabled everytime at the exact same point?

 

Or was that just a one off thing?

 

 

Send me a Support Ticket via our website.

Share this post


Link to post
Share on other sites

Thanks Brian, but actually thanks to this topic it got me thinking and i have worked out the cause of my problem.

 

This one has been bugging me for days, and its proving so hard to find any solid information on anything related to the old queen, google is to eager to push me threads about newer versions rather than the stuff i am looking for from 2005/8

It was your comment above about overlays and simulated keypresses that got me thinking, so I cleared out everything and let FS2crew re asssign again via the start center, and everything works a peach...

Thanks tho. appreciate your help and your work on what you do, i may be flying old kit, but im having lots of fun in my Ifly 737, Ld767, and pm747... all with your program attached!

I cant begin to wonder what you have done in the last few years looking at the pace of development of all things flightsim!

 

rgds
Liam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this