Sign in to follow this  
Guest BrianFletcher

Can someone please explain what stuttering is?

Recommended Posts

I have been struggling for two months now to end my stuttering problem in FS9. I am getting exceptional frame rates of 60+, but the simulator is choppy. Can someone explain what causes stutters? I have tried every suggestion given on these forums to fix the problem, but it has not gotten any better.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

What system are you running? If you post the specs here some of us geeks may be able to assist :-)Mostly I have found that different specs, different slider settings and the BIGGEST thing -- how you maintain your windows, are three of the biggest factors in how FS runs.Sliders can be a huge issue. I have a halfway decent system (specs in my signature) -- runs FS2004 at 60+ FPS with no problems, smooth rates and so many add-ons I filled a 500GB partition . . . . yet the default installation of FSX with similar slider settings brings it to it's knees. In FSX I killed the autogen and maxed all other sliders and whalaa -- smooth sim. There may be just that one magic slider in your FS that is cauing the issue.OH!!! In FS2004 I have all sliders maxed EXCEPT Weather. In 2004 Weather seems to be the killer. I leave weather at default and I have great performance even with max autogen. Max the weather, though, and FS2004 does to this system what FSX does to it with it's autogen . . . . .

Share this post


Link to post
Share on other sites

I'm using an Athlon 64 FX-62 Dual core, GeForce 7800 PCI-e, and 4 GB of ram on my Asus motherboard (not sure which one). My computer is about 3 months old with a 1000 Watt power supply and a liquid cooling system from Aerogate. I keep all of my FS settings at "High" or the equivalent. I have tried reducing all of the settings to the absolute minimum with no traffic, no autogen, etc, etc, but the stutters still happen. I went through every tweak I could find in here, but no improvements came of it. I did manage to get my frame rates up quite a bit, but with the stutters, it really doesn't matter.

Share this post


Link to post
Share on other sites

>ASUS M2N32-SLIdeluxe>AMD Athlon 64 X2 Dual-Core 5000+>8 GB OCX DDR2 EEC Memory>2x GeForce 7600 GT SLI'd8 GB??? Even FSX + future addons will not probably take advantage of 8 GB... Why didn't you save those bucks to buy a more powerful videocard or CPU?Marco

Share this post


Link to post
Share on other sites

HiStuttering of the scene (regardless of the frame rate), is normallydue a problem of data throughput. Ie the scene has to get originallyfrom disk (8G RAM - no problem here then), into RAM, then from theRAM to CPU/GPU etc. The stuttering is most effected by the fsbspeed - this is a clock rate measure of the data through themotherboard. The stutter is usually the wait of the GPU for more sceneto be sent to it. 1) It is not dependent (usually) of the speed of your CPU/GPU2) What is the fsb speed of your motherboard.3) The GPU you are using I believe are PCI-express, so this is fast and is unlikely to the route of the problem.4) Could it be some setup problem with the SLI'd GPU - have yougot the latest drivers for these ?5) Terrible disk fragmenting - but since you have 8Gb of RAMI would have thought you could load the entire world into memoryso this would only effect start up times.The normal solution would be to reduce the scene complexity andmove sliders to the left. This results in less scene detail beinggathered from the RAM. In your case you should be able torun FS2004 flat out unless you have some really crappy mother board.My guess is there is a driver problem for the GPU causing some conflict.Can you set your GPU to work with a single one - you should haveno problem with just a single GPU with performance, this mightreduce the fps but does it remove the stuttering ?Just for comparison I have a moderateDual 2.8 intel 945 with hyperthreading800 Mhz fsbATI X600 with hypermemory.1G mem30 to 70 fps.I can run FS2004 with most sliders (scene + weather) maxed out,and I only notice stutter with a F14 flying at 800 knots at groundlevel with GE-texture/76 meter mesh and UT loaded and maxed out. You should be able to easily exceed this.Anyway, just my 2p worth.Tom

Share this post


Link to post
Share on other sites

Three key points: defrag, defrag, defrag. Hopefully you defragged your HD before installing fs9 and after. You should also defrag regularly, especially after installing large add-ons. Get yourself a 3rd party defrag utility that works much faster than the default. I use Diskeeper, but any of the other ones are good as well. I defrag regularly, at least once a week. All the PC power in the world isn't going to help if your hard drive is fragmented severely. For example, last night I noticed my two drives were "slightly fragmented". So, I schedule them both to defrag overnight and the next morning it is done. Now, stop trying to run at 60fps. FS9 simply won't work well at that level. You would think that 60 fps would be smoother than 30 fps, but in FS it isn't usually the case. The problem is the FPS counter isn't necessarily showing you the full picture. I remember a discussion awhile ago about how the FPS counter shows more of an average and doesn't update all the time. I don't remember the details, but you are seeing it on your system. I remember we've had the debate here about locking FPS vs leaving it at unlimited. I tried mine on unlimited, and I ended up getting much higher FPS according to the counter, however FS9 ran exactly the same. Try your FPS locked at 25 or 30 at the highest and see what happens. After that, there are tons of tweaking threads here. Some that contradict others. One set that works pretty well for me is from Flightscenery: http://flightscenery.com/optimizingfs.htm

Share this post


Link to post
Share on other sites

>5) Terrible disk fragmenting - but since you have 8Gb of RAM>I would have thought you could load the entire world into>memory so this would only effect start up times.>The fact that you have enough ram to load the entire world doesn't mean that FS does that. It loads and unloads scenery on the fly. When and how much of it depends on the radious settings in your CFG file. If you have a bottleneck somewhere alone the file system pipeline (i.e. FBS, fragmented HD...etc), stutters will still hit you even if you have a lot of ram. It only helps in the way that you'll never run out of ram with FS needs to load a lot of stuff between a complex plane and many addon sceneries at the same time.That's my understanding. I may be wrong about it.Jason

Share this post


Link to post
Share on other sites

>>ASUS M2N32-SLIdeluxe>>AMD Athlon 64 X2 Dual-Core 5000+>>8 GB OCX DDR2 EEC Memory>>2x GeForce 7600 GT SLI'd>>8 GB??? Even FSX + future addons will not probably take>advantage of 8 GB... Why didn't you save those bucks to buy a>more powerful videocard or CPU?>>Marco>>Because I got the memory for free :-) I never pass up free stuff.

Share this post


Link to post
Share on other sites

>>5) Terrible disk fragmenting - but since you have 8Gb of>RAM>>I would have thought you could load the entire world into>>memory so this would only effect start up times.>>>The fact that you have enough ram to load the entire world>doesn't mean that FS does that. It loads and unloads scenery>on the fly. When and how much of it depends on the radious>settings in your CFG file. If you have a bottleneck somewhere>alone the file system pipeline (i.e. FBS, fragmented>HD...etc), stutters will still hit you even if you have a lot>of ram. It only helps in the way that you'll never run out of>ram with FS needs to load a lot of stuff between a complex>plane and many addon sceneries at the same time.>>That's my understanding. I may be wrong about it.>>Jason Uhm, I think that one confused my reply with the original poster. The original poster didn't say he had 8 GB of RAM. As for me, I defrag religiously . . . every Sunday :-) I forgot to mention that in my original reply to the poster, but I do agree fully, defragging IS crucial. The original poster has 4GB which is about average, but the reply is right, you shuld defrag often.

Share this post


Link to post
Share on other sites

You could test the defrag theory with the following flight1) Fly straight for some 5 minutes. This will load textures intothe memory from disk if they are not already there. Any textureloaded out of FS2004 will still be cached within pages of memorystill in RAM. Ie if you have lots of RAM old "deleted" objectswill remain cached in the RAM in the page file. (probably - wellthey do in linux, I use this sort of thing in my work)2) Now fly back exactly the same 180 heading so that you retracethe same texture. See if the stutterstill happens. If the stutter has gone away then the texturesare being loaded for RAM cache and not from the disk and the diskis a mess. If you still get stutters then the problem may stillbe fragmented disk or some other bottle neck. 3) Do you get a lot of disk activity if flying - so loadingnew textures - and getting stutter. You will hear a fragmenteddisk working hard if this is the case. You should also be ableto look in the MS system tools for a run time environment viewand see if there are lots of IO waits - again I am a linux person mostly so I cannot give you a link at the moment. I knowwin XP has system tools to graph various properties - I believeon win XP IO wait shows up as CPU idleThis may not be conclusive as it depends on the latency ofobjects within the page cache file in windows.4) Finally, I have done various experiments and tweaking with limiting the max fps and like some article discuss (sorry - can'tremember the reference) I see an improvement when using unlimitedfps. This is counter-intuitive - as it would seam obviousthat if the CPU is idle then it would have time to load terrain.It suggests a problem with the wait for refresh when the fpsis limited within the code. Ie I see > 30 fps and usually about60 fps on unlimited, but I see fps falls and stepping when limitingthe fps to 20 or 30.Regards

Share this post


Link to post
Share on other sites

>8 GB??? Even FSX + future addons will not probably take advantage >of 8 GB... Why didn't you save those bucks to buy a more powerful >videocard or CPU?I'm running 4 GB, I believe it is the person who asked for my specs that's running 8 GB.>The normal solution would be to reduce the scene complexity and>move sliders to the left. This results in less scene detail being>gathered from the RAM. In your case you should be able to>run FS2004 flat out unless you have some really crappy mother >board.I tried moving all sliders to the left, which shot my FPS through the roof, but did not eliminate the stutters.>My guess is there is a driver problem for the GPU causing some >conflict.>Can you set your GPU to work with a single one - you should have>no problem with just a single GPU with performance, this might>reduce the fps but does it remove the stuttering ?I still see stuttering, perhaps a little less, but I can't really tell because I don't have a way to measure the stutters. By my naked eye it looks close to the same as before. The FPS did go down a touch.>I can run FS2004 with most sliders (scene + weather) maxed out,>and I only notice stutter with a F14 flying at 800 knots at ground>level with GE-texture/76 meter mesh and UT loaded and maxed out.>You should be able to easily exceed this.Up until two months ago I had the same results, but for some reason the stutters just came out of nowhere. I even re-installed WinXP and FS9 without installing any add-ons, but the stutters were right there waiting for me. >Three key points: defrag, defrag, defrag. Hopefully you defragged >your HD before installing fs9 and after. You should also defrag >regularly, especially after installing large add-ons. Get yourself >a 3rd party defrag utility that works much faster than the default. >I use Diskeeper, but any of the other ones are good as well. I >defrag >regularly, at least once a week.I also use Diskeeper. I did defrag before I installed FS9, and again directly after. I usually defrag once a week as well, but since I have been having so many problems, I have been defragging every few days. For some reason it just doesn't seem to improve my performance. >Try your FPS locked at 25 or 30 at the highest and see what >happens.I locked the FPS at 25, 30, and 35. The stutters seemed to lessen when locked at 30, but they were still bothersome.

Share this post


Link to post
Share on other sites

>I'm running 4 GB, I believe it is the person who asked for my>specs that's running 8 GB.Infact my post was directed to him. :)>Up until two months ago I had the same results, but for some>reason the stutters just came out of nowhere. I even>re-installed WinXP and FS9 without installing any add-ons, but>the stutters were right there waiting for me. Maybe you have a "heavy" antivirus or firewall?Or maybe you have spyware? Have you tried running some anti-spyware programs?Try running perf monitor or disk monitor to track down some application that is causing continue disk or cpu access and thus causing stutters:http://www.microsoft.com/technet/sysintern...essmonitor.mspxhttp://www.microsoft.com/technet/sysintern...es/diskmon.mspx(you need WinXP SP2)Marco

Share this post


Link to post
Share on other sites

My experience is that rapid stuttering is tied to the video driver.Try another driver release if you can.. it may help.Also, as a test, lower AA and AF settings and maybe screen resolution, just to see what impact it has.Also, try flying out of Midway Island or such, as a test for low scenery load.Slow, intermittent stuttering is usually caused by some background program, like anti-virus monitoring, kicking in.Running Filemon concurrent with FS9 will show you if other programs are interfering.

Share this post


Link to post
Share on other sites

I concur with Marco. Also remember that newer is NOT always better. You say the stutts started suddenly, even with a reinstall of Windows. Did this occur after a windows update? Are you using a recently released graphics driver? One idea may be to look up and download an OLDER driver and see if thathelps.I know this may sound strange, but I have had cases on my gaming machine where a new driver fixes some games . . . at the expense of breaking others. The same went for my sim. I had an ATI driver when i was running ATI that fixed an issue with Unreal, but made my FS perform worse and even have a lot of CTD's.

Share this post


Link to post
Share on other sites

I'm running a Dell XPS 700 with a Pent.D, 3.40 Ghz (Dual), Nvidia 7900GTX (Dual) and 2GB RAM. Also, using WinXP.While trying to get rid of stutters, I've done the defrag, disabled SLI on the dual graphics, set Priority to High, set Affinity to only one CPU and experimented with limited and unlimited FPS. Plus several other things that made no difference.Using only one CPU does make a difference for the better, but it isn't good enough.For me, the most stutter-free solution was to use the Microsoft version of a "Clean boot" (see Microsoft KB 815069). That procedure shuts down all startup programs and everything else except "essential" services. The results: Early in a flight, while still at low altitude, very minor stutters can still be seen if I concentrate and look for them. I could easily live with this solution, except the clean boot is a damned nuisance. Especially if you're about to taxi for takeoff and realize you forgot to start with a clean boot!In summary, don't discount all the garbage that's continually running in the background, using up resources and jumping in and grabbing the CPU at any time. From what I've read, Enditall or FSAutostart (IIRC) seem to help, but setting them up may be no small task.None of the above is new info, but I just wanted to share my experience. Hope this provides some food for thought. Regards,JerryH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this