Sign in to follow this  
Guest Osure66

FS9.1 and VISTA

Recommended Posts

I recently upgraded from a Dell 8400 XP SP2 to a Dell XPS-420 with VISTA Home Premium OS.After installing and setting up FS9 without any addons, I ran FS9 using the Boeing 737-400, which resulted in the screen going black and message: Microsoft Flight Simulator has stopped working; Windows will notify if a fix is available; then back to the desktop ( no fix available notice). I tried running FS9 using varied aircraft, some flew others crashed.Any suggestions appreciated.Intel Quad CPU Q6600@ 2.40GHzNVIDA GeForce 512 8800GT3GB Ram

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It could be one thing or many. So, I'll guess an issue with sound. Suggest ensuring the drivers for your sound card/board are current. I'm sure others will have other suggestions. Good luck.Dave Vega

Share this post


Link to post
Share on other sites

FS9 does not like advanced themes. Even some of the default XP themes give FS9 problems.Make sure you change the Windows Desktop to the Windows Classic theme before starting FS9.Next Item - make sure you have made the following changes to the icon from which you launch FS9 - right click and select properties:Under the compatability tab - select "Run this program in the compatability mode for: Windows XOP (Service Pack 2)"Ensure the Privilege Level for you and all users is set to Run this program as an administrator.Also, where did you install FS9 ?I strongly recommend against installing FS in the Programs Files folder because with Vista Home Premium you don't have full control over that folder even if you are the administrator of the computer.If you haven't installed anything else, I'd recommend you uninstall and reinstall.Also after you have FS9 setup - right click on the FS9 main folder and make sure your ID have Full Control of the folder and all sub-folders and files.FS9 runs just fine on Vista Home Premium, Ultimate and Enterprise that I have setup with User Access Control enabled on all three computers. However, it is setup as I've described above.On Vista I've setup FS9 on a separate physical hard drive - as we've seen in the past helps it work better. But I have FSX setup on the system hard drive because is has been demonstrated to work better in that location.However both are setup in a folder called Microsoft Games which is NOT under a Program Files folder.

Share this post


Link to post
Share on other sites

The changes you recommended as to XP SP2 compatability and ID Full control did the trick; FS9 now runs fine.Thanks for your response; it was most welcome.:)

Share this post


Link to post
Share on other sites

Tried the 'run as win xp compatibility' option and fs9 still not running.Stating 'you are running an incompatible version of DX.Any suggestions now?

Share this post


Link to post
Share on other sites

Hi,I have almost the same computer as you, vid card is different. I am experiencing problems in the windowed mode but it flies fine in the full screen mode. I am having an issue with my CH Pro controllers. I can't get them to program. I am now trying to get them to work with windows drivers and every time I set the controllers up, they revert back to the default switch settings. I have searched for another copy of fs9.cfg and found none anywhere so who's changing my settings? This is strange...

Share this post


Link to post
Share on other sites

Thanks for your responses; Running FS9.exe in XP SP2 compatability mode corrected problem; next to see how Add-Ons I used in FS9 under XP will like VISTA or no !!

Share this post


Link to post
Share on other sites

> next to see how Add-Ons I used in FS9 under XP will like VISTA or no !!Good Lord, this IS getting confusing with all the FSX service packs, the OS service packs (XP SP3 soon to come) and then the to-be-announced add-on SP's to comply with all the other service packs. Not to mention many of us are still using FS9..................:-grnmdRegards, Kendall#1: E6750@3.2GHZ/Coolermaster HyperTX2 Gigabyte P35-DS3L 4GB Crucial Ballistix Tracers PC6400 Seagate 250GB 7200.10 SATA2 Gigabyte X800XT -Cat 6.12's CH Yoke/Pedals/Saitek Throttle Dual Monitor: Dell 2405/1905 #2: Dell 8400 3.2 H.T. 3GB PC4200 Diamond Xtreme/Logitech X-530's

Share this post


Link to post
Share on other sites

One other thing to look at. Santa brought me a new desktop with Home Premium and I had multiple issues and many CTD's at first. Searched everywhere for ideas, tips, etc. and finally found the answer that worked at Flight1's Simforums. This worked for me, your mileage may vary...:-)I have 2 320gb drives and FS9 is on it's own dedicated drive, not C. I accepted FS2004's default install to E:Program FilesMicrosoft GamesFS9. Vista, apparently, treats some or all of the files in any Program Files install as read only, which will cause issues, as you can imagine. When I did a re-install to E:FS9 and changed the permissions on the Properties tab to full control all of my unexplained CTD's have gone away. BTW, I have also turned off UAC.I also re-installed everything that was in Program Files out of PF in their own folder. This is especially important for GE Pro, if you have it, because GE Pro may not do a full write of texture files to FS9 out of the Program Files install and this was causing my CTD's.I know, this means a re-install but in my case it was worth it. More info at Simforums by searching for Vista.Hope this helps...

Share this post


Link to post
Share on other sites

I've had enough time on my hands to experiment with FS9 and FSX on my new Dell system w/Vista SP1. This is what I have found: FS9 is greatly improved over my 3.2GHz P4 and FSX still leaves a lot to be desired. I have SP1 and SP2 installed in FSX and still the sliders must be at 1/2 to get 20FPS or else it's a slide show. I have no addons for FSX except for the Mark Adams' ground scenery fixes. I think that I will stick with FS9. Vista does have a problem handling windows properly as when I switch to FS Nagivator it takes sometimes 3 or 4 tries to get it to come up. Other than that, I have no problems running FS9 with all sliders maxed out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this