Archived

This topic is now archived and is closed to further replies.

DAL488

Out of Memory Error: CURED for me!

Recommended Posts

I'm excited to say that I believe I've cured my OOM errors. I just completed the flight that I always receive an OOM on descent.I use PMDG747, Ultimate Terrain USA v1.30 and the FSG Mesh patch; FSG mesh for the entire world, Ultimate Traffic at 85%, ActiveCamera. (I run ActiveSky and FSCommander on the Client PC using WideFS.)I have all the UT USA settings ON except Bridge and Tunnel Roads and Lights.Solution: boot using the /3GB switch, /userva=2900 (to allow my 8800 GT 512MB drivers to load), and then modify the FS9.exe to allow >2GB Address set.YEAH!!James

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Sorry would you like to explain better?Boot what? Do you mean booting the PC or starting FS9?and where do you put the switches?Tnx in advance

Share this post


Link to post
Share on other sites

I use WinXP; not sure about Vista. The instructions below reference WinXP Pro, but I've done this on WinXP Home.The two steps are below. Remember, you do this at your own risk. Also do searches on this forum for "/3GB switch", "OOM", and "Out of Memory" to learn more. And search google for "/3GB switch" and "/userva" and you'll find the Microsoft tech pages describing this stuff.________________________________________________________________STEP 1 -Here's how to enable the 3GB switch (thanx to Michael Swannick):Adding the 3GB switch is very simple. You first need to locate your machines Boot.ini file which should be located in the root of your main system drive. (Be aware that this file may be hidden and marked as read-only initially.) You will want to open this file in a program such as Notepad to edit it properly.Before adding the 3GB switch though it is important to note that the switch is very picky, and requires that every device and driver on your system be fully WinXP compatible in order to work at all. If anything in the system is not compatible, Windows will not load at all when restarting with the 3GB switch activated. The only way to then remove the switch from the Boot.ini file so that Windows can load is to either mount the drive in another system and manually change the boot.ini file, or reformat the drive and re-install Windows. Both solutions are far from ideal.To safely add the 3GB switch we recommend adding a second instance of the OS in the boot.ini, and add the /3GB switch to that second version.----- default boot.ini without 3GB Switch -----This is what a default boot.ini file will look like. (This may differ from system to system.)timeout=30default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Pro"----- updated boot.ini with 3GB Switch -----This is what the updated version should look like. Notice the /3GB that has been added to the second instance of the OS line.timeout=30default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Pro"multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Pro with /3GB" /3GBAnd if you have a 512MB or greater video card, you'll need to add the /Userva=???? also. I have a 512MB card, and 2900 works for me so:multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Pro with /3GB" /3GB /Userva=2900If you have a 640MB or 768MB card, you'll need to experiment.Once you have updated your boot.ini file accordingly and have saved the changes, simply restart your system for the changes to take affect. When your system reboots you will be given the option to choose either the standard Windows XP version or the 3GB switch enabled Windows XP version. If you choose the 3GB version and it fails to allow Windows to properly load, just restart your system and you will be given the two options once again, where you can then choose the standard Windows XP version to load. Either way, if it works or doesn't, you can then remove whatever line you don't need in the boot.ini file. Alternately, you may wish to leave both settings so that you can choose to boot without the 3GB switch should you ever have problems with drivers installed in the future. The boot loader will default to the first option listed in the file. So you may want to put the /3GB option first. You may also wish to lower the timeout value to something quicker so that you don't have to wait for 30 seconds or press enter with each boot.__________________________________________________________________STEP 2 -Now to modify to the fs9.exe (thanks to Markus and Stu):Try this only if you have at least 2 GByte of RAM and at your own risk.First download the explorer from http://www.ntcore.com/exsuite.phpNext make a copy from fs9.exe. Than start "CFF Explorer" and open the orginal fsx.exe file.Now go to NT Header/File Header and click File Header. Ther you find a button labeld "click here". Click it. And select the mark at "App can handle> 2gb adressest "Save the modified EXE, overwrite the orginal one (You have youre copy saved?)._________________________________________________________________That's it!James

Share this post


Link to post
Share on other sites

Do you need to have more than 2gb memory on your system?

Share this post


Link to post
Share on other sites

Thanks for the easy-to-follow instructions. Here's an update for those using older hardware. I have a X800XL AGP card with 256M, a AMD64 3700 processor with 1G of main system memory, Win XP SP2, and FS9.1 (old setup yes but it still runs my add-on bloated FS9.1 quite well).I followed the above procedure with great success, but with the following modifications. Boot.ini [boot loader]timeout=30default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS[operating systems]multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=AlwaysOffmulti(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Home Edition with 3GB" /fastdetect /NoExecute=AlwaysOff /3GB /Userva=2900I also **modified the FS9 execuatble** per the above procedure, even though I have only 1G of main system memory.The results were amazing. I was thinking of performing the 3GB mod for awhile, but my latest OOM on final (after a long flight ofcourse) spurred me to finally do it. I performed the modifications and repeated the same flight. No OOM. Indeed, after I realized FS9 was not going to crash on final, I started a real torture test. Before this modification, an absolute NO-NO on my setup was approaching a huge problematic (payware add-on) airport in such a way that FS9 was forced to load the scenery details twice (e.g., overflying the airport causing a first detail scenery load, then flying downwind some distance causing the scenery to disappear, and then entering final causing the airport scenery details to load again). With the 3GB modification, I was able to do this with no OOM errors. After the above torture test, I landed the aircraft at said problematic airport and parked it at the gate. I then did something else that also usually causes an OOM after landing at said airport -- I loaded 100% AI and started shifting views (spot, tower, virtual) forcing massive texture loading. Again, FS9 hung in there! The texture loading time at this point had certainly slowed down, but it was still quite usable especially for the end stages of a flight.The only problems I have concern my ATI display device driver. Sometimes when I boot-up, the ATI driver performs a diagnostic test that causes a WinXP crash, but I just re-boot using the normal WinXP configuration, then reboot back into 3GB mode, at which point the ATI driver skips the test, and I'm good to go.I did have a problem with a Cloud9 installer (bglman.dll), but they have a fix for it (I found it easily via Google). Huge thanks to everyone who helped dream up this fix. After so many struggles with OOM errors, this is significant tweak, maybe the tweaks of all tweaks in my book.

Share this post


Link to post
Share on other sites

I too was experiencing occasional OOM errors and tried the above configuration. Cannot say whether or not it cured my OOM problems but after the first flight I found that the settings caused long pauses and stutters, so unless there is something to tweak regarding my particular system guess i'll go back to the original.System:XP HOME(SP3)AsRock 4CoreVSTA C2D 6600E2GB DDR2-5300RADEON X850 256MB AGP

Share this post


Link to post
Share on other sites

Yes, I'm sure mileage will vary. I also get more pausing and stuttering, but at the end of the flight. I can tolerate it however in exchange for getting on the ground without an OOM. I would have thought your system less prone to pauses and stuttering than mine though.Perhaps adjust the Userva number. I'm not sure whether AGP cards even need the Userva parameter (i.e., whether they reserve system memory like PCI express)? I just picked 2900 to back off from 3G a bit, yet still have a high number (more memory available to FS9).Reducing the texture load on FS9 might also help. There are a lot of FS9 config settings to dial down texture here and there without too much quality loss (i.e., you can keep the texture size parameter set to massive). I also use DXT3 clouds textures. If you're seeing a lot of stuttering during taxi and on the takeoff/landing roll as AI aircraft liveries are constantly loaded and reloaded, one of the best tweaks I found was to convert all AI aircraft to DXT1 texture format. The trade-off was slightly worse quality versus much smaller texture size that the simulator can load quickly (less stuttering).

Share this post


Link to post
Share on other sites

Vista is a different animal altogether. There needs to be more folks running Vista therefore more folks tweaking to get an answer for us. I will keep on it and update as I find things. Meanwhile, we wait for the cure.

Share this post


Link to post
Share on other sites

>I just picked 2900>to back off from 3G a bit, yet still have a high number (more>memory available to FS9).I highly recommend stepping back your /userva to 2560 as both Phil Taylor and I recommend... ;)This article has been up at this Wiki for many months now:How to Fix OOM Errorhttp://forums.flightsim.com/fswiki/index.php/OOM_Error

Share this post


Link to post
Share on other sites

Please can you elaborate a little when you say "go to NT Header/File Header and click File Header. Ther you find a button labeld "click here". What is NT etc I cant see anything that resembles 'Header etc" Paul

Share this post


Link to post
Share on other sites

Hi Folks,Please ignore my previous post I was attempting to edit the FS.cfg and not the FS9.exe, which is the one needing editing.Paul

Share this post


Link to post
Share on other sites