Archived

This topic is now archived and is closed to further replies.

JET 1

Unable To Use Fs9 Atc

Recommended Posts

Hi allA strange problem, I don't really know when it started as I often fly without atc or use online services.I am able to open the ATC selection window, but can't select any of the available options. For example I press 1 to tune the radio or contact ATC services, but simply nothing happens.Things already checked:- keyboard physically ok- FS9 key assignments (select option 1-4) ok- atc is not disabled from FSUIPC- ATC sliders ok, pilot voice selected- avionics switch is onAny ideas? I'm stumped :(

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The sounds are all ok. I can even tune the radios manually to listen to ATC, but I can't interact with them at all! The keypresses do nothing even when the options are displayed on the screen.

Share this post


Link to post
Share on other sites
The sounds are all ok. I can even tune the radios manually to listen to ATC, but I can't interact with them at all! The keypresses do nothing even when the options are displayed on the screen.
Have you tried the age old trick of letting FS2004 rebuild a fresh FS9.cfg file ?That often fixes some of the strange things which pop up from time to time.Just rename your FS9.cfg file to FS9.cfg.BAK and restart Fs2004 - a fresh cfg file will be created using all of the default settings. You can then copy and paste any special treaks you may have entered previously and/or reset options from within the sim.Good luck.

Share this post


Link to post
Share on other sites

sounds like you don't have a default voice selected for your own speech. i forget where the option is, but it's probably under ATC settings or something.i had this happen a few times before. Somehow it gets reset with certain 3rd party software installed...hope this helps-feng

Share this post


Link to post
Share on other sites
sounds like you don't have a default voice selected for your own speech. i forget where the option is, but it's probably under ATC settings or something.i had this happen a few times before. Somehow it gets reset with certain 3rd party software installed...hope this helps-feng
Hi FengThanks, but I do have a voice selected, it was one of the first things I checked. Even if it was not selected, I would still be able to use all the ATC functions, just the voice would no be audible.
Have you tried the age old trick of letting FS2004 rebuild a fresh FS9.cfg file ?
HiNope, not yet. That's one of the "hardcore" remedies that I will use after all else fails. Just checking if anyone had other easier ideas.

Share this post


Link to post
Share on other sites
Hi FengThanks, but I do have a voice selected, it was one of the first things I checked. Even if it was not selected, I would still be able to use all the ATC functions, just the voice would no be audible.HiNope, not yet. That's one of the "hardcore" remedies that I will use after all else fails. Just checking if anyone had other easier ideas.
Select default plane. Go to any airport on the runway. That should reset it.I've had this happen a couple times and I never found a way fix it unless I did the above. So I stopped trying to figure out why and just reset the flight.

Share this post


Link to post
Share on other sites

Are you using the numbered keys on the main keyboard or the number pad keys?Bud

Share this post


Link to post
Share on other sites
Are you using the numbered keys on the main keyboard or the number pad keys?
I am using the main keyboard keys.One additional oddity I noticed is that I am able to use functions from key 3 onwards, but 1 and 2 are disabled and for the life of me I can't get them re-enabled!!I've now tried rebuilding the fs9.cfg file - no effect.I have checked and double checked that the assignments for "select 1, select 2..." are correct in the Assignments menu.I don't have anything in the background that could capture those two keystrokes, main key 1 and 2.Reeeally bizarre..

Share this post


Link to post
Share on other sites

Sigh, :( Load default airplane,,,Go to any airport and position yourself at a gate. ATC will work again..

Share this post


Link to post
Share on other sites
Sigh, :( Load default airplane,,,Go to any airport and position yourself at a gate. ATC will work again..
:( B) Ok, to add - I had already tried default flight and no, ATC does not work :( .The position of the aircraft (default Cessna), be it at the gate or at the North pole, has nothing to do with how ATC works, that much I know. It just may have, if the fully default flight is loaded (which happens to be in Seattle) but in this case, no effect.One more thing I tried was moving different non-default .dll files from the Modules folder (including FSUIPC) to a temporary folder one by one, trying the sim between every move, but no effect whatsoever..

Share this post


Link to post
Share on other sites
Hi allA strange problem, I don't really know when it started as I often fly without atc or use online services.I am able to open the ATC selection window, but can't select any of the available options. For example I press 1 to tune the radio or contact ATC services, but simply nothing happens.Things already checked:- keyboard physically ok- FS9 key assignments (select option 1-4) ok- atc is not disabled from FSUIPC- ATC sliders ok, pilot voice selected- avionics switch is onAny ideas? I'm stumped :(
Rather than starting over with a new FS Config, have you tried restoring your key assignments to default with FS9? That has solved a few mysterious problems I've had over time.Bob

Share this post


Link to post
Share on other sites
Rather than starting over with a new FS Config, have you tried restoring your key assignments to default with FS9? That has solved a few mysterious problems I've had over time.
Thanks for your reply. I have already tried rebuilding a whole new fs9.cfg file which of course automatically resets all key assignments. I assume that it has essentially the same effect as pushing the "restore defaults" key in the Assignments menu.

Share this post


Link to post
Share on other sites
:( :( Ok, to add - I had already tried default flight and no, ATC does not work :( .The position of the aircraft (default Cessna), be it at the gate or at the North pole, has nothing to do with how ATC works, that much I know. It just may have, if the fully default flight is loaded (which happens to be in Seattle) but in this case, no effect.One more thing I tried was moving different non-default .dll files from the Modules folder (including FSUIPC) to a temporary folder one by one, trying the sim between every move, but no effect whatsoever..
You did not indicate that you had tried that.I have had the exact same problem, therefore I can speak with knowledge.The steps that I used to fix the issue are as follows.select default plane. Note I did not say default flightgo to any airport, position plane anywhere you want.. no, the position does not matter but you just dont change planes and say, "well that didn't fix it". Did you close the sim from that point?once on the ground and at a gate or the north pole, close the sim.restart the sim.So how about you follow those simple steps, then report back? You'll need to tell us the EXACT steps you have tried. when you ask for troubleshooting help. Thats so we don't waste your time, or ours.You asked for help, I gave you a suggestion as to what fixed the EXACT problem for me. If that doesn't fix it and you don't get any other help, reinstall. and please, if you DO fix it, report back here what you did so others can see in the future.....

Share this post


Link to post
Share on other sites
You did not indicate that you had tried that.I have had the exact same problem, therefore I can speak with knowledge.....
While I do appreciate that you're trying to help, don't make the assumption that I am someone who just started the sim for the first time two weeks ago. Please don't patronize.Perhaps I did the same mistake by assuming you are just someone tossing "random" ideas without a clue of what you're talking about and I apologize. The forums are full or members like that.I have been tinkering with flightsims since '02 and have followed the various flightsim forums equally long. I can therefore honestly say that I have provided a wealth of information and I do have a good understanding of the inner workings of the sim.Now, back to the problem..For starters, I assume you call "default plane" the plane MS chose for the default flight of a vanilla install of FS9 - the C172.Then..1. Open sim and from the aircraft menu select the cessna2. from create flight menu I select "any" airport at "any" gate3. load flight4. noting the aircraft is engines running, battery and avionics on5. open atc window, and note there are two options - 1 tune airfield ground frequency 2 tune atis6. note that pressing keys 1 or 2 have no effect. frequencies do not change7. close sim8. restart sim and start this list from the beginning, no matter what airport I choose, ending at 6 - the ATC does NOT respond to keys 1 and 2Can you please describe the EXACT problem you solved this way?ps. reinstall would of course cure it, but in this case that would be throwing the baby out with bathwater

Share this post


Link to post
Share on other sites