Archived

This topic is now archived and is closed to further replies.

frankla

ITS the TREES Its the TREES. PLEASE HELP!

Recommended Posts

Its the trees I tell you. It is!!!!!In an earlier post, I mentioned that whenever I went on to the gliding missions, I got terrible stutters. It was the trees!! I, now, realize the stutters come whenever I am in places that has a lot of trees. I don't get stutters in terminal areas like LAX or DCA that has lots of building scenery and building autogen. However, if there are lots of trees, I get them. Basically I get frame rates of 25 dropping to 8-10 and back to 25 constantly. When I reduce the autogen density (to no more than normal) the problem is solved. If the trees are giving my pc a hernia, why don't I just get poor frame rates instead of stutters? I hope some of you veterans and geniuses have a solution and can help me out of this never ending forrest.I have my frames locked at 25. If I unlock it, the stutters get worse. I have almost everything maxed out except cloud distance, no light bloom, very low road and airport traffic. I am running the sim at my monitors native resolution of 1920*1200.I have made the following change to my FSX.cfg Texture_Bandwidth_mult= 70. I read that adjusting pool size can fix the stutters. But I can't find a bufferpool section in my fsx.cfg. The following is my brand new system that I just built (my first one, thank you):i920 at 2.66 ghz stock speed (waiting for past to cure to over clock it) with Zalman 9900LED HSFEVGA X58 3SLI6 GB OCZ Gold triple channel 1600 memoryBFG 275 GTX video card with 890mbWD 1TB HD with 32 CacheAntec 650W PSNZXT Tempest Case with 6 FansLG 22X DVD player/writerASUS 24 Inch 1920* 1200 Monitor

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Its the trees I tell you. It is!!!!!In an earlier post, I mentioned that whenever I went on to the gliding missions, I got terrible stutters. It was the trees!! I, now, realize the stutters come whenever I am in places that has a lot of trees. I don't get stutters in terminal areas like LAX or DCA that has lots of building scenery and building autogen. However, if there are lots of trees, I get them. Basically I get frame rates of 25 dropping to 8-10 and back to 25 constantly. When I reduce the autogen density (to no more than normal) the problem is solved. If the trees are giving my pc a hernia, why don't I just get poor frame rates instead of stutters? I hope some of you veterans and geniuses have a solution and can help me out of this never ending forrest.I have my frames locked at 25. If I unlock it, the stutters get worse. I have almost everything maxed out except cloud distance, no light bloom, very low road and airport traffic. I am running the sim at my monitors native resolution of 1920*1200.I have made the following change to my FSX.cfg Texture_Bandwidth_mult= 70. I read that adjusting pool size can fix the stutters. But I can't find a bufferpool section in my fsx.cfg. The following is my brand new system that I just built (my first one, thank you):i920 at 2.66 ghz stock speed (waiting for past to cure to over clock it) with Zalman 9900LED HSFEVGA X58 3SLI6 GB OCZ Gold triple channel 1600 memoryBFG 275 GTX video card with 890mbWD 1TB HD with 32 CacheAntec 650W PSNZXT Tempest Case with 6 FansLG 22X DVD player/writerASUS 24 Inch 1920* 1200 Monitor
I did add the following to my fsx.cfg file (I am not sure if the placement of the line matters):[bufferpools]poolsize=70000000 I didn't see any change :(

Share this post


Link to post
Share on other sites

Hi FranklaWe have a fix for that tree problem coming with GEX Europe but we are not quite ready for release yet. I just checked the sailplane mission for EU and it will fix what you are seeingIn the mean time the primary problem is two areas on your system.. your CPU clock is low and that will affect that tree problembufferpools is subjective to the system if it will work or not.. you must ADD the header and the value to the config.. your config will not have it in the list by defaultAdd it to the bottom of the listTry this:[bufferpools]poolsize=70000000Also try: [bufferpools]poolsize=100000000you will find a complete FSX tuning 'guide' which includes bufferpools and how to set it here: http://www.simforums.com/forums/forum_posts.asp?TID=29041If that bufferpool suggestion I posted above does not help then I suggest you remove the entire entry from the FSX.cfg file... your issue is most likely CPU speed and video card settings at that point and they can not handle the autogen settings with trees. The link I provided also includes settings for Nvidia cards using Nhancer to bypass FSX and allow your card to have full control. I do not usually suggest the use of the autogen restriction lines however as a last resort you can try this.. add it to the FSX.cfg under the heading shown:[TERRAIN] <---- look for this headerTERRAIN_MAX_AUTOGEN_TREES_PER_CELL=3000 <----- add this lineYou may reduce as needed. Try 2500 if 3000 presents no relief I really do not advocate the use of that tweak as I have found it to make the sim stutter strangely however you are welcome to try itAre you frame locking? Make sure to lock frames at 24, 30 or try UNNLIMTED tooThe area you seem to be having problems if this is in the sailplane mission is a combination of the THERMALS and TREES.I think your CPU may be the primary problem here.. most run a 920 at 3.6-4GHz

Share this post


Link to post
Share on other sites
Hi FranklaWe have a fix for that tree problem coming with GEX Europe but we are not quite ready for release yet. I just checked the sailplane mission for EU and it will fix what you are seeingIn the mean time the primary problem is two areas on your system.. your CPU clock is low and that will affect that tree problembufferpools is subjective to the system if it will work or not.. you must ADD the header and the value to the config.. your config will not have it in the list by defaultAdd it to the bottom of the listTry this:[bufferpools]poolsize=70000000Also try: [bufferpools]poolsize=100000000you will find a complete FSX tuning 'guide' which includes bufferpools and how to set it here: http://www.simforums.com/forums/forum_posts.asp?TID=29041If that bufferpool suggestion I posted above does not help then I suggest you remove the entire entry from the FSX.cfg file... your issue is most likely CPU speed and video card settings at that point and they can not handle the autogen settings with trees. The link I provided also includes settings for Nvidia cards using Nhancer to bypass FSX and allow your card to have full control. I do not usually suggest the use of the autogen restriction lines however as a last resort you can try this.. add it to the FSX.cfg under the heading shown:[TERRAIN] <---- look for this headerTERRAIN_MAX_AUTOGEN_TREES_PER_CELL=3000 <----- add this lineYou may reduce as needed. Try 2500 if 3000 presents no relief I really do not advocate the use of that tweak as I have found it to make the sim stutter strangely however you are welcome to try itAre you frame locking? Make sure to lock frames at 24, 30 or try UNNLIMTED tooThe area you seem to be having problems if this is in the sailplane mission is a combination of the THERMALS and TREES.I think your CPU may be the primary problem here.. most run a 920 at 3.6-4GHz
Thank you Nick. Does GEX US have a fix for the tree problem?

Share this post


Link to post
Share on other sites
Thank you Nick. Does GEX US have a fix for the tree problem?
Not at this time however anyone using GEX USCAN who installs the Europe product it will automatically work for USA/CAN/AL as well. We will issue a patch of USCAN users who do not use the Europe product sometime after the EU release. GEX USCAN will provide much relief for the default autogen as a whole and it will increase performance but tree/forest tiles, specifically pines, are still an issue eveywhereI do wish to point out the tree fix we are going to provide does not fix all of the tree perf issues.. there is one very large set of tree tiles used all over the world in the sim we could not manipulate without changing core autogen description files and we did not want to do that forcing the user to use a "Switch" for the product so although the fix will bring relief in many places it will not fix all forest areas. As an example the Missoula Montana area would not get relief from that because the area extensively uses the tree tiles we were not able to edit. Try the suggestion I posted above and see how it works out for you. You can try lowering the tree value to 1800-2000 and then raise the autogen slider

Share this post


Link to post
Share on other sites
Not at this time however anyone using GEX USCAN who installs the Europe product it will automatically work for USA/CAN/AL as well. We will issue a patch of USCAN users who do not use the Europe product sometime after the EU release. GEX USCAN will provide much relief for the default autogen as a whole and it will increase performance but tree/forest tiles, specifically pines, are still an issue eveywhereI do wish to point out the tree fix we are going to provide does not fix all of the tree perf issues.. there is one very large set of tree tiles used all over the world in the sim we could not manipulate without changing core autogen description files and we did not want to do that forcing the user to use a "Switch" for the product so although the fix will bring relief in many places it will not fix all forest areas. As an example the Missoula Montana area would not get relief from that because the area extensively uses the tree tiles we were not able to edit. Try the suggestion I posted above and see how it works out for you. You can try lowering the tree value to 1800-2000 and then raise the autogen slider
Nick you are the glue that holds up the forums. Thank you!

Share this post


Link to post
Share on other sites

I get the same probs near forests, with spikes from trees reaching the SKy, and stutters with high G.Any fix for this will be much appreciated. Without having to use GEX. Feeling a bit broke after PC upgrade.I would use the file autogendescriptions.spb i got it from somewhere on web, and its supposed to reduce the variety of trees in FSX so you get higher FPS, but some posts say not to use this new file with SP1 or SP2.But any ideas about fixing stutters near forests much appreciated.

Share this post


Link to post
Share on other sites

I also get problems near large forests. It doesn't matter (so it seems) where I fly. Right now I am mostly flying above FTX Blue and Gold: I have trees at something like 1200 or so. That's quite low...! And still the autogen slider is at Very dense...! I suppose the GEX fix won't help FTX trees...?Tree problems and autogen popup are my main concerns with FSX...

Share this post


Link to post
Share on other sites

This problem is everywhere - I am flying mostly in Hawaii and you get it there all the time. The reason is a specific texture tile that has no autogen annotations but rather is hardcoded by FSX to depict the maximum allowed number of trees for a given autogen setting. Maxing the autogen out over these forested areas is damn near impossible on any of todays configs. Very dense gets you get by while the dense setting usually eliminates the problem alltogether albeit the look of the forested area will change. I am running FSX on a yet unclocked I7-940 at 3 Ghz and I get no more than 14-18 FPS in these areas with the very dense setting. I usually fly helos at treetop level just skimming the top branches and am reluctant to sacrifice the nice effect tree density gives me - especially using Treex! - to avoid stutters alltogether. It would sure be nice though ... my last wish for FSX besides a proper VFR ATC addon.

Share this post


Link to post
Share on other sites

Well, if you really must have trees when gliding, give either Condor or Silent Wings a try, both very good gliding sims and no problems with frame rates. Silent Wings has one of the best flight models of any sim and although it is pricey, if you want realistic simulated gliding, it's an excellent choice. Condor is more geared toward online competition flying, but still has a very good flight model. Here's a vid of me doing some stunts in Condor with the aerobatic glider (FPS lag is caused by FRAPs incidentally, not Condor):http://www.youtube.com/watch?v=sJnK6wgLjnE...re=channel_pageAl

Share this post


Link to post
Share on other sites
This problem is everywhere - I am flying mostly in Hawaii and you get it there all the time. The reason is a specific texture tile that has no autogen annotations but rather is hardcoded by FSX to depict the maximum allowed number of trees for a given autogen setting. Maxing the autogen out over these forested areas is damn near impossible on any of todays configs. Very dense gets you get by while the dense setting usually eliminates the problem alltogether albeit the look of the forested area will change. I am running FSX on a yet unclocked I7-940 at 3 Ghz and I get no more than 14-18 FPS in these areas with the very dense setting. I usually fly helos at treetop level just skimming the top branches and am reluctant to sacrifice the nice effect tree density gives me - especially using Treex! - to avoid stutters alltogether. It would sure be nice though ... my last wish for FSX besides a proper VFR ATC addon.
Makes you wonder how ACES tested the sim, if everyone has this problem. Again, its not low frame rates, its the massive fluctuation in rates and that should have been "solved"?

Share this post


Link to post
Share on other sites
Makes you wonder how ACES tested the sim, if everyone has this problem. Again, its not low frame rates, its the massive fluctuation in rates and that should have been "solved"?
Have you tried FPS_Limiter and set frames UNLIMITED? I don't have huge swings and have very smooth flight even in forested areas, and I am using those with a bufferpools setting.Noel

Share this post


Link to post
Share on other sites
Have you tried FPS_Limiter and set frames UNLIMITED? I don't have huge swings and have very smooth flight even in forested areas, and I am using those with a bufferpools setting.Noel
Thanks Noel, Did you have the sutters before getting the FPS_limiter? or was yours always smooth?

Share this post


Link to post
Share on other sites
I do wish to point out the tree fix we are going to provide does not fix all of the tree perf issues.. there is one very large set of tree tiles used all over the world in the sim we could not manipulate without changing core autogen description files and we did not want to do that forcing the user to use a "Switch" for the product so although the fix will bring relief in many places it will not fix all forest areas.
Nick, As there will be no further development on FSX coming from ACES and as FSXI is not yet on the radar, Would it not be time for the major scenery developpers to get together and agree on a new common set of core autogen description files which would solve the problem for everyone ?

Share this post


Link to post
Share on other sites
Nick, As there will be no further development on FSX coming from ACES and as FSXI is not yet on the radar, Would it not be time for the major scenery developpers to get together and agree on a new common set of core autogen description files which would solve the problem for everyone ?
Amen to that! :(

Share this post


Link to post
Share on other sites