Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest BigSwede

Out of memory running FSX

Recommended Posts

Guest BigSwede

Hi,I have edit boot.ini as NickN suggested in "Setting up FSX and how to fix it" (/3GB/userva=2560) but I still have problem.It happens when I switch screen for a add-on that are running on the same computer as FSX, I use UltraMon with hot keys.My question are, what number should I try ?Par

Share this post


Link to post
Share on other sites
Hi,I have edit boot.ini as NickN suggested in "Setting up FSX and how to fix it" (/3GB/userva=2560) but I still have problem.It happens when I switch screen for a add-on that are running on the same computer as FSX, I use UltraMon with hot keys.My question are, what number should I try ?Par
Try 3072

Share this post


Link to post
Share on other sites
I have edit boot.ini as NickN suggested in "Setting up FSX and how to fix it" (/3GB/userva=2560) but I still have problem.
Hi, Par;It's just a thought, but are you using FSX SP1 or SP2?

Share this post


Link to post
Share on other sites
Guest BigSwede
Hi, Par;It's just a thought, but are you using FSX SP1 or SP2?
Hi,I have FSX Accelerator installed. Down below are my spec. from Belarc.Windows XP Home Edition Service Pack 3 (build 2600)2,20 gigahertz AMD Athlon 64256 kilobyte primary memory cache2048 kilobyte secondary memory cache64-bit readyNot hyper-threadedBoard: MSI AMETHYST-M 1.0Bus Clock: 200 megahertzBIOS: Phoenix Technologies, LTD 3.47 03/03/20063328 Megabytes Usable Installed Memoryc: (NTFS on drive 0) 1000,19 GB 785,87 GB freed: (NTFS on drive 1) 293,59 GB 129,71 GB freee: (NTFS on drive 6) 160,04 GB 104,51 GB freeNVIDIA GeForce 9600 GT [Display adapter]Samsung S/M 1100p+ [Monitor] (19,7"vis, s/n H3NRB02269, november 2001)Standardbildsk

Share this post


Link to post
Share on other sites
Hi,I have FSX Accelerator installed. Down below are my spec. from Belarc.Windows XP Home Edition Service Pack 3 (build 2600)2,20 gigahertz AMD Athlon 64256 kilobyte primary memory cache2048 kilobyte secondary memory cache64-bit readyNot hyper-threadedBoard: MSI AMETHYST-M 1.0Bus Clock: 200 megahertzBIOS: Phoenix Technologies, LTD 3.47 03/03/20063328 Megabytes Usable Installed Memoryc: (NTFS on drive 0) 1000,19 GB 785,87 GB freed: (NTFS on drive 1) 293,59 GB 129,71 GB freee: (NTFS on drive 6) 160,04 GB 104,51 GB freeNVIDIA GeForce 9600 GT [Display adapter]Samsung S/M 1100p+ [Monitor] (19,7"vis, s/n H3NRB02269, november 2001)Standardbildsk

Share this post


Link to post
Share on other sites
Guest BigSwede
What's your graphics card memory? I assume your Windows XP is the 32bit version. For a 64bit version the rest of the post is of no use, since has no the Virtual Address practical constraints of the 32 bit's.As a rule of thumb I've found somewhere a formula to calculate the memory to be reserved for user VAS (Virtual Address Space):App_VAS (/userva param) = 4096 - 768 - <graphics_card_memory_size> = 3328 - <graphics_card_memory_size>The reasoning after this formula is as follows:- At least 768 MB should be reserved for the kernel code and data.- PCI(express) graphics cards map their memory onto the System VAS- The rest until 4096MB can be reserved for user mode processes (applications)That gives us for:- 256MB Graphics cards -> /userva=3072 (ie, 3GB)- 512MB -> /userva=2816- 768MB -> /userva=2560- 1024MB -> /userva=2304
Hi,Thank's for this usefull info, I test it right now and it seams to run good so fare.Take CarePar

Share this post


Link to post
Share on other sites
Guest sssummer

I have tried all of the tricks, but almost every time I have a flight of 30 minutes or more, I get the dreaded OOM error. I run Vista 32, FSX sp2, and have and i7 core system with 6 GB ram and a 1 gb video card. I think my only option is to go to Vista 64, which means a complete reinstall of everything. Sure dreading this, but I have run out of ideas. Very frustrating.

Share this post


Link to post
Share on other sites
I have tried all of the tricks, but almost every time I have a flight of 30 minutes or more, I get the dreaded OOM error. I run Vista 32, FSX sp2, and have and i7 core system with 6 GB ram and a 1 gb video card. I think my only option is to go to Vista 64, which means a complete reinstall of everything. Sure dreading this, but I have run out of ideas. Very frustrating.
Check out some Vista forums because I think I remember (mind like a sieve) there is a special command to use for memory allocation rather than the /3gb switch.

Share this post


Link to post
Share on other sites
Guest BigSwede
I have tried all of the tricks, but almost every time I have a flight of 30 minutes or more, I get the dreaded OOM error. I run Vista 32, FSX sp2, and have and i7 core system with 6 GB ram and a 1 gb video card. I think my only option is to go to Vista 64, which means a complete reinstall of everything. Sure dreading this, but I have run out of ideas. Very frustrating.
Hi,I follow Palafox advice and it works for me now, but I also visit simviation forum and get this replay from the Guru NickN, maybe it solve the problem you have.... Good luck.---------That information is correct but the numbers presented are not exact.. they are calculated based on subtracting the video memory amout from the base value specified for address space... but those values, although ok as a rule of thumb, are to always required to be that low. If you read what I said about tuning that value in the FSX tuning threadhttp://www.simforums.com/forums/forum_posts.asp?TID=29041you will find I said if OOM's still occur, to DROP the value by 64 until the OOMs cease which is basically the same information as above, except my method tunes it 'exactly'If it works, leave it.. if you wish to tune it to the exact value, go back to 2560 and start by reducing that value by lots of 64 until the OOMs stop. ----------Take Care and Three Green Down (LOL)Par

Share this post


Link to post
Share on other sites
Hi,I follow Palafox advice and it works for me now, but I also visit simviation forum and get this replay from the Guru NickN, maybe it solve the problem you have.... Good luck.---------That information is correct but the numbers presented are not exact.. they are calculated based on subtracting the video memory amout from the base value specified for address space... but those values, although ok as a rule of thumb, are to always required to be that low. If you read what I said about tuning that value in the FSX tuning threadhttp://www.simforums.com/forums/forum_posts.asp?TID=29041you will find I said if OOM's still occur, to DROP the value by 64 until the OOMs cease which is basically the same information as above, except my method tunes it 'exactly'If it works, leave it.. if you wish to tune it to the exact value, go back to 2560 and start by reducing that value by lots of 64 until the OOMs stop.
The "magic" number here is the 768MB reserved for the kernel code and data. This value is somehow arbitrary but AFAIK it falls on the safe side. Please note this value only applies to Windows XP 32 bits running a typical configuration. For another OS version or an unusual configuration, a different value should be used. For example, a server edition (ie Windows 2003 Server) would probably require a higher one. So this formula is merely orientative. As usual, only thru experimenting you'll get the best suited and tuned for you.

Share this post


Link to post
Share on other sites
If it works, leave it.. if you wish to tune it to the exact value, go back to 2560 and start by reducing that value by lots of 64 until the OOMs stop.
I assume you mean increase, not reduce..

Share this post


Link to post
Share on other sites

×
×
  • Create New...