Jump to content

Archived

This topic is now archived and is closed to further replies.

asdf12321

Version of FSX unsuported?

Recommended Posts

Hello everyone.At the end of the installation of my RC4, I got a message saying that my version of FSX is unsupported, that I needed to obtain an update from Microsoft, and that no changes were made to my system. I've got SP2, if that helps.Thanks for any help.

Share this post


Link to post
Share on other sites

Hi,When installing RC4.3 did you select the correct version of Radar Contact to install?All versions of FS are included in the install and the correct choice must be made.Norman Bowman

Share this post


Link to post
Share on other sites

Go into your modules folder and right click on FSUIPC.dll, get its properties, then version. Is it version 4.something? If not, you selected the wrong version for FS.If you have both FS versions then you have to do two separate installs of RC specifying a different folder for each version and then specifying the different paths for each.Also, go into your RC folder and look at the version on the title page of the manual. If it does not say 4.3 get the latest from:http://www.jdtllc.com/documentation.htmAfter you correct your installation and register, update your FSUIPC and makerwys from the links pinned at the forum top. Then start RC and redo the scenery rebuild.See if any of this works out your problem.

Share this post


Link to post
Share on other sites
If you have both FS versions then you have to do two separate installs of RC specifying a different folder for each version and then specifying the different paths for each.
No that's not true Ron. I have both versions of FS but only one install of RC. I have FSUIPC 4.xx in the FSX modules folder and FSUIPC 3.9x in the FS9 modules folder.I click on the same desktop icon to fire up RC and it recognises whichever version of FS is running.When I installed RC I selected the option that included both FS versions and it took care of it.Iain Smith

Share this post


Link to post
Share on other sites

In two folders, right? There are different versions of scenery data. Unless jd made a major overhaul the installer should have made two folders and one has scenery data for FS9 and the other for FSX. These were his posted install instructions before he made the three options available (either or both).I can't think of anything that would cause this except a really old FSUIPC version or the wrong one. I think clarification is needed if the failure occurred on in the start of RC to build the scenery database which occurs after registration and RC is ready to go except for the scenery rebuild. FSX FSUIPC needs at least 4.60 in the modules folder with the pdates to FSX installed. We need to know if the error window is from FUIPC or RC.

No that's not true Ron. I have both versions of FS but only one install of RC. I have FSUIPC 4.xx in the FSX modules folder and FSUIPC 3.9x in the FS9 modules folder.I click on the same desktop icon to fire up RC and it recognises whichever version of FS is running.When I installed RC I selected the option that included both FS versions and it took care of it.Iain Smith

Share this post


Link to post
Share on other sites
In two folders, right? There are different versions of scenery data. Unless jd made a major overhaul the installer should have made two folders and one has scenery data for FS9 and the other for FSX. These were his posted install instructions before he made the three options available (either or both).
Not on my machine. My FS9 & FSX are on my D drive while RC is on the C drive and there is just one rcv4 folder and the usual sub folders (data, script, tutorials & winwood) plus other files, inside. No separate files for FS9 and FSX.Maybe I've got an incorrect install but it works! :( Iain Smith

Share this post


Link to post
Share on other sites

It is still two folders as of 8/2009:http://forum.avsim.net/topic/257358-help-with-dual-install-fs9-and-now-fsx/page__p__1645116__hl__dual+install__fromsearch__1#entry1645116It may be one step now for both installs due to the additional choice.V4.3.3845 CD was the last delivered version and the same AFAIK for the download.

Share this post


Link to post
Share on other sites
It is still two folders as of 8/2009:http://forum.avsim.net/topic/257358-help-with-dual-install-fs9-and-now-fsx/page__p__1645116__hl__dual+install__fromsearch__1#entry1645116It may be one step now for both installs due to the additional choice.V4.3.3845 CD was the last delivered version and the same AFAIK for the download.
Thanks Ron. Yes that's the version I have and although I didn't follow that procedure I'm pretty sure mine works just as well on both sims. I'm off to check it out now and I'll let you know.Iain Smith

Share this post


Link to post
Share on other sites
Hello everyone.At the end of the installation of my RC4, I got a message saying that my version of FSX is unsupported, that I needed to obtain an update from Microsoft, and that no changes were made to my system. I've got SP2, if that helps.Thanks for any help.
that was a message from the fsuipc installer, which i start at the end of the rc install.during the rc install, i ask if you are installing for fs9, fsx, or both fs9 and fsx. depending on your answer, i install rc into 1 of 2 possible folders (rcv4, rcv4x or both if you choose both). i also install fsuipc 3.x and/or 4.x depending on your answer.jd

Share this post


Link to post
Share on other sites

. . . and don't forget to update for each sim after your install FSUIPC from:http://www.schiratti.com/dowson.htmland from the FS9 section on that page MakeRunways 4.41 installing that into both your FSX and FS9 folders (not RC). After installing the latter redo your scenery rebuild by starting RC for each sim supplying the correct path for each sim. There are important scenery priority fixes for RC's scenery database build with version 4.41 or better.You can also try later interim fixes of both utilities after installing the above from:http://forums.simflight.com/viewtopic.php?f=54&t=81475&sid=7e40fc23a644179b053ed77100bd8bd4See the release notes further down on that page.

Share this post


Link to post
Share on other sites
that was a message from the fsuipc installer, which i start at the end of the rc install.during the rc install, i ask if you are installing for fs9, fsx, or both fs9 and fsx. depending on your answer, i install rc into 1 of 2 possible folders (rcv4, rcv4x or both if you choose both). i also install fsuipc 3.x and/or 4.x depending on your answer.jd
Well this is getting more interesting. I have both FS9 and FSX but, as I said in my earlier post, I have only one folder rcv4. However, it works fine with either sim and I can rebuild the scenery db for each and use the appropriate sim's flight plans.So, what might I be missing by only having one folder? Presumably, if it is necessary to have the second folder rcv4x I do an install just selecting FSX?Iain Smith

Share this post


Link to post
Share on other sites

Except for some of the files in the data folder and the batch file created in the RC file I believe they are the same. If you wish to save time just maje a copy of your current RC4 folder and rename it RC4X (or the other way around). In your new folder run RC to redefine your paths to that version of FS and your plan folder. Check in that RC folder editing the file makerwys.bat with notepad. Here's mine for FS9:del .\data\a4.csvh:cd "h:\program files\microsoft games\flight simulator 9"makerwys.execopy r5.csv "H:\rcv4\data\r4.csv"for the correct paths normally set in the install.------------------------------------------------After that edit you can go with a scenery build but starting RC with a shortcut to that folder and also specifying the path to that specific FS version. (I keep ny paths in a text file for easy copy/paste insertion into that dialog.) Be sure you do not start the rc4.exe in your FS9 version folder and then specify on the scenery rebuild the path to FSX or vice versa. If you do you'll get the wrong scenery data in the wrong folder. You can make each shortcut exclusive also by renaming rc4.exe to rc4x.exe.Try that and post if problems.If it doesn't just run the installer for the version you wish to create. If you do that you might have to reload the current FSUIPC.dll and makerwys.exe for that version of FS in its modules folder to insure newer versions were not overwritten with the installer older versions. FSUIPC3.98 and 4.60 are minimal vesions and makerys,exe needs to be at 4.41 or better.

Well this is getting more interesting. I have both FS9 and FSX but, as I said in my earlier post, I have only one folder rcv4. However, it works fine with either sim and I can rebuild the scenery db for each and use the appropriate sim's flight plans.So, what might I be missing by only having one folder? Presumably, if it is necessary to have the second folder rcv4x I do an install just selecting FSX?Iain Smith

Share this post


Link to post
Share on other sites

Tried copying the folder across as you suggested Ron but for some reason this did not work. Having created the desktop icon for the exe in the new folder, clicking on it brought up "Error 53 cannot find file."So, I gave up and did a full install of FSX only and now I have two fully working separate installs of RC for each sim.Again as you suggested I ran the file path for each and did a scenery db update.Thanks for your helpful response.Iain Smith

Share this post


Link to post
Share on other sites

×
×
  • Create New...